Home AOMEI Products Support

Backupper doesn't work following Windows 10 update KB3116900 - Error code 4104

I have used Backupper Standard for several months with no problems. Starting a couple of days ago it no longer works. It will complete a backup (Disk image of System) but at the validation pass it stops and gives the message:

"Information Code: 4104

Invalid image file. This file may be not complete or has been damaged or it does not match with the current software version."

I have uninstalled backupper and reinstalled from a fresh download but have received the same result. I have tried both Disk image and System backups but have still received the same error. I have used windows tools to verify the condition of my primary hard drive and my external backup drive. The backup is aslightle over 110GB and there is over 1.2TB available on the backup drive. I have shut down, disconnected, and restarted and reconnected the external drive and retried the backups with the same results.

Any help will be greatly appreciated!


  • Have you tried to check your image manually to see if the same information still comes out?

  • Using the explore image tool in the utilities tab seems to work and the data in the backup file seems to be ok and accessibile. However, using the check image tool yeilds the following message:

     "Checking private structures...

    Checking backup data...

    The program has detected some mistakes in the backup file, so we suggest you:

    1. Delete the backup file, and re-create a backup to make up the mistakes.

    2. Try to browse the backup file by clicking "Utilities" -> "Explore Image" to as far as possible retrieve data. And through this way, you could copy files in this image file and paste other location.

    Information Code:4104

    Invalid image file. This file may be not complete or has been damaged, or it does not match with the current software version."

    I cannot confirm the total contents of the backup manually but what I can see appears correct and I got no errors trying to look at the files.

    Thank you for looking into this problem.

  • Maybe you can try to restore the Image files to other locations to see if there is any problem.

  • I don't know how to do that. Is there a reference I can look at to guide me in that? Thanks.

    I have looked into a couple of log files and they start out as follows:


    AOMEI Backupper 3.2.0 log is as follows:

    ====================== System Information ======================
    Module Path: C:\Program Files (x86)\AOMEI Backupper\Backupper.exe
    Product Name: Windows 10 Pro (6.2.9200.2)
    Service Package:
    OS Version: 6.3
    Total Memory: 15284 MB
    Available Memory: 12656 MB
    System Root: C:\WINDOWS
    Processor Architecture: AMD64
    Processor Number: 4
    Current Time: 2015-12-10 23:19:31

    [0       ]::GetFileAttributesA(sCurPath) != INVALID_FILE_ATTRIBUTES return code: 0x00000000, NetworkMgr.cpp(208).
    [2       ]::GetFileAttributesA(sCurPath) != INVALID_FILE_ATTRIBUTES return code: 0x00000000, NetworkMgr.cpp(208).
    diskinfo.h(451): Failed to init GPT style table.
    [2       ]dyndisk.cpp(213): Failed to RegQueryValueEx on GetSysDgGuid.
    [0       ]ldmio.cpp(89): No dynamic disks are found.

    //////////////////////////////Dump Information////////////////////////////

    Dump Disk:
    Disk Index Total Sector  Geometry   Product Name
    ---------- ------------  --------   ------------
    0  1953525168 (931.51GB) (121601,255,63)   ST1000DM003-1ER162 (Basic Disk,GPT)
    1  3906963456 (1862.99GB) (243197,255,63)   WD      My Book 1140     (Basic Disk,MBR,Sig: 21365)

    Dump Volume:
    ID Volume File System Total Sector  Used Sector  Free Sector  Type  Status    Cluster Size Volume Label
    -- ------ ----------- ------------  -----------  -----------  ----  ------    ------------ ------------

    0.0 *: NTFS         2047999    (1000.00MB) 745824     (364.17MB) 1302175    (635.83MB) Primary    Ok                    8  WINRE_DRV
    0.1 *: FAT32        532480     (260.00MB) 65984      (32.22MB) 466496     (227.78MB) Primary    Ok,Sys                8  SYSTEM_DRV
    0.2 *: FAT32        1024000    (500.00MB) 573928     (280.24MB) 450072     (219.76MB) Primary    Ok                    8  LRS_ESP   
    0.3 *: Unformatted  262144     (128.00MB) 0          (0KB) 262144     (OKB) Primary    Ok                    0  
    0.4 C: NTFS         1898455039 (905.25GB) 228182208  (108.81GB) 1670272831 (796.45GB) Primary    Ok,Boot               8  Windows8_OS
    0.5 *: NTFS         51199999   (24.41GB) 22920296   (10.93GB) 28279703   (13.48GB) Primary    Ok                    8  PBR_DRV
    1.0 E: NTFS         3906957311 (1862.98GB) 1689177440 (805.46GB) 2217779871 (1057.52GB) Primary    Ok                    8  My Book


    I don't know if any of that gives any clue to my problem. I wonder about the part that says there is an unformatted partition -- I cannot see it in the Windows Disk Manager.

  • edited December 2015

    unformatted is MSR, this is right, and it is not visible in Disk Management, but in diskpart from the command shell.

    What wonders me that it reads Windows10 Pro, but version is 6.2.9200 . Which means Wiindows 8. And OS version is 6.3: which means Windows 8.1.

    You could try a file backup, just to see if that works. You wrote that disk backup and system backup do not work properly. If the issue is at the OS level, then file backup should work properly. If it is at the backup image level, file backup would fail.

    KB3116900 should not contain things that might understandably interfere with backup needs.It is security updates and Edge update. You might also consider uninstalling update KB3116900, just to see, from the new Control Panel, section Update History (as I recall)

  • Actually I installed KB3116900, and after that checked an existing image,

     and then did a system backup with checking (on an UEFI 64bit Windows 10 Pro virtual system): all green.

    I do not really believe the issue is on Backupper, but I believe it is firstly on your computer.Try this with admin privilege:

      dism /online /cleanup-image /restorehealth

    and Google for exact instructions. dism is a built-in Windows command.

Sign In or Register to comment.