Home AOMEI Products Support

[Backupper] Restored drive has no access to recovery partition

I have tried twice now, and both time Backupper Standard 2.8 has lost access to the HP recovery partition. With this HP laptop one presses F11 to access Recovery, but it will not work on a disk restored from a Backupper disk image. It works perfectly on the original drive. 

In addition, I had to repair the Vista boot on the new disk. That's an annoyance, but thankfully I had a repair disk. But the loss of the recovery partition is much more significant and concerning.


  • Did you copy the entire disk, disk-to-disk?  Were the disks of the same size?  If not, there may have been some repositioning of the data on the drive.  If you had to repair the boot sector, that seems like indication that you copied partitions and not the entire disk.  Are all the partitions still present on the copy?  The Recovery partition should be a "hidden" partition.  I had a similar problem, since I had made the recovery partition visible so I could check the disk integrity.  Then using it as a Recovery partition would not work until I hid the partition again!

    The other possibility is that the program might look for the partition to start at a particular sector of the drive.  If the drive is not an exact copy, it's possible it won't be able to find the Recovery position because of that.  I found that at least it had to be hidden.

  • I backed up the Disk to a file. Yes, both are 160gb. Did not edit partitions. Both partitions there, and recovery is at end of drive, so should occupy same start sector. HP does not hide their recovery partitions for some reason. I'm sure the bios does look for a particular sector for the recovery boot manager. Not sure why it's not finding it.

  • Sorry for that. Aomei backupper has this problem. The software can't restore the recovery partition completely. We will improve it in the later version. You can use Aomei Onekey Recovery (free) to create a Recovery Partition.


  • Thanks for that information. I had no idea that this was the case. This is a critical deficiency in my estimation, and I can only hope this has top priority.

    I'm confused about OneKey Recovery. It says it creates a "factory recovery partition", but my sense is that it actually creates a user recovery partition of the current, not factory, installation. I would appreciate clarification on that.

    The concept of easily creating a separate backup partition of the current install and making it accessible via a boot hotkey is excellent. The problem is that sometimes disk space may be a problem. The Vista machine that is the subject of this thread has a 160gb drive, of which 9gb is factory recovery. I backed up the completed Windows install, with user data, and the Backupper file was almost 60gb. So replacing the FRP with a OneKey partition would take 60 - 9, or 51gb of disk space, unless extraordinary compression is used. Am I understanding all this correctly?

  • Paul--

    >"It says it creates a "factory recovery partition", but my sense is that it actually creates a user recovery partition of the current, not factory, installation."<

    I hope you do get an answer to your questions.  The description of the "Onekey Recovery" is nothing if not vague about what this "Factory recovery partition" actually is.  I don't see how it could be a true factory partition.  Sounds to me like it is just a backup of the drive at the current time, with a couple of added features like putting backup of the OS in it's current state on a separate partition instead of a file, and including a simple key combination to call up the restore (which sounds dangerous, actually!)  Maybe it doesn't include the user data, but I don't see how that could be done very effectively.  Normally, such a backup would not be made to the same HDD.  You want it on another disk in case your drive goes down.

  • Has this ever been solved?  When I create a disk image with a factor restore partition the restore partition is created but the system no longer recongnizes it in the BIOS.  A disk image seems a bit misleading if this doesn't capture the factory restore partition properly.  

  • Sorry, we don't solve the problem at present.

Sign In or Register to comment.