****HELP : SURFACE PRO 3 + AOEMEI BACKUPPER USB Bootable Media (Windows PE)

Hi guys,

first of all I looooove AOMEI Backupper : THANX SO MUCH FOR YOUR GREAT WORK !

Aomei works fine, quick and easy, when launched in windows (for me) + accepts dynamics disks (I love it!) and restoring a System Image. THANX.

Nevertheless, recently I got a Microsoft Surface Pro 3... and here starts my problems :
it's just impossible (for me) to start from the USB Bootable Media I made previously (Windows PE) with Aomei Backupper! 

Help?! Cause my SP3 won't accept or recognize it.

Here is what I tried :

1. - Inserting a USB recovery drive into the USB port on your Surface.

             Then pressing and holding the volume-down button.

             Then pressing and releasing the power button.

             Then release the volume-down button, so that my Surface Pro 3 will force the start on my USB drive.


2. - Then I search on the web (a lot !) and tried Disabling the UEFI Secure Boot (On my Surface Pro 3 with Windows 8.1)

               So as to access the Advanced Boot Options 

               Then selecting TroubleShoot > etc > Restore image disk ... or...  USB recovery (another time)

      ---> WON'T WORK NEITHER : ERROR MESSAGE JOIN TO THIS MAIL in both cases/menu selections

So anyone has an idea, please, or THE solution... for my SP3 to accept the Aomei USB Bootable Media I made , and then the image disk ?

NB1: I didn't find any answers on this forum --> that's why I'm posting (sorry if I missed it)

NB2: hopefully you understand my concerns and english.... cause it's not as good as I wish.... ---> I'm French   ;o)

NB3: I put the USB Stick in the Native Surface Pro 3 USB slot. My hard drive with the Image Disk is connected to the docking station.

Thanx for help

>vincent. b .


PS. SEE the join ERROR MESSAGE my SP3 delivers



Sign In or Register to comment.