AOMEI STILL not ready for use, several issues

edited February 2015 in AOMEI Products Support

The recent update to 2.2 is a step forward but AOMEI still has
some show stopping bugs.


When creating UEFI bootable media it is NOT putting the correct efi
files in the ISO image, UEFI booting to the boot media is not
possible unless you manually insert the \efi\boot\bootx64.efi file
into the image.


When trying to restore a UEFI image to a disk that is a MBR
disk, AOMEI will still NOT correctly convert the disk to GPT. 
Booting is not possible from a recovery.  Granted this may be an
issue to few users but someone, sometime is going to inherit a disk
that was MBR and want to restore their backup to it.  Even Free
Partition Manager will not convert it.  Windows will nt covert
it if it has any data on it.  The only solution is to delete all
partitions and then use Windows drive management to convert it - THEN
- restore the image. 


I can't seem to register a brand new installation of AOMEI PRO
onto a fresh Windows 8.1 64 bit UEFI system.  I can install the
previous version but it will NOT accept the license code.  It
says INVALID CODE. I installed it to a WIn 7 64 with no issue.


Apparently when you put the AOMEI Standard (perhaps PRO too but
read above) it DISABLES the "Time to display recovery options
when needed" in the Windows Startup and Recovery settings. 
This is truly bizarre.


I am a tech in a Fortune 1000 company, we are looking for a well
priced backup to use world wide.  I was excited about AOMEI but
these stupid bus just keep cropping up. We might just buy a bunch of
Tech licenses if AOMEI ever gets these bugs fixed. As it stands no ther eis no way I can recommend this product.


When is this stuff going to be fixed?

Comments

  • You can try my aomei pebuilder. Just d/l the zip, extract the files, then run as admin on the .cmd file.


    Windows 7 pe builder - supports both bit versions:

    https://www.dropbox.com/s/lz0j0z4g3xlhfv5/AOMEI-7PE.zip?dl=0


  • This still does not fix the issue of the product failing to convert MBR disks to GPT.  While I know the difference and can fix the issue, most other "normal" users cannot. Someone, somewhere is going to take a HDD that was previosly used for MBR and try and upgrade their system to it by restoring a UEFI system to it.  And get an unbootable system.


    I have tested other vendors utilities and they WILL convert the disk properly.


    In my case the PE builder won't build a relaible PE ISO for me, it halts at every boot.  I have a Dell Inspiron 7000 laptop with Windows 8.1 UEFI. I've tried the builds on several machines, even WIndows 7 machines. The PE ISO will work on some and halt on others.


    As for the missing UEFI boot file - the proper boot file SHOULD be included in the BackUpper ISO in the first place, you are even prompted to select beween MBR and UEFI when creating bootable recovery media.

  • It looks like you are having the same issue with PE Builder as I am.  Mine also halts at every boot.  Like you I am looking for a reliable product.


  • Please note that PE Builder only supports running in English language operating system currently. If you are running English operating system but still can't boot, please provide us with the iso file so that we can analyze the problem.

  • The PE Builder IS halting is the least of my worries, what is really bad is the missing EFI files in the recovery media built by the AOMEI app itself.  That and the failure of AOMEI to properly covert a HDD that was previously used as MBR to GPT.  


    These are two pretty bad defects and need to be addressed sooner than later.

  • In fact, our software would add the efi files automatically when creating the iso image.But you created the recovery madia,it may add failed. I have forwarded the issue to our dev team.If you would like to provide us with your iso image(without adding efi files),it will help our developers analyze the issue fast.

    Also, you can use our another software(AOMEI Partition Assistant) to convert mbr disk to GPT without lost data.

  • edited February 2015

    OK, I have an ISO for you.  How can I get the ISO to you?  I have no way of transferring a 205 mb file via email.


    I took a PC, put  FRESH install of Windows 7 64 bit on it using UEFI boot media.  Verified the system booted UEFI to Windows, installed Windows SP1.  Installed AOMEI PRO 2.2.0 and tried to register it.  For some reason I always get an INVALID CODE when trying to register it, the same code will register 2.0.2 just fine.  So I skipped the registration.


    I then went to UTILITIES -> CREATE BOOTABLE MEDIA -> WINDOWS PE ->  BASED ON UEFI (RECOMMENDED) and created the ISO.  The EFI folder is present but the BOOT folder under it is not, and the BOOTX64.EFI  is of course not there. And it will not boot to UEFI mode. I can pull the file out of a WIndows install ISO and copy then to the AMPE.ISO file but the Media Builder should do this correctly by itself.


    EDIT:  The new 2.5 beta does the same thing.  No BOOTX64.EFI
    file when building recovery media.

  • Rootman,


    Maybe you can upload the iso file to your cloud storage then share it to us. About registration, you can send me your code in private, I can help to check the code for you. 

  • edited February 2015

    a) regarding convert MBR to GPT issue, I found this:

    I had to manually use diskpart "convert GPT", then restart the ampe boot cd and after that recover disk worked to bootable system.

    Without these steps ampe wanted to recover to MBR. (backup was from GPT this is understood).


    b) I too find that PartAssist boot cd does not contain BOOTX64.EFI and BOOTMGR.efi and I don't know how to inject my self, and don't want to know.

    It does not matter PartAssist Boot CD created on win81-32bitMBR or win81-64bituefi. .iso was different but always without these files. surprisingly simple AMPE.iso contained the files and booted.


    (Solution is however to use PartAssist from within the running Windows, or even use DiskManagement and DiskPart withing running Windows)

  • Peter, that's the solution I used as well.  While it works it should NOT happen this way, the AMPE recovery disk should convert a disk to the correct boot type automatically and on it's own. I use another manufacturers product and it does this, it even restores UEFI if booted to under MBR recovery media and converts a disk on its own if it's of a contrary type all by itself. So it IS possible for a backup / restore utility to do it correctly.


    AOMEI is attractivly priced and I would really like to get a few Tech licenses for my company.  What I don't want to do however is have to remember that AOMEI fails to put the proper UEFI files in it's rescue media when created and have to insert them manually every time an update to AOMEI happens and we update the recovery media.  Nor do I want to have to remind some idiot tech of mine that a spare MBR disk that he dug up to replace a dud in a UEFI booted system must be coverted manually prior to a system restore. 


    We use THICK images for our systems so that retoration is quick.  We have perhaps half a dozen image types, each one setup with all our company software and settings and everytime there is a lot of MS updates or software updates the entire image is backed up and used for the next PC that needs to be imaged. Most are 32 bit Windows OS images booted MBR but we are getting more and more UEFI booted systems, and some are occasionally converted from MBR to UEFI when a select system is changed from 32 to 64 bit when the need arises.


Sign In or Register to comment.