Automatic rescheduling of failed backups

edited November 2014 in AOMEI Products Support

In AOMEI Backupper Standard 2.0.3, if the computer is not on when a backup is scheduled, or if a scheduled backup fails for any reason, Backupper simply skips that session.  It isn't an effective backup program for computers that aren't always turned on.  Backup programs should automatically attempt to rerun failed sessions (hourly and/or for a certain number of times) until successful.  Last June someone mentioned a fix for the problem was in the works.  When do you expect that improvement to be available?

Backupper is an outstanding product.  Thank you for developing and supporting it.




  • Another possible solution - atleast in Backupper Server 2.0.2 - is that when scheduling a backup task, under "Advanced Settings", if you remove the checkbox  for "Use Windows Task Scheduler", then Backupper has the feature that it would on its own wake up the program at scheduled times and undertake the backup - BUT PROVIDED one is logged into the machine.


    In relation to this same feature - when you uncheck the "Use Windows Task Scheduler" option, another selectable checkbox become visible - which is what you want - it allows you to select that "Run missed backup at next system startup".


    Hope this helps.

  •     Thank you.  Those were useful comments ganon11000 and ndel.  They did help.  I had already considered manually editing the task in Task Scheduler, but that really shouldn't be neccessary.  That's kind of like using a stick to check how much gas is in your car.  It should have a fuel gauge.

       I think "Run missed backup at next system startup" is the key.  I hadn't noticed that option since I used Task Scheduler.  I'll find out if it solves the problem next week.





  • It's been a couple weeks and it looks like the "run missed backup" setting was exactly what I needed.  No more missed backups.  Thanks.  That makes my life a lot easier. 

Sign In or Register to comment.