Home AOMEI Products Support

Huge backup file and corrupt sectors?


short question that bothers me for a long time: If I have a 6 TB harddrive and make a full backup, so that for example a 4 TB backup file will be created, what if one bad sector that can't be read appears in that single file that is 66% (4 TB) of my harddrive? Will the whole backup be currupted? That drive already has 31 pending sectors. There were a few single files in the past that can't be read and had to be replaced from other places. 

Many thanks in advance for your reply,


  • I believe that if you attempted to create a disk backup and encountered a file that you were unable to read the backup would be unsuccessful and fail.
  • Thanks for your reply. The backup was already created succesful. If I already have 31 replaced sectors and get another one in that one, huge file (66% of the hdd) it would probably be better to use folder synchronisation so that I can still access 99,99% of the files? I mean, I would prefere to loose one out of a thousand files instead of loosing a whole backup from one single file.

    But now, there is another problem. When I try to verify the previous succesful created backup file (3,7 TB) I get the following error:


    After that my pc crashed  with a bluescreen at the exact time, when the scedule for the incremental backup should start.


    There is definatelly something wrong. Any ideas what could help?
  • edited December 2020
    I forgot to mention, that I already did a full chkdsk run on that backup drive before the backup. Te result were 18 replaced sectors. I am using AOMEI Backupper Professional 6.1.0.

  • @Loam, As for the crash with a bluescreen at backup time, please upgrade to v6.2. We have optimized the problem in the new version. Please download the latest version from here:
    As for 4102 error, where did you save the backup? Please try to browse and select the image file manually to check.
    As for bad sectors, if the disk you want to back up has bad sectors, generally, AOMEI Backupper will skip the bad sectors to backup. That's to say, it doesn't back up the data in bad sectors.
  • Hello, thanks for your reply. I will reply shortly. I have to test some things that you recommended. So far, the new version works with schedule but the backup verification is still corrupt. I will tell you more soon. Many thanks.
  • edited December 2020

    So, here we go. As stated, the schedule for incremental backup works good now with the new version.

    "As for 4102 error, where did you save the backup? Please try to browse and select the image file manually to check."

    I can also open the backup files with windows explorer by double click and mount the three hard drives, browse them in explorer and copy files.

    I have :
    C : with system SSD on Windows 10
    D : 6 TB harddrive for my files
    E : also 6 TB as my backup drive

    C and D are backed up on E as a full harddrive backup with daily incremental backups.

    The hardware is:
    C : Samsung SSD 840 EVO 1TB
    D : Western Digital WD Red 6TB WD60EFRX
    E : Western Digital WD Red 6TB WD60EFRX

    If I click on tools-> verify backup, I still geht the error after about 5-10 minutes with 0% running the verification. It takes a bit longer with the first incremental backup after the full backup.

    It's still the same error I get: https://imgur.com/6cl2BhZ

    Thanks for your help!
  • @Loam,
    Could you send us the log folder under the installation directory of AOMEI Backupper so that we check?
  • @admin

    Yes, please check pm for the download link. Thanks

  • @admin
    One more thing I noticed: The incremental backup takes extremely long. The last schedule was yesterday. Now another backup startet 1,5 hours ago and has 20%. Since the last incremental backup yesterday I did not really work on my computer, just browsing, mails etc. It is going to take around seven (!) hours again, like yesterday.
  • @Loam "please check pm for the download link."---We don't see the link.
    "The incremental backup takes extremely long."---Could you try to create two backup tasks to back up C and D Separately?Aftet that, please check if the incremental backup still takes a long time.
  • @admin
    I did send it again (click on your name, click on message).

    ok, I will try that. If one backup (schedule) is working on a backup and the next one wants to start, I guess it gets paused and put to queue.

    It will take some time (4 TB). I start the incremental backup tomorrow morning and tell you about it.

  • Yesterday I made two new backups with different schedule for C and D. That worked well and took around 7 hours for 4TB. I tried to verify the new C and D backup again and it stopped 2x with the error codes 4102 after round about 10% for C and around 5+%  for D some point over night.

    I also did the incremental backup for both schedules start again today and it took again 7 houres. 30-60 minutes for C and the rest of the time for D.

    Surprisingly I checked with crystaldisk again and the pending sector count did change from 31 to 34 to 11. When I checked today it went up again to 16.

    I reuploaded the new logs including the new results, please check pm (or maybe hand out your e-mail or other option to me if it does not work). Many thanks.
  • I suggest you to make several partitions, replace all your datas and make futurely multiple backups (every partition).... easy, fast, safe, any trouble with portable and restore!!

    I would never backup such huge "partition" in one file. Too big, can be broken, too much time backup / restore and so on....
  • edited December 2020


    There is definitely something going wrong. I am using backup software for ages and neither there should be read error when verified nor take seven hours for incremental backups for 4 TB. The ETA was around 10-40 minutes normally for an incremental backup. 7 hours is like making a full backup every time. We just need to figure out if it comes from a bug, my hardware or the way the backup works.

    But besides that I understand your point. You suggest not to backup everything. The problem here is that I change files everywhere now and then. The time, as described above, would be the same. It doesn't matter if I backup 1x4 TB or 8x0,5 TB with single partitions. I don't really care about a full backup taking a long time but the incremental backup should be way faster. Also, it's so important to verify backups regularly to check for integrity. Maybe folder synchronization is faster. I will probably check that later but first wait for admin to reply.

    And yes, maybe a huge file is a problem. That was my question from the first post. If sectors get faulty, maybe the whole file is corrupt? I don't know.

  • I change even files and folders overall partitions. Therefor I have separate my drive (4TB) into several partitions.

    Faulty sectors should be checked by software and repaired or marked at first a backup runs. You can use Windows own tools or a special tool from the hard drive manufacture.

    Anyway, here my suggestion:
    Use a second drive. Backup all datas you need. Plug in the new drive and install the system newly. During the installation create only a partition for the system at about 100GB and complete the installation. After the restart you will be able to create all other partitions you need, name them and copy back your datas to each partition. It takes time, but you will be more save. Afterwards you install Backupper, create a job for each partition ( I use only full backup!), schedule them (my runs every Sunday morning), store them local and be happy. Getting more safe, you should migrate all your backup files to an ext. drive (NAS, USB-drive....) directly after the backup has been completed (forthat I use pre/post with batches). So, my backup will be stored on 3 different drives. Don´t forget to create a WinPE rescue media (CD/DVD or USB). If you are finally out of trouble, you have time to check the old drive in detail for further use.

    If you have any questions don´t hesitate to contact me :-)

    Below you will find an example. I use AOMEI Backupper Workstation and Partition Assistant for all my tasks!!

  • @Loam, Yes, we see the link. But, we can't download it. When we open the link, it shows that the server encountered a temporary error and could not complete your request. Please check if the link is damaged. Or, could you contact us via email and zip the log folder, and send it attachment.
  • @admin
    Yes, Google drive seems to have problems. The link was working before, dunno. E-mail should be ready.
  • @Loam, Sorry that we forget to attach the email address. Please zip the log folder and then send it to [email protected]
  • @admin
    Somehow I got an E-Mail from AOMEI first that I did reply with the logs attached. It's all good.
Sign In or Register to comment.