Home AOMEI Products Support

Backup Scheme Not Working - Continues To Keep All Backup Jobs Instead Of Space Managing

I'm using a full backup scheme on my system with the retained number of backups set to 2. However, AOMEI Backupper seems to ignore that setting and just keep every backup job until there is no more disk space and jobs begin to fail. I'm using v6.2.0 and this has been a problem with every version since I first started using AOMEI in 2016.

In past versions the scheme would sometimes work, sometimes fail, but in the end it was up to me to keep checking to make sure my backup drives weren't getting overfilled with numerous backups. Now, this version seems to completely ignore the "number of backups" limitation I set via schemes so I have to manually clean up the extra backups every couple of weeks or so.

I get no errors, no warnings, no popups explaining something went wrong - just failed backups due to lack of space because schemes don't seem to work properly. 


  • When I started using this scheme it never worked for me unfortunately. Always sending emails asking if such a problem has been solved since 12/09/2018 23:57, kamlee replied.
    It looks like some of the best backup schemes Aomei has, but unfortunately it doesn't work.
  • I have the switch, enable backup scheme, switched to the on position and I selected the Full Backup Scheme.  Then I set the software to retain 3 backup copies and for my purposes it seems to work okay. 

    Now if you employ a different scheme I am not sure exactly how the software decides which files to keep and which ones to delete. 
  • @vbbritt that's the exact same setting I have for my system drive backup scheme - full backup, 3 copies max, enable scheme switched on. It doesn't work any more and at best it only worked occasionally, failing at random and filling my drives with a bunch of backups.

    I also have 3 other drives I backup using schemes and none of them limit the number no matter the setting. They seem to have finally fixed the BSOD/lost backups issue, now they need to fix the scheme not working consistently, if at all.

  • @Thogar, Could you offer the log folder under C:\Program Files (x86)\AOMEI\AOMEI Backupper 6.2.0 and task2.2.xml file under C:\ProgramData\AomeiBR so that we check the problem? Please note that ProgramData is a hidden folder. You need to show hidden files/folders under Folder Options.
  • Sure. How would you like them sent? And do you want the entirety of the log folder compressed into a zip or rar file?
  • @Thogar, Yes, please zip the log folder and then send it to us. And, please also send us the task2.2.xml file.
    You can send them to our support email.
  • @admin, as I stated earlier the backup scheme appears to be working fine for me on my main machine.  However, on one of my other machines it is not.  I don't know if this will help identify the problem, but I changed the name of the backup on the machine that is failing.  The scheduled backup is backing up just fine, but it is not removing any of the old backups.
  • @Vbbritt, " I changed the name of the backup on the machine that is failing"---Did you mean that you modify the name of the backup task?
    Could you also send us the log folder and task2.2.xml file?
  • @Admin, yes I had previously changed the name of the backup task.  Unfortunately, after I discovered that the software wasn't removing the backup tasks I erased everything and started over so I am unable to supply you with the information you requested.  Should I see this behavior again I will let you know.
  • You don't have to test anything, it just doesn't work.
  • @Thogar: I´m not sure if this will help you. But since a few years I use pre/post batches to control the number of my backup files (only full backup from every partition on both computers) and copy them afterwards to my NAS. Maybe this could be a benefit for you. In my case these construct works perfectly.

    But you´re right, AOMEI should fix it anyway.
Sign In or Register to comment.