Home AOMEI Products Support

Best way to clone an SSD with 2 partitions, one system and one data partition

As the topic suggests, what is the best method using AOMEI Backupper Pro to clone an SSD disk consisting of one Windows 10 system partition and one data partition? Would the best option be to use the Clone Disk option or should I rather use the Clone System option and then restore the data partition separately?

I currently have a 500 GB SSD which I'll replace with a 1 TB SSD. I have 2 partitions on the SSD, a 100 GB system partition for Windows 10 and a 400 GB data partition. The SSD is an M.2 drive and the new one will be an M.2 drive as well.

My goal obviously is to make the process as smooth as possible. As for the size of the partitions, my plan is to keep the system partition size 100 GB also on the new disk and add the additional space on the new drive to the data partition.

Many thanks in advance for your advice.


  • Hi WebMaximus, you can use Disk clone, which will clone all partitions on the disk. If you only want to clone system partitions, please use system clone. 
    When you do the disk clone, you can select "Edit Partitions", then select "Manually adjust partition size" to add additional space.
    As for disk clone, please refer to here: https://www.ubackup.com/help/disk-clone.html
  • Thanks, was able to successfully clone the disk using 4.0.6
  • I actually noticed one weird thing now after cloning the disk. Some of my programs ask for allowance to pass through the firewall. Even when I already allowed them a very long time ago.

    Today I realized the reason why I'm asked again when I was checking the Windows Firewall rules. For whatever reason, Windows Firewall refers to one of the partitions on the new disk as D:0 rather than F: which is the correct letter for this partition. And it looks OK elsewhere, such as in Windows Explorer, Windows Disk Management etc. So I really don't know where this D:0 comes from but what I do know is it started after cloning my disk.

    Would very much appreciate some advice how to make Windows correctly name this partition again.
  • Can't you change the drive letter in disk management?
  • As mentioned in my last post, the drive letter is already correct in Disk Management.
  • @WebMaximus, Is there D:drive on the original disk you clone from? It becomes F: drive on the cloned disk?
    Maybe you can change the drive letter from F to D via windows disk management.
  • No, there wasn't a partition assigned the letter D on the original disk. The original disks had 2 partitions, one assigned the letter C and one assigned the letter F. The C partition was of course my Windows/system partition where the F partition was a partition for various games etc.

    Now looking at the new disk which is a clone of the original disk, I still have the correct C and F partitions. The issue is that for whatever reason, in the Windows Firewall, the F partition isn't named F but instead D:0. Meaning, when typing the path to a file on that partition, it will be D:0\...filename rather than F:\...filename. I don't think D:0 in this case has anything to do with the drive/partition letter D. Instead I think D:0 is how Windows internally refers to a certain disk/partition. I could be wrong though, just guessing.

    Here's a screenshot where you can see the issue. Note how newly added rules for files residing on the F partition is added with a path where D:0 is used. Like x-plane.exe in this case. Where rules from before the clone referred to the same partition using F:\ instead. Such as CLS2Sim in this example. Also seen is how this strange D:0 format is used only in the Windows Firewall. Looking in Windows Explorer for example, the partition is named F as you can see.

    Here's another screenshot demonstrating what happens when I launch CLS2Sim now after the cloning. As you can see, it triggers the box to have me allow the program though the Windows Firewall. Even when it was already on the list as seen above. Reason being, now after the cloning, CLS2Sim is referred to as D:0\ in the beginning of the path rather than F:\. Which makes the Windows Firewall think this is a new file. And hence the popup where I'm asked to allow access...again...for the very same file.

    I hope this makes the issue a bit more clear.
  • Oh yeah, someone in another thread asked me to run diskpart to see what that one reports. So I did and as you can see below, that one too refers correctly to the partition as F rather than D:0. So at this point, this only seems to affect the Windows Firewall. One other thing I noticed though was how I had trouble launching the beta of the new MS Flight Simulator. Which resides on this partition. Problem was solved though after I re-validated my access to the beta program. So I'm guessing that too was caused by MS Flight Simulator not recognizing the path any longer. If it was now D:0 instead of F:

    Really odd issue this! Here's the diskpart info where Disk 3 is the disk in question and Volume 5/Partition 5 on this disk.

    DISKPART> list disk

    Disk ### Status Size Free Dyn Gpt -------- ------------- ------- ------- --- ---
    Disk 0 Online 3726 GB 0 B *
    Disk 1 Online 9 TB 0 B *
    Disk 2 Online 476 GB 1024 KB *
    Disk 3 Online 931 GB 3072 KB *

    DISKPART> list volume

    Volume ### Ltr Label Fs Type Size Status Info ---------- --- ----------- ----- ---------- ------- --------- --------
    Volume 0 D DATA NTFS Partition 3726 GB Healthy
    Volume 1 E BACKUP & OR NTFS Partition 9 TB Healthy
    Volume 2 G AOMEI NTFS Partition 476 GB Healthy
    Volume 3 Recovery NTFS Partition 498 MB Healthy
    Volume 4 C SYSTEM NTFS Partition 97 GB Healthy Boot
    Volume 5 F FUN NTFS Partition 833 GB Healthy
    Volume 6 FAT32 Partition 100 MB Healthy System

    DISKPART> select disk 3

    Disk 3 is now the selected disk.

    DISKPART> list partition

    Partition ### Type Size Offset ------------- ---------------- ------- -------
    Partition 1 Recovery 498 MB 1024 KB
    Partition 2 System 100 MB 500 MB
    Partition 3 Reserved 16 MB 601 MB
    Partition 4 Primary 97 GB 618 MB
    Partition 5 Primary 833 GB 97 GB
  • What is "Volume 0 D DATA NTFS Partition 3726 GB Healthy"? The original disk still is connected to the computer when you boot from the cloned disk? Could you take a screenshot of your windows disk management so that we check?
  • That is a completely different disk. It's a HDD and totally separated from the SSD disk I have this issue with.

    To answer your second question, yes...the original SSD disk is still connected to the computer but totally wiped and now used for something completely different than serving as the system disk.

    First I wasn't sure what to do with the old disk but then I figured, maybe it would work good as a pure AOMEI image disk. And it sure does! The performance both during backup as well as restore when you're backing up an SSD to another SSD is really nice! So I'm very happy with this new purpose for my old SSD. Which is seen in the list above as Disk 2/Volume 2 with only a single partition.

    Here's the screenshot you asked for

  • That is a completely different disk. It's a HDD and totally separated from the SSD disk I have this issue with.

    To answer your second question, yes...the original SSD disk is still connected to the computer but totally wiped and now used for something completely different than serving as the system disk.

    First I wasn't sure what to do with the old disk but then I figured, maybe it would work good as a pure AOMEI image disk. And it sure does! The performance both during backup as well as restore when you're backing up an SSD to another SSD is really nice! So I'm very happy with this new purpose for my old SSD. Which is seen in the list above as Disk 2/Volume 2 with only a single partition.

    Here's the screenshot you asked for

  • Sorry for the double post caused by slow response time when pressing the 'Post comment' button.
  • We can't confirm the set rule of your windows firewall. It might use the absolute path, which doesn't base on the drive letter. When you boot from the clone disk, the actual path(registry path) in the windows firewall can't be changed to the new one. You might need to contact the support of windows to check the problem further.

  • Well, since this issue started after cloning my previous SSD to a bigger one using your software, it seems to me the problem would be in your corner.

    Will see if I can find an answer elsewhere.
  • edited August 2020
    Just guessing now but I think what might have caused this issue is how I chose during the disk cloning process to adjust the size of one of the partitions.

    The source disk was a 500 GB SSD with a 100 GB system partition (C:) and a 400 GB data partition (F:). The destination disk was a 1 TB SSD where I during the cloning process chose to keep the size of the system partition (100 GB) and give the extra space to the data partition to make that one bigger. Meaning it grew from 400 GB on the source disk to about 900 GB on the destination disk.

    The problem I'm now seeing only affects the partition I resized. So what I'm guessing is it's the method your software uses to resize a partition this way that in some way upsets Windows and the Windows Firewall in particular.
  • So...just noticed how this seems to upset your own software as well and not just the Windows Firewall.

    I wanted to perform an incremental backup based on the last full backup of the partition that has been causing the issue explained here. That didn't go all to well...this was the result:

  • Did you create the backup when you boot from the original drive? The Cloned F: drive is different from the source one, so it can't detect the original F: drive when you boot from the cloned disk to run the previous backup task. Please try to recreate the backup.
    In addition, you can upgrade to the latest v5.9 to use:
    Please still use your license code to check.
    The rule of your windows firewall might use the absolute path. When you boot from the cloned disk, the original F: drive might be changed to D before you wipe it, so the path also changes to d in the firewall. 

  • OK, things appear to start getting a bit confusing here now so...let's do this again.

    I started off with a 500 GB SSD disk with the below partitions:

    - 100 GB Windows system partition assigned the drive letter C
    - 400 GB normal data partition assigned the drive letter F

    I then bought a 1 TB SSD disk where my goal was to clone my original SSD disk to this new drive and use the additional 500 GB to expand the 400 GB data partition to be roughly 900 GB. For this I used the option Disk Clone option in your software after installing the new SSD disk in my computer. I performed the disk cloning operation after booting up from the bootable media which I always use if doing any operations with the Windows (system) partition.

    During the cloning process, I came to the screen where I was able to manually edit the size of the partitions and chose how the additional 500 GB on the new SSD disk should be distributed. This is where I chose to have the 100 GB Windows system partition (C) remain the same size but expand the 400 GB data partition (F) giving it all the additional space on the new SSD. Making it about 900 GB.

    I then started the actual cloning process which completed successfully. I then booted up my computer on the new SSD and all seemed to have went OK until I started getting these messages where I had to allow software through the Windows Firewall. Software which I already had allowed long time ago. And...when I eventually spotted the odd looking path (D:0\ rather than F:\), that's when I understood why I was prompted again. And that something went a bit wrong somewhere during the disk cloning process.

    You claim the disk cloning feature of your software should result in an exact 1:1 copy of the disk that is cloned. Something that clearly isn't fully true. If it had been, I wouldn't been having this issue right now. Since the F: partition on my old SSD was always correctly referred to as F: rather than D:0\ which is now the case with the new SSD. And once again I want to underline after reading your last post, you shouldn't confuse D:0\ with the drive letter D:. The 'D' in the D:0\ syntax doesn't refer to a drive letter. I'm guessing it's rather Windows way to shortly refer to a certain disk. In this case Windows apparently thinks of the F partition on my new SSD as disk nr 0...? Anyway, don't think of D:0\ as anything related to the drive letter D.

    Last night I tried something different which felt a bit like the last thing I can think of would fixed the issue. I started doing a new full partition backup of the F partition. I then deleted that volume/partition via Windows Disk Management. Leaving that space as 'Unallocated'. I then created a new partition using Windows Disk Management to make sure it was Windows itself creating the new partition. I then assigned it the drive letter F.

    Now with a brand new and empty F: partition created and formatted by Windows itself, I mounted the full backup image of F: I created earlier and started manually copying files over from the image to the new F partition. Started with the folders containing software which I know will trigger a Windows Firewall message. Deleted the odd looking rules with the D:0\ paths and then launched some of these applications. Hoping they wouldn't pop up a Windows Firewall message. Since they already had an old rule in there using the correct path (F:\...). Sorry to say, I still got the message to add a new rule. Using the D:0\ path.

    So...whatever the disk cloning feature in your software did, it left me and my Windows in a state which we sadly don't seem being able to recover from. Meaning I'll have to learn to live with having my F: partition being referred to as D:0\.

    Lastly, you ask me to try the latest version of your software. I already did and quickly went back to the version I'm now on since I had problems right away when using the latest version. Where your response was saying you're sorry for the trouble and that you will report this to the developers to improve on the software. The same reply I has often been given in the past when reporting issues with new versions of your software. It's really a shame that such an awesome software at its core isn't fully reliable. Here's the thread where we already discussed this.

    Sorry for the wall of text but I hope this will now make things perfectly clear. And that you'll take the time required to really read through everything I say here and fully understand the issue. Now that I've spent quite some time writing this to help you understand.

    Here are a couple of pictures I took during the cloning process. Where you can see what I've described above. Unfortunately, I never grabbed a picture of the final 'Disk cloning completed successfully screen' but you can see the result in Windows Explorer and how I after the cloning process have an 833 GB F partition.

    Picking the source disk:

    Picking the destination disk:

    Editing the partitions to allow all extra space on the new SSD to the data partition:

    Disk cloning process on the way:

    Back in Windows, now with an 833 GB F partition:

  • Hi WebMaximus, Sorry for the inconvenience. we can't confirm the reason why it shows "D:0\ ". Could you contact the support of Windows to check the problem further?
  • Already asked about it over here but so far no responses unfortunately.
  • Converting the disk from a basic to a dynamic disk fixed the issue.
  • OK, just realized I've locked myself up in a corner here...

    After converting the disk from basic to dynamic, that indeed fixed the original issue with the weird looking paths in Windows Firewall. However...now that I tried to perform a new full backup of my system partition on this disk, I was informed your software doesn't currently support backing up dynamic volumes on a GPT disk. And since it's not possible to convert a dynamic disk back to a basic disk, I find myself in a quite bad situation. Because I do want to be able using your software as I always have.

    The way I see it, I have 2 options right now:

    1. Perform a new and clean installation of Windows including all my software from scratch. Where I'll of course be able to go back to a basic disk. This however is far from optimal considering all the time and effort that will result in installing everything including Windows from scratch

    2. Start the Windows installation to wipe the dynamic disk from within the Windows installation to make it a basic disk again. Then create the same partitions I had on the disk from start followed by running AOMEI from my bootable media to restore the images created when the disk was still a basic disk

    What I don't know is if AOMEI will allow me to do that? Or will it sense the disk is "new" telling me it can't restore the images? If I do wipe the disk and then won't be able to restore my image backups, I'm forced back to option 1 whether I like it or not. Having to perform a full re-installation of everything including Windows.

    Would very much appreciate your input on this and what is possible and not using your software.
  • Hi WebMaximus,
    Yes, you can use AOMEI Backupper to do restore. Before wipe the disk, please first check if the backup is fine. You can run AOMEI Backupper to explore the image under Tools-->Explore Image and check if it can be explored.
  • Happy to let you know I was able to restore my system to the state it was before I converted the disks to dynamic disks. Was a bumpy road though where I first had to manually mess around with diskpart after booting up from the AOMEI bootable media. This to be able to totally clean the SSD from the old volumes etc and force it to become a basic disk again rather than a dynamic one.

    What I wonder now after restoring the old image and with the disk being back as a basic one, I ended up with 2 recovery partitions and 2 EFI system partitions. How can I get rid of those not in use? And how do I know which ones those are?

  • Also, now that you know the problem with the weird looking paths in Windows Firewall was solved after I converted the disk to a dynamic disk rather than a basic disk, it can help you figure out why this happened during the disk cloning process. To find a way to fix it without having to convert the disk to a dynamic one. Resulting in not being able to backup the disk anymore using your software.
  • Hi WebMaximus,
    Did you perform system restore? or disk restore? You can create WinPE bootable media via AOMEI PE Builder, and then boot from the WinPE to delete all system partitions on the disk, and then do the system restore again.
    "now that you know the problem with the weird looking paths in Windows Firewall was solved after I converted the disk to a dynamic disk"---Did you mean that the  "D:0\ " become "F:" automatically when you convert the cloned system disk to dynamic? 
    And, it is "F:" in the windows Firewall after you do the restore?
  • edited August 2020
    I performed a system restore.

    I know I can boot from the WinPE bootable media created by AOMEI and do various things from in there via the Windows Shell. That's exactly what I did. As mentioned in my previous post. The weird thing was how I after this restore ended up with 2 recovery partitions and 2 EFI system partitions. Also as seen and said above.

    Yes, after I converted the cloned disk to dynamic, the issue with weird looking paths in Windows Firewall was resolved. However, as mentioned it wasn't an acceptable solution in my case when I learned I wouldn't be able to use your software anymore to backup my system partition after converting the disk to a dynamic one. The message I received from your software told me this wasn't supported. But also told me it would be supported in an upcoming version of your software. I wonder how far off that new version is? Considering I got this message in 4.0.6 which is the version I'm still using for reasons we already discussed. And you released quite a number of new versions since then and it's still not supported. I confirmed this by downloading and installing the latest version of AOMEI Backupper (5.9). Still got the same message telling me backing up system partitions on dynamic disks isn't supported.

    Due to the fact I had the issue with the extra partitions in combination with being back with the weird looking paths in the Windows Firewall after restoring my system from an image after the disk cloning process, I decided to try restoring an old image from before the disk cloning. And what do you know! Using that old image I didn't end up with any extra partitions and the issue with the weird looking firewall rules were finally solved!! Below is a screenshot showing this. The same screenshot I posted in one of the first posts in this thread. Now however, with the big and very pleasant difference the path to the program now starts with F:\ rather than D:0\.

    So to sum things up:

    Using your disk cloning feature which should result in a 100% 1:1 copy of the disk cloned, that is not fully correct. Clearly, something happens during the cloning process using your software which makes the Windows Firewall (and maybe other components as well only that I didn't spot those during these last couple of days I've been messing with this) consider the cloned disk as a new one rather than the original, source disk you cloned. Resulting in referring to it in this very strange way using D : <nr> \ rather than the assigned drive letters.

    Converting the disk from basic->dynamic fixes the issue but leaves you in a situation where you no longer will be able to use AOMEI Backupper to create system images from that disk. Where you need to fully wipe the disk from all volumes in order to get back to a basic disk. Since you can't simply convert a dynamic disk->basic disk.

    Restoring a system partition created after the cloning process will also restore the issue. Meaning, the only way to get rid of the issue once you have it as well as being able to continue to use AOMEI Backupper to perform system image backups, you must completely wipe the disk clean ensuring it's a basic disk. Followed by restoring a system image created before the cloning.

  • Thanks for your feedback.  We have submitted the problem to our technicians to check and analyze further.

  • You're welcome 
Sign In or Register to comment.