Backupper Std installer throws error: IPersistFile:::Save failed

The Installer throws the following error at the end of the installation process:
IPersistFile::Save failed; code 0x80070002
The system cannot find the file specified

Clicked OK to finish the installation.
Backupper Standard worked fine after creating a disk backup onto an external backup hard drive.

Backupper didn't throw a set up error after the initial installation process and it didn't throw the error after creating an initial disk backup
The external disk was initially set up to MBR style. The partition style was initially thought to be GPT.  To make the change, the external drive was re-formatted with Windows Disk Management to change from MBR to GPT .
After the set up to GUID Partition Table,  a new disk backup was created. This is when the Installer threw the error. 
The same error re-occurred again just 2 days ago after updating the version of Backupper Standard from version 5.0 to 5.1

The only site found with the same identical error was on GitHub on this site.  No resolution was posted. 

This set up error is not listed on as of this writing. 
A resolution would be appreciated.
Windows 10 Home, ver. 1903 OS build 18362.295
Windows Update is running w/o any issues         


  • Two screen shots depict what occurs after clicking your attached download link. The results are the same as I explained in my original post. First the installer detects AOMEI already existing. After electing to uninstall - then to install, the error message is thrown. Then the message from the launch site says "Installation Successful"
    I don't understand the whole point of this exercise
    Taking everything into account I explained before in detail, what was this supposed to resolve?

  • Maybe you didn't uninstall the program completely, see this:
  • As far as the message: "AOMEI Backupper has been installed in your computer. Do you want to uninstall it?"  
    This message only appears one time during each unistall. Clicked 'Yes' to uninstall. Checked the program had been completely uninstalled in the installation directory C:\ProgramFiles (x86)\Aomei Backupper. The entire folder becomes removed. The only other two folders are: Aomei and AomeiBR -  both of which remain after the uninstalls in C:\ProgramData\ . The files in Aomei BR have nothing to do with the installation program. 

    The particular  'error' messages mentioned from your link never appeared.  FYI the IPersist File:::Save Failed error does not only occur just when installing a new version of the program. The error occurs with every attempt to install the program with one exception when the program was initially installed the very first time (see my original post)  

    The operations programmed into associated extensions as executable can be the underlying cause of the setup error.

  • Can you show me your installation path?
  • edited August 2019
    Aomei Backupper Standard chose by default the installation path in C:\Program Files (x86)\Aomei Backupper when the update was installed from version The folder Aomei Backupper contains the executable file 'Backupper.exe' for product version This launches product version from the desktop shortcut installed on the 64 bit system.

    If you are asking about a different directory path of associated program files, then you need to be much more specific when asking your question. The entire list of program files and folders within C:\Program Files (x86)\Aomei Backupper consist of 319 files and 34 folders

    An executable 'Backupper.exe' also exists for product version  in the directory path C:\Program Files (x86)\Aomei Backupper\Winpe64 captured below.

  • …  it looks like Admin gives up trying even after detailed information and screen shots are provided with a step by step occurrence of the problem. The responses received are just one liners with no content or any effort. This entire thread for all I know may have been between a virtual support service instead of a real person. What a waste. 
  • Sorry for the delay. Are you able to run Backupper when you click the OK button?
  • edited August 2019
    The program runs.  The issue isn't whether the program runs or doesn't run. The problem is the set up error.
    These are the events leading up to when the error first happened in step by step sequence : 
    1.) Connected a brand new 2TB external HDD pre-formatted in FAT32. Windows Disk Management selected MBR as the default partition style. Installed  Aomei Backupper Std for the first time. 
    2.) Created a Drive backup of the second internal system HDD with Backupper Standard. 
    3.) Discovered the partition style that Windows selected by default for the external HDD was MBT. Desired to change the partition style from MBR to GPT.
    4.) Un-installed Aomei Backupper.
    5.) Performed a long re-format in NTFS of the external HDD with Windows Disk Management. After the re-format  completed, the partition style was selected to GPT. 
    6.) Re-installed Backupper. The "IPersistFile" set up error occurred during installation.(refer to screen shots in post)
    This error occurred only after the re-installation of Aomei Backupper Standard and after the steps were performed to re-format from  FAT32 to NTFS and then change the partition style from MBR to GPT.   
    The set up error re-occurs now whenever going through the process built in to the backupper program to un-install and re-install Backupper. If Admin knows how to correct this set up error then please list the procedural steps that will resolve this . Unless Admin needs some additional clarification, any other response that is not going to include a procedure will not be helpful. The one line and no content responses that have been provided thus far are not of any help.        
  • If the program runs, you could ignore that error, it doesn't matter.
Sign In or Register to comment.