does not support gpt removable device: WinToGo

whenever I try to create a windows to go external usb hdd I get the message "does not support gpt removable device". I have 4 different external USB hdd, not USB flash drives that I have tried and all get the same message. they range in size from 250Gb to 2tb. All are USB 3.0. 
I addition If I plug in a USB flash drive, it doesn't even see it. I have tried 16,32,64 and 128GB from different manufacturers and none are seen.
I don't think your WintoGo feature works. 
I have windows 10 Pro  Build 17763.rs_5_release.180914-1434
TIA for any help or assiatance you may be able to provide.


  • So are they GPT drives? Maybe you could try to convert them to MBR?
  • They are created it seems by default as ntfs/mbr, which are unbootable with my Intel Visual Bios which is UEFI and does not support either Legacy boot or CSM compatibility.
    I tried to convert them to gpt, which I can do but it does no good.  
    WINTOGO does not see any USB flash drives that are plugged in to the pc prior to opening the program. Is this normal behavior?

  • Can you upload a screenshot of Partition Assistant?
  • Notice the USB64 Drive I: doesn't even show up in Partition Assistant Standard Version 8.1. 
  • Here's another
  • edited April 2019
    Can you try to convert Disk 5 to MBR?
  • why would I convert it to mbr? I've already told you that my uefi precludes me from booting with a mbr type disk. Also this doesn't explain why APA doesn't even see my USB drive, when Disk management , EaseTodo PM 13.5, and diskpart does see it.  If I have time later, I may uninstall 8.1 and reinstall 7.5 and see what happens if anything. 
  • OK I don't know what changed but I upgraded from 1809 to 1903 and now wintogo sees my usb flash drives. SO I was able to create the wintogo usb flash drive, it completes successfully. it creates it as a ntfs/mbr partition, My NUC8i7HVK does not support booting MBR disk, so using EaseUS  Partition Manager I convert it to GPT/NTFS.  It doesn't see or boot from it. So i changed it back to NTFS/MBR and set the partition active in diskpart, and still it doesn't see it or boot from it. I can clearly see it has created the complete folder structure on the usb flash drive which what looks like the windows install. 

    I also tried it on a second windows pc, my laptop and again it doesn't see it or will boot from it.....even when i press f2 to go into the bios or use f10 .....
    so i'm at a lose as to why this won't boot on either win10 pc that I have. 
  • Did you created the ISO by Media Creation Tool?
  • edited July 2019
    No the .iso was downloaded from  using their .iso downloader tool. It was version 1803. 
    I don't think either of my PC's support non-uefi booting. There's no legacy or csm support in either of them. 
    I can send you images of the sector 0 and sector 1 of the usbfd and to me it looks like there is no boot sector/partition boot record.  
    I'll wipe this usbfd install and run it again and then take a look at sectors 0 and 1 to see if the mbr to gpt to mbr conversion process I did somehow changed the boot sector .and report back. 


    Ok using HxD Hex editor and comparing my sector 0 to the NTFS  sector 0 information in my old NT4 Resource Kit book, the Wikipedia NTFS entry and for reference, my sector 0 is indeed a NTFS MBR/PBR and has the correct info in it.  So your WinToGo function is formatting it correctly as a NTFS MBR disk..... But unfortunately for me every PC that I own has only UEFI bios with NO legacy or CSM support,  so I cannot boot MBR disks. 
  • Currently only ISO downloaded from Microsoft MSDN is supported.
  • I discovered that my Intel NUC8i7HVK  with Intel Visual Bios can boot GPT/NTFS formatted USB IF I disable Secure Boot.   
    Perhaps in a future release you can include GPT/NTFS support in your Win To Go?
     Can you pass this along to your developers?
    AT some point in the near future I would assume that ALL MOBO manufacturers will no longer use Legacy BIOS'es, or even UEFI Bios'es with CSM support as they will not be needed.
    There will be just UEFI firmware. 

    since I now know that my PC can boot GPT/NTFS I am going to try one last time and I will convert the MBR/NTFS to GPT/NTFS and disable Secure Boot and see what happens. 
    Will report here.
Sign In or Register to comment.