Restore System - problem with partitions


I have an SSD which is partioned in two halfs. One is a storage partition and can be ignored now. THe other one is my windows-partiton, let's call it A for now. When I created A during installment of Win10, Windows created a couple of additional partitions. For example a 500MB-Restore-whatever, a 16MB partition and one 100 MB Partition. Is that the Boot partition? I have no idea, but let's call this one B. All those additional partitions are hidden, have no disk-letters and I cannot access them. I'm sure you know which ones I am talking about. Maybe I forgot one small one. Maybe not.

Now I try to backup my windows-partition. I start the Aomei Boot-DVD and choose backup system. Aomei then backups A and B into an image. That is fine.

Now I try to restore the whole thing. I choose Restore Backup and AOMEI offers me to restore the image containing A and B to a partition of my choosing. I just want it to be as it was before, without changings, so I choose of course A.

Now Aomei tells me, that the image of A and B will be placed into A. And that is the problem. It doesnt place A and B into A and B, it places A and B into A alone.

So my A becomes smaller, because a tiny little bit of 100MB is cut from it to create a new B. And now I have 2 Bs.

What am I doing wrong?


  • edited June 2019
    What are you trying to restore this to? A blank unused SSD? A used SSD? Ideally it should be a blank disk and it appears your original disk is formatted GPT (that's all those extra little partitions which would have been imaged if you did a System Image) so the destination disk should also be GPT. If you are using a blank disk and it is GPT a system restore should work and Aomei will put the partitions were they belong.
  • Im trying to restore this to the original SSD. Its like making a backup and restoring it 2 seconds later to the same disk as a test. And it's not working.

    Why should it be ideally a blank disk? So before I restore my backup I have to delete the partitions? Why doesnt it replace all partitions it backuped before.
  • First of all, I don't think it's a good idea to do a test restore to your active system disk as any failure could render your PC inop. (You could do a file or folder restore as that wouldn't affect the operating system.)
    I think what you tried to do was restore your system to a single partition. Please read about doing a system and a partition restore in the help guide  If you want to continue with your tests, you may want to try just restoring one partition at time.
    I also think you may want to be doing a DISK backup as you have data on the same drive. In case of a drive failure, you would want that partition back too. 

  • I made a system backup precisely as described in the manual and I had an image afterwards. I clicked on that image and got the default operation suggested by AOMEI: A system restore. There was nothing to choose but one destination to restore to, and I used that one. THe result is as I described it.

    Interesting is that its different from the restore operation in the manual. The first 2 steps are the same, but not the 3rd.

    3. You need to specify the destination drive if the size or location of the original system drive has changed. If they haven't changed, the program will automatically select the current system partition (usually C drive) as destination and directly skip this page.

    That is not whats happening. It doesnt choose on its own. I get a list with all partitions (including the small ones) and then I need to decide where to install it to. And sorry to say, its the default action. I click on it, a menue shows up telling me "that is a system backup, comrade, do you want to restore it?" and that's it.
  • edited June 2019
    You'll have to have the forum admin answer that or write to support for the answer as to why that's happening. Again, I wouldn't use your active drive to do test restores to. Any backup and restore program can glitch (apparently like this one wants to) and you might not like the result. I've done many test restores to an SSD in a test bed PC using Disk, System, Partition and Universal (to unlike PC) and they've all worked. The biggest thing to watch out for is using the same formatted disk for the target as your source... ie, MBR to MBR or GPT to GPT (as it appears to be what you have).
  • I think the manual already answered your question: You need to specify the destination drive if the size or location of the original system drive has changed.
Sign In or Register to comment.