Home AOMEI Products Support

Clone won't boot in windows 7 pro

I hope someone can help me out..
I run win7 pro and have several partitions on the same 2.5" ssd 
I used Aomei Backupper (free version) to clone C: to E: (both have the same size and with 30GB spare space each  and  ticked Optimize for SSD, than started Clone operation. -->ALL seems to  have gone OK..
I installed Easybcd v4.2  and  entered  both C & E drives in the boot menu with time-out of 3 s.
On rebooting the laptop  the Easybcd menu shows and boots fine into C: But if I choose to boot from E: (the cloned version) it still boots into C: I tried this a few times, but it keeps ignoring the E partition.
I put different  text files on both partitions, so I know for sure which one it has booted into
Can anyone please please shed some light on this problem?


  • edited June 2019
    Three possible problems. I Guess  B. is the main problem:

    A. 2 active disks if C and E are on different disks). Set the second disk (E:) as inactive with Diskpart.

    B. The clone (E) still has referalls in the registry to C: since it is a clone of C:
    (Maybe you booted from E: but the Desktop and other environment things from C: are used, so you think you are on C:
    Examine this in Windows Disk management)
    Most important: Delete all but the first entry in E:'s registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices    They are correctly rebuilt at first boot of E, but E is now renamed as C: and old C: probably has no letter yet.

    C. For later OS than Win7: Set in both Windows Fast Startup off (See Power options) 

    B. and C. are best done just before the cloning or as soon as possible after the cloning process.
  • Both C and E are on the same ssd..   I can't boot into E., it reverts back to the original C drive constantly.
    I understand the E becomes C  when  booted.

    You write " Delete all but the first entry in E:'s registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices "
    I can only access the registry in C. The top line or fist entry  here is  :Default    REGSZ       (value not set) . Are you suggesting I delete all the lines below and than clone? Or have i got this wrong?
  • edited June 2019
    Are you sure you added the correct E drive to the boot menu with EasyBCD?
    Do it again. And use the last added.
    When booted from E, open Windows explorer. Which drive has the OS flag in the disk icon? It should be E, but the desktop may show C files because of wrong registry.
    Then edit the registry as told here before. Yes, you can delete all entries. The entries just assign letters to drives and is rebuilt on new boot. Because C and E are on the same SSD, there is a drive letter confusion. This will be corrected if you delete the entries. 
    Now boot again into E.

    You can also install iReboot from neosmart.net and boot to E that way.
  • Thanks JohnnyboyGo for your help. It's now working fine
Sign In or Register to comment.