Home AOMEI Products Support

Backupper: Create Bootable Media is driving me crazy

Ok, so I set out to create a bootable USB drive to restore a cloned image to new hardware. Start Backupper, go to Utilities and select 'Create Bootable Media'. I select Windows PE, because the Linux media doesn't support UEFI boot. Check 'Create UEFI bootable disc". Select the flash drive and things start processing. After some time, the creation-windows just vanishes. USB drive unusable. Tried a couple of times without luck. So, instead of creating the USB drive at once, I choose to export to ISO file and use Rufus to create a bootable UEFI drive. Set Rufus to GPT, UEFI and NTFS as file system.
Try to boot from this USB drive and it fails: "Could not locate 'EFI\boot\bootx64.efi': (14) not found". Can't figure out if this is a problem of Rufus or the ISO file.

So, again with Rufus, I recreate the USB boot drive, but this time I choose FAT32 instead of UEFI. Plug it in and notice I cant select a UEFI boot drive. 

And time passes - I've been trying now for about three hours and getting pretty frustrated. So I'm hoping there's someone out there to tackle this thing?



  • Well, I tried again. This time I created a bootable Windows PE USB stick. Just follow the instructions: instructions https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/winpe-create-usb-bootable-drive
    This works right away. But the stick doesn't contain Backupper, of course. So how to get that onto the stick> Just copied the folder 'Aomeibackupper' from within the earlier created ISO file to the USB drive. Now I can start Backupper in the Windows PE environment, but it's impossible to select drivers / folders / files to backup. There's just no dialog to do that. I can, however, select a destination. But without a source, that's no use. I guess there's something hidden to prevent unlicensed use.
    Question is, can I merge the ISO and USB drive so I end up with something that DOES work?

  • Does your computer support Legacy boot mode?
  • Yes it does, but that also complicates things. The drive to image is set up as GPT / UEFI. In case I have to start the USB drive in legacy mode, I first have to change the BIOS settings. Then create the image (if possible), then revert toe BIOS back to UEFI and pray it will run... So yes, the machine can use legacy boot, but no, I'm not eager to do so...
    BTW - this page https://www.backup-utility.com/articles/uefi-disk-imaging-and-cloning-software-4348.html says AOMEI backupper is the best UEFI Disk Imaging and Cloning Software....
  • If you create a Legacy boot ISO, you can burn it to the USB drive by Rufus and it should work.
  • I managed to tackle the problem, but it involved some steps and a lot of time.

    First thing: I wish I had discovered AOMEI PE Builder a couple of days earlier! The USB stick created with it booted right away AND it ran Backupper, so that was good first step.

    However, Backupper didn't 'see' the GPT drives, only the USB drive. Turned out to be a driver thing. So I used PE Builder to add a bunch of drivers, but that didn't do the trick. Then I copied out 'boot.wim' and used DISM to add that bunch of drivers. Copied back boot.wim to the USB drive and…. everything hunky dory! Backupper works a charm. 

    Finding the right drivers is / was a problem. It involves Dell machines (Precicion 3630 to be exact). Dell offers driver packages for a whole bunch of machines and revisions. So I ended up with a driver package of about 1.4 GB without any explanation of which driver to use for a particular model. Luckily, they also have a driver package for WinPE, which is quite a bit smaller. Extracted all Windows 10 drivers and put them in the WinPE installation using DISM.

    And DISM turned out to be bitchy as well. It wouldn't commit and close the image the right way, so that took some work as well.

Sign In or Register to comment.