Home AOMEI Products Support

Cannot explore image

Synopsis:  a system backup cannot be accessed from explorer


0) Windows 10 installed on a BootCamp partition successfully created by OS X (High Sierra)

1) created a system backup using Backupper Professional

2) verified backup successful

3) Backupper Pro:Utilities:Explore Image

    a) select the system backup to explore

    b) select the backup point (in this case there was only one)

    c) map disk/partition to new drive letter (D:, F:, whatever; in this case, D:)

    d) Image preview is initialized, checked and attached to drive D: successfully

4) open explorer and select drive D:

    a) a modal dialog displays the following information:

        (1) location is not available (in the title bar)

        (2) D:\ is not accessible

        (3) Incorrect function

5) Return to Backupper Pro: Utilities:Explore Image and detach image successfully

What to do?  Windows 10 appears to be well behaved.  I have no issues booting back and forth from OS X to Windows.  OS X Disk Utility pronounces all the partitions as healthy.  And, for that matter, so does Backupper.  I am at a complete loss as to how to access this backup.  By the way, I created a new backup of a new Bootcamp partition and encountering the same problem.  I really need to get this data back so any help would be appreciated.



  • If you restore the backup, I'm afraid your OS X will not be bootable.

  • Fair enough, I understand that.  But that is not the question posed by this post.  The need now is not to restore, per se, but to mount and use the explore feature.  Please advise how this can be accomplished.  Thank you.

  • The backup is on an external device? Can you explore that on another (Windows) PC?

  • No, I only have one Windows' seat on a multi-system machine (an iMac).

  • It's a bug, please restore the backup to another computer to access the data.

  • If only I had another computer to which to restore the backup.

  • You could restore to another disk.

  • SueSue
    edited October 2018

    exactly I have a same issue, i.e. cannot explore the mounted backup (partition/system).

    This would lead to the system backup (.adi) useless!!

    Also I can confirm restore the system backup will make MacOS not bootable even disappear the MacOS partition.
    I don't if this related, but does AOMEI also backup 3 partitions(EFI, Windows Reserved, WinX system partition),  it should be given a choice while restoring only the Windows System.

    i.e. following software bugs need to be fixed:
    1. Backup file(.adi), the integrity need to improved, in order to be explore after mounted;
    2. AOMEI needs better solution for multi-OS/boot backup.
    If possible, would not make the .adi file a .img or .iso, which can be mounted directly in Windows 10. Is that a great idea and more friendly solution?

    PS: restore the corrupted(?) backup.adi to another PC is not a good idea, because hardware/configuration are different!


  • @Sue, remember the adi file is not an image by it self. If you have incremental or differential backups, you need to point to such a backup and Aomei creates a chain back to the full backup to mount a virtual disk consisting of all the combined adi files from full backup to the chosen backup.
  • SueSue
    edited October 2018
    Thanks for the reminder.

    My .adi files are not incremental backups, just a one-time backup. It is really pity now that those files cannot be read anymore(already checked integrity). It is strange also, that I just did a fresh backup cannot be mounted/read too.

    But I really like the idea, that the ADI can be mounted directly and easily read from WinX.
    Also the incremental backup is another great advantage, but firstly the data reliability really need to be improved.

    Frankly speaking, I am testing this software recommended by a PC-World columnist, but now I don't know if I should keep the 2 backup .adi files.

    Also I want to understand, e.g. how to organize/move the backups, because after reinstall AOMEI, it cannot find the path to external HDD and the backups. Intuitive way would be, I point to the file path and it rebuild the backup database/lineup.

  • edited October 2018
    You can point to the file and the task is rebuilt. Just choose Path and point.
    Did you try Utils menu -> Explore to mount? It should also work on another PC.

    Oh, I don't know anything about MacOS. 
  • SueSue
    edited October 2018
    would you pls help how to mount and make readable of the .adi backups?
    the backup adi files can well be read if boot from AOMEI PE bootable USB. Also if single partition(no system or EFI) then, it can also be mounted and readable.

    Now even the fresh done backup .adi cannot be read after mounted.
  • @Sue I think maybe you could provide more details on how the backup image cannot be mounted?
  • SueSue
    edited December 2018
    I am back and still want to make the old .adi backups be able to open.
    All the backup(.adi) for single partition(non-system) can be retrieved and mounted and readable within WinX.
    But those system backups NOT! Usually these backups contains 3 partitions, EFI, WinX and a 850MB (must be Windows reserved). Even if I try to mount only the WinX partition, it fails to be read.

    Could you help?
    PS: what details do you  want?
  • I have just got an idea if the deployment needs more HDD space, but the same thing should be for non-system.adi too, for the latter I can mount/decompress w/o any issue.
  • it fails to be read.
    -- What's the error message?
  • SueSue
    edited December 2018
    No info was given.

    The backup.adi can be successfully mounted to e.g. G: drive,
    but if I click on it in windows explorer , it cannot open.
    the mounted drive can be easily detached/unmounted and disappear in windows explorer.

  • @Sue I'm afraid you'll have to restore the backup to access the files.
  • in fact, I tried to setup a new backup, and tried to attach again/mount, the same thing.

    as I have written above:
    "the backup adi files can well be read if boot from AOMEI PE bootable USB"

  • I agree that it is a pity that the *very* cool feature of being able to browse the content of image files does not work. I tried with a couple of different images, and only one (useless) EFI partition did actually mount as a virtual partition.

    Since my partitions are TB:s it is impractical to just say "Restore to image to view". That will take hours and spare disks that are the same size as my real hard drive.

    I would have been happier with the customer support from AOMEI if the response here had been "I am sorry that does not work. We are looking into this bug. Is there any information that you can share so that we can fix it?"
  • Hi can I join this conversation please? I now have two virtual partitions/images on Win 10 This PC. The partitions will open giving the folder structure but no files will open, same message as Sue above "G:\****** is not accessible. The file or directory is corrupted and unreadable."
    Question is how do I safely remove these virtual partitions/images? Can I just delete them without affecting my other drives?

  • @BCNorwich The virtual partition will disappear when you restart your computer.
  • The same thing is happening to me:
    I am trying to access a file from a virtual disk image but when I try to open the file I get the following message:
    "The file or directory is corrupted and unreadable"
    What to do here?
    Can you please guide me as to why this is happening.
    Thank you
  • @Natiguthoy Did you explore the image on another computer? or same computer and same administrator account? It seems that there is no permission to access the file under the current account?
    Could you try to download and use Q-dir tool to access the explored partition?
  • Same problem here. "The explore image" function does not work, support just gives the runaround with non-solutions, 

    It should be "explore image", mount drives, read drives. But this is not what happens.

    its probably time to just start a campaign to warn people that this software does not do what it promises to do. Support probably knows this so does the old "give em the runaround until they give up" trick.
Sign In or Register to comment.