Unable to use any existing backup job after doing a system restore

The last two times after I needed to restore my system from a backup, I was unable to continue using any of my stored backup jobs. I got messages that the partitions do not exist or were changed. I was forced to create a new full system backup. Could someone please explain why this is happening. It never did in the past. I am running the latest version of Windows 10 64 bit and my Laptop is UEFI.

Does this mean that once I do a system restore, all my current backup jobs are obsolete? Does this mean that I can no longer do another restore from any of these backups?

Thank you.


  • I'll try to rephrase my problem.

    It seems that any backup job active in AOMEI becomes obsolete once I restore my system from an AOMEI backup on an external hard drive. I am forced to create a new system backup job.

    When attempting a backup from an existing job, It says that all partitions are either missing or have changed.
  • edited July 2018
    If you did a SYSTEM  backup, when you restored, it will not restore your Recovery partition(s). They are not needed if you have a Microsoft Rescue Disk. Same info and functions on both. If you did a DISK backup, Aomei sometimes adds a drive letter to the Recovery Partition (you need to remove the letter in Disk Management). In either case, your new backup will not look the same to Aomei so I'm assuming that's why you're getting that message. And therefore you would need a new job that is looking at your current system. You could keep an older backup image but you'll probably want an image of the system the way it is now.
  • Flyer, thanks for the explanation. But lets say in three days from now, for some reason, I need to restore from a backup done a week ago (because I forget to create a restore point). Will that backup restore successfully?
  • edited July 2018
    I don't see any reason it wouldn't. If the image was good then, it should be good now. Your inquiry was about having to create a new backup job (for whatever reason) after a restore. That really has nothing to do with using an older image. Do a new image and you should have all your bases covered; having an old image AND a new one for insurance.
  • Flyer, I understand now that I must create a new full backup after doing a restore. But I also needed to know that my prior backups would not be obsolete in case I needed to restore from one of them. Thanks for reassuring me on this.
  • Yes, your prior backups wouldn't be obsolete.
  • Thank you so much for the clarification.
  • Up to version 4.0.6, the old backup jobs still worked correctly after a system restore. Starting with version 4.1, it no longer works.
    Since I use a total of 5 different backup jobs and do not want to create them again after each backup, all versions after 4.0.6 are unusable for me.
    It would be nice if this bug could be fixed.
  • This is probably just me, but why would you want restore a backup that is over a year old? If you just want a file or folder from that backup set, have your tried to mount the image and see if you can recover the file?
    I thought the idea of doing these backup images was a way to restore a computer in case of a drive failure or system crash. Why would you want to restore your computer to a state from a year ago? Again, I'm probably missing something and everyone has their own idea on what they might need. Just curious as to the way others think about how to use and how long they want to keep a backup. Again, if you may need a document, make a file and folder backup of your docs or pics. Why keep a system backup that long????
  • edited August 2018
    It's not about the backups themselves but about the backup jobs.
    I have created five different backup jobs to back up the system to different drives at different times.
    After a system recovery from version 4.1 these backup jobs do not work anymore and I have to recreate all five.
    After a system recovery with version 4.0.6 the backup jobs still work.
  • OK. Thanks for explaining that. I'm always trying to learn. I was a little confused here as @Mdubin was talking about using his older stored backups or at least I thought that's what he was trying to say. Your situation wasn't quite the same... Thanks for replying.

  • edited August 2018
    @reisender1967 ; What you mean "it no longer works"? You got the same message as Mdubin?
  • @admin: Yes, here is the error Message (translated from the German version):

    Initializing the backup...
    Volumes are checked...
    Volume 0 was not found or has not been changed.
    Volume 1 was not found or has not been changed.
    The specified volume 2(C:) could not be found or was changed.
    Information Code:4123
    None of the partitions to back up have been found.

  • @reisender1967 ; We will try to improve it.
  • Thank you!
    Would be great if I could use the new versions again.
  • edited September 2018
    This is a Eureka moment for me! Since my last post, I built a new system for my wife. All is new except for the secondary hard drives. The C drive is a new SSD so since this was going into a different system, I backed up her C drive and restored it to the new one using universal restore. Reassembled everything and all worked great. Updated all drivers, reactivated windows and reactivated all programs that needed it. Aomei was reinstalled with my activation code and all looked good. All my backup jobs were still there... 4 of them. But today I was checking the status of the backups that SHOULD have run this past week but NONE did. Each with some different error code or fault. 2 of the backup destinations were on HHDs that we're installed locally and 2 of the backup jobs were to a network drive on my PC. No drive letters were changed. NONE WORKED. I had to delete the backup jobs and redo each. After doing so, all the backups are working.
    So my apologies go out to you Reisender1967. I understand your problem.

  • yes, this is really annoying.  After restoring to a different disk, you need new backup jobs.  There should be an option or an override.
  • edited February 2019
    I was just about to post about the very same and most annoying issue where after doing a system restore, your old backup jobs can't be used anymore.

    In my case, and to explain to anyone who still doesn't see why this is such a big problem, I usually do a full system backup. After that point, I will do incremental backups before I do any important changes to my system with comments attached to each incremental backup what is about to change. A normal comment for one of the many incremental backups could be "Before installing software X" for example.

    Since I do quite a lot of changes to my system and always want to be able to easily roll them back should I have to for whatever reason, this functionality is imperative to me.

    I then keep going like this until I decide my system is stable and I'm 100% happy with it. This could be months after I created my first full backup. At this point, I will delete the old backup job(s) and backups and start all over again with a new and fresh full backup.

    I've been using this method without any issues for years and I always stayed with an old version of AOMEI Backupper since I have some very bad and scary experiences upgrading to a newer version in the past where AOMEI Backupper once restored a backup image to another disk than the one selected resulting in a complete disaster!

    This time around though, I just finished building a brand new PC system and figured it was time to try out the latest version of AOMEI Backupper as well. I was obviously hoping the latest version should prove to be stable without any major flaws and an improvement over the old version I've been using.

    So...when can we expect this bug to be fixed?

    I see how this thread was created back in July 2018. That is about 8 months ago and still no fix and I'm now using v4.6.2 which as far as I can tell is the latest version.

    Some final words to the developers.

    You really need to be a bit more on your toes and address issues such as this one without 8 months passing by with no actions on your part if you want to stay competitive in this business.

    Even more important when developing software people need to be able to really rely on. After all, this kind of software is like using the seat belt in your car...it just needs to work with zero issues whenever it's needed.

    Allowing 8 months to pass where you even released a number of new versions within this time frame and still the reported issue is the very same and untouched by you, that is not cool.
  • Hello,

    I'm still using version 4.0.6 for this reason because it works with it.
    If the bug in the new versions is not fixed soon, I will probably switch to another software.


  • I found and downloaded v4.0.6 which doens't have this problem. I do have another issue though with this version, the UI is very tiny making it almost hard to read some of the stuff on my 4K screen.

    So in one way or the other, it seems to be very hard to find a version of AOMEI Backupper at this point that ticks all the boxes with no issues.

    Would be awesome with a comment in here from the AOMEI developers what their plans are for this software going forward.
  • Have you activated the large window mode in the settings under "Other"?
    Then the window should get bigger.

  • @reisender1967

    Many thanks, missed that option which sorted the issue.


    ...and sorry for the late response. Never received a notification I received a reply. Probably because I didn't bookmark this topic...
Sign In or Register to comment.