Laptop won't boot after full disk image restore

edited March 2018 in AOMEI Products Support

My laptop will not boot. The error msg says:

"Reboot and select proper boot device..." so apparently it is not recognizing my hard drive as a boot device.

Here's what happened.  My laptop had a motherboard failure, but the HDD seemed okay.  I removed it and put it in a USB enclosure and performed a full disk image backup with Backupper onto an external drve.

I reinstalled the HDD in the laptop and sent it for repair.  It came back with a new motherboard, and the original HDD reformatted to a factory Windows 10 install.

I backed that install up with Backupper, and then attempted to restore my original disk image.  It appeared to complete okay.  But...

When I tried booting, I got that message above.  I checked the BIOS, and it lists the HDD as first boot device.

I have repeated the restore a few times, using a USB restore drive created from Backupper on another computer.  (Specified to legacy BIOS.)  I made sure to specify Universal Restore.  I restored each partition separately, specifying Universal Restore each time, and making sure the main drive was C:.  I still get "Reboot and select proper boot device."

The BIOS screeen still lists the HDD as the first boot device.  "Launch CSM" is Enabled. 

I hope someone can help.  I am at wit's end. I am using the Professional version, by the way.


  • Did your backup include both the C: partition and the "System Reserved" partition? The SR partition contains the boot manager (see here compatible with the C: partion and I believe that both are required together. If you only backed up the C: drive then this might be the problem.

  • edited March 2018

    Is the HDD formatted as GPT after repair? In Legacy mode you need MBR, but in any case you need the same partition style as it was originally: BIOS/CSM=MBR, UEFI=GPT.

     I restored each partition separately, 

    Didn't you make a disk or system backup? In that case restore in one go and don't use the Universal option. 

  • Yes, I did a full disk image backup, which included the system partition, the recovery partition, one very small partition which I don't know what it is, and the C: drive.  I don't know if it's MBR or GPT--the question was never presented to me--but my computer does have a BIOS setup.  Does it matter that I made the backup image with the disk drive out of the laptop?  I created the backup using default settings.

    For the restore part, I guess I should give more detail.  When I ran the first recovery procedure, I had a working Windows system reset to factory state by the repair shop.  I installed AOMEI on that system and ran the recovery to go in one step.  (That's what I tried to do, anyway.  The interface is a little unclear.  I didn't select individual partitions, anyway.) That completed and gave me the "Reboot and select proper boot device" error.

    After that, I had no way to rerun it the same way, so the next thing I tried was pulling the drive and rerunning the recovery with the drive hooked up to another computer via USB. Same result.

    Then, on the other computer, I made a recovery thumb drive. I tried EFI and it didn't work, so I tried again making it using the legacy setting.  That worked, in the sense that it enabled me to get the AOMEI recovery app running.  So I tried again.

    I wasn't sure whether the "one go" method was even working, so I recovered each partition individually.  There were never any options that I could see re MBR/GPT.  I got the same result. 

  • edited March 2018

    Regarding the Universal Restore option, I used that because the AOMEI instruction pages said it was necessary after a hardware change.  (new motherboard) 

    I'll try again using System Restore option. 

    Ah, okay -- I have restarted it, set to go all at once.  Now I see where you can click to select the entire drive as destination, and that it does identify both the source and the destination as GPT.  I hope that's correct.

  • That restore also failed.  I am now attempting to restore the factory-reset install that the laptop came back with.  (It was also identified as being GPT.) 

  • edited March 2018

    If you have, before and after the repair, an UEFI machine, where the original HDD was GPT, then your BIOS should not be set to BIOS/CSM/Legacy but set to EFI/UEFI.

  • Good grief. Was this all a question of BIOS setting?  I don't see in my BIOS a choice between BIOS/CSM/Legacy and EFI/UEFI, though under the Enable CSM was a choice to enable some kind of controller involving UEFI.  Enabling that did not work.

    But... when I disabled the CSM option (that second thing went away), and I enabled Fast Boot, it booted into Windows!  Partial success!  I now have the factory-reset Windows restored successfully. 

    So... now that I know how to make that work, do I have the nerve to try the original restore of my latest Windows setup?  I guess I'll try. 

    Thanks for that tip about the BIOS.

  • Does the Universal Restore option control anything except the system partition?  I am currently waiting out the full restore (my C: drive has 258 on it and it's a lengthy procedure).  This time around I left Universal Restore unchecked -- no, wait, I think the option didn't show up this time.  If I have to retry with/without the Universal Restore, can I do just the system partition?

  • Well, that failed, and gave me a blue screen that said my PC needs to be repaired.  After the full repair failed, I tried restoring just the system partition, first by asking for system restore, and then by asking for universal restore. Now I'm going to try restoring just the system partition from the factory reset backup.  If that doesn't work, I see no alternative to going back to the factory reset and reinstalling all my programs and configurations from ground zero.  Which is exactly what my backup of the disk image was intended to prevent.

  • I removed it and put it in a USB enclosure and performed a full disk image backup with Backupper onto an external drve.

    —Backupper cannot detect system on USB, that's why the system cannot boot after restore.

  • Are you saying that there's no way to make a disc image from a drive that's outside the computer?  Can't drives be cloned from USB?
  • Okay, with this information in mind, I went looking for an earlier disk image backup and found one from November.  I restored that--and it worked!  I have successfully returned my laptop to its state as of a few months ago, and I then restored all missing data by copying with File Explorer from the more recent backup.  (Plus Dropbox, etc.) 

    So... I wish I had known about this limitation before beating my head for two days. :)

    But now I am back up and running!  Thanks to all who took time to help.

  • edited March 2018

    So a Disk backup made from a HDD with an OS on it, attached through USB, cannot boot after this backup is restored? I did not know that and I was surprised reading this. A Disk backup should be a Disk backup isn't it?

    So I tested this.

    I took an old HDD with Win8.1-X86 on it, connected with a USB cable to a PC and made a Disk backup. I Cleaned that HDD with Diskpart and Restored the backup I just made.

    Inserted that HDD in the original laptop, booted and I got errors that it couldn't boot. Just like JeffC. I was stunned. I think everyone expects that this backup should boot when restored. It's a Disk backup!

    There should be a warning in Aomei when making a Disk backup of a USB connected Disk. Something like: "Attention, you cannot boot from this Disk backup when restored..."

    Then I tried to repair this non booting HDD with the Win8.1 installation DVD, Boot repair. That did not work. Neither with a Win10 DVD. 

    Next I installed Win8.1 again from the Installation DVD. This one booted of course and I got a working System partition and a fresh C: partition.

    Then I restored only the C: partition from the backup overwriting the fresh installed C: partition. The result was a new System partition and the old C: partition.

    And that combination booted just fine. So this could be a workaround for people experiencing boot problems.

    Again Admin: there should be a warning. "Attention, you cannot boot from this Disk backup when restored..."

  • @JohnnyboyGo ; Thank you for the suggestion, I'll submit it to our development department.

  • I wholeheartedly agree with the suggestion. 

    Re JohnnyboyGo's last method of restoring just the C: partition onto a working system, I thought about that, but worried that there might be a conflict between the system as of (for example) November, and whatever system files are on the C: drive in February.  IOW, would there be conflicts having to do with Windows updates between the two? 

  • @JeffC. I don't think there will be a conflict. AFAIK the Windows OS is concentrated in the C: partition, the System is only there for booting or additional manufacturers software outside the OS. I often restore a C: partition (from a system or disk backup) onto a system that already has a working OS, and put the restore on een D: or E: partition, making a multi boot system by adding the restored OS with EasyBCD to the bootmenu. Always worked fine.

  • These are my thoughts. They are not facts. It seems to me that the backup process isn't just backing up the disk but also the hardware configuration and environment it sits in. i.e. The motherboard, graphics card etc. So if the HDD is sitting in a caddy when the backup is done then that environment is nothing like the same as it being installed in the computer. When trying to restore to the disk when installed in the computer the restore process looks for the correct environment (the caddy) and, when it doesn't match, the restore operation fails. What think you?

  • edited March 2018


    the hardware configuration and environment it sits in. i.e. The motherboard, graphics card etc.

    These things are all present in the OS partition (C:) of the HDD. If you connect a HDD through USB nothing changes in the content of the HDD.

    If you insert the HDD in another computer, these settings are set again or reinstalled again. In most cases (maybe always) the HDD will boot just fine as long as GPT/MBR is the same and CPU-bits are compatible.

    I have not tested yet, but there is also a Clone option in Aomei. I hope that a Disk Clone from USB1 to USB2 is an exact copy and will boot....

    @Admin, tell me, will such a clone work?

  • Theoretically it will work, but you might encounter the driver issue(BSOD).

    It is recommended to use the Backup and Restore, and remember to enable the Universal Restore.

  • edited March 2018

    I just tested it:

    A 2,5" laptop HDD with Win8.1 on it connected to USB1

    A 3,5" desktop HDD unallocated connected to USB2

    Aomei 4.0.6 on Windows 10 FCU managing the USB ports

    Cloned the entire disk from USB1 to USB2

    Inserted the 3,5" HDD in a Desktop computer.

    It booted just fine into Win8.1. Of course since the hardware has changed, Windows performed some settings, but that is a one time only operation of about 5 minutes.

    So why is it that a clone from USB1 to USB2 does work but a backup on USB1 and followed by a restore on USB1 not?

  • I sure would like to know that, too.

  • Well, we will test the backup and restore of USB drives and see if we can improve this function.

  • @JohnnyboyGo I was having problems booting after doing a system restore so I did as you suggested, doing a fresh install of Windows then restoring only my C drive. I encountered the same BSOD as before, but whereas previously when I tried bootrec in CMD it returned " 'bootrec' is not recognized," this time it was a recognized command. So I ran the following commands: 


    bootrec.exe /fixmbr

    bootrec.exe /fixboot
    (this returned an "Access denied" error so I followed these instructions and ran bcdboot C:\windows /s V: /f UEFI, where V: was the letter assigned to Volume 2, my System volume)

    bootrec.exe /scanos

    bootrec.exe /rebuildbcd

    After that, I was able to boot and access my restored C: drive. HOWEVER!!! My computer now seems to think I'm dual-booting, because whenever I turn on my PC I get prompted to select my OS from the following:

    Windows 10

    Windows 10, Boot from Volume 2

    If I choose the former, I get the original BSOD! If I choose the latter, it boots fine, but I'd very much like to know why this is happening. I'd like to either be able to delete the first non-functional Windows 10 OS, or repair it then remove the option to boot from Volume 2.

    I've checked Disk Management and I only have an OS partition (which is marked as "boot"), an EFI System partition, and a Recovery partition, nothing else. There's no other OS on any other partition, so it's not a true dual-boot; something is wrong.

    Do you have any ideas on what's going on or how to fix this?
  • edited February 2019

    I have the exact same problem!!!

    Luckily I am trying to replace an old but still working disk in bad shape before crashing, and I'm trying to restore a full system back up (yes, all partitions including that little weird one) to the new disk but failing. It just don't want to boot (see all problems and suggested and failed solutions as described above)! I was using this back up for my computer at work, but I really must consider changing my back up plan since it's obviously not working.

    Like someone said; a back up should be a back up because, well, it is a back up, and it makes perfect sense. The only safe alternative seems to be to back up all the ever changing files (music, documents, pictures etc) and then clone an exact identical disk copy once or twice a week and boot it just to confirm the clone really works if you ever need it.

    Finding out a back up doesn't work AFTER your hard drive has crashed is just too bloody late if you ask me.


  • This is an even bigger issue when upgrading a M.2 NVME SSD when you only have one M.2 slot. Admin, Please rectify this or at least come up with a tutorial to address this issue. Thank you
Sign In or Register to comment.