Windows crash in ammntdrv.sys after mounting image

I've been trying out AOMEI Backerupper Pro 4.02 as a replacement for Acronis True Image, and everything looked fine for the first two weeks. But now when I try to Explore my largest data partition backup which has 2 incremental backups, Windows crashes in ammntdrv.sys immediately after Backerupper successfully mounts the image. Explore worked fine when there was one incremental backup. Everything is still fine when I Explore the other backups on the drive that are smaller and have only one increment. The problem backup is reported as 100% ok when I have Backerupper check it. I even tried exploring the backup file on another system with Backerupper installed, but it gets the same crash in ammntdrv.sys (one system is Win7, the other is Win10). Any ideas?



  • edited March 2017

    A few other things:

    - The ammntdrv.sys crash is a "Page fault in non-paged area", so pretty generic.

    - The crash occurs even when I separate out the original full backup adi file and try to open it with Backerupper on another system without the incremental backups. This is pretty puzzling, because the file still has the original backup date, and I know I tried it with Explore after I made it.

    - I'm pretty sure there have been no system software updates on the Win7 system since Explore last worked, aside from the anti-virus package, and I tried turning the av package off to make sure it wasn't interfering somehow (no effect).

    - The version of ammntdrv.sys in Windows\system32 is an identical copy of that found in the drivers\amd64 subdirectory of Backerupper, presumably the one that was placed there during installation, dated 12/22/2016.

    - The adi file size is about 650 Gbytes, and it's a backup of a 720 Gbyte data partition on a GPT drive.

  • I know this is an old thread but did you happen to fix the issue? I started getting the same problem recently on a Windows 10 machine.

  • @morgan81 ; Can you upload the minidump and log files?

  • edited February 2018
Sign In or Register to comment.