Clone external HDD

edited September 2017 in AOMEI Products Support

Running on Win7, is it not able to clone to or from external HDD?

However, I can choose files from external in file backup function.



  • Of course,it should be.

    Any information you got?

  • Thanks for the reply.

    Why it should be? What informatin you want?


  • Does the external HDD contain operating system?

  • no OS, just data

    is there any thing to do before using clone for external?


  • No, nothing special, just clone one drive to another.

  • thanks for the reply

    I tried again today still no external drive appears in either disk backup or partition backup

    it only displays internal drives and even SD card

    however, I can choose files from external drive in file backup

  • Does the external drive appear in Windows Disk management (or Windows Explorer)

    Does the external drive have advanced formatting with 4096 bytes/sector? It seems that Aomei does not see these .

  • yes, the external appears in Windows Explorer

    how to see the formatting? I didn't choose any setting when I format it, also AOMEI **DO** see the drive in file backup function

    how to check?


  • OK if it shows up in Explorer and in file backup then that's OK.

    I don't know why the external drive does not show up in Clone or Disk or Partition backup but only in File backup.  

    Is it connected through USB? USB 2 or USB 3, and how big is the drive

  • thanks for the reply

    how to check if it is USB, 2 or 3?

    the drive is 3T size


  • Please check whether or not the drive is 4096 bytes per sector. You can install and run Partition Assistant, then right click a partition on the drive--select Properties--File System Info to check it. Backupper doesn't support drives with 4096 bytes per sector.

  • checked that the drive is 4096

    so is there any way to clone it?


  • If the source and target drives both are 4096, you could try AOMEI Partition Assistant.

  • Hi admin,

    I just tried Partition Assistant and it is still not work.

    I choose partition copy to copy partition. Source is the external HDD. However, I cannot select target.

    If the source is another partition, the target can be selected.

    The target partition is larger than the source.

    What can be done? Thanks.

  • If the source is another partition, the target can be selected.

    —Can you upload a screenshot?

Sign In or Register to comment.