Home AOMEI Products Support

Clone Company SSD to Upgrade SSD


I received a company ssd that has a program called Endpoint and some other corporate stuff.  It deletes aomei before it can finish installing and it also won’t allow me to turn off bitlocker.

I purchased a faster and larger ssd I want to upgrade to.  So far all attempts to clone or install this software have failed.  

Would it work if I removed the current ssd, put it in an external enclosure.  Then plug one external enclosure with this ssd into my personal computer and one more external enclosure with the upgrade ssd into my personal computer and clone both external ssd’s with  Aomei from my personal pc.  Then put the upgraded ssd back in my work computer? 


  • edited June 29
    Thank you Mjh2157, I understand you want to install an Aomei product, but your IT Manager's configuration does not allow you to. Please contact your IT Manager to allow your Aomei product to be installed.
    If you need more help, please reply with which Aomei product and version you are attempting to install, and a screenshot of the Endpoint security program.
    "Would it work"
    What change do you want to see happen, what is your goal?
    Tech Support
    [email protected]
  • My goal is to clone my current work computer ssd to a larger and faster ssd. The install the larger and faster ssd into the work computer and be on my way.
  • "My goal is to clone my current work computer ssd to a larger and faster ssd"
    You may use Backupper, or Partition Assistant to clone disks. If you are cloning a Windows system disk, they both will do that, but in my personal experience, PA clone, with Sector By Sector setting is best.
  • Thank you for your help
  • @Mjh2157, For the clone, you need to do the clone on the original computer. That's to say, you need to boot from the source disk and then clone it to another disk. You can connect the target disk as external drive when you do the clone.
    But, if you also contact the source disk to another computer as external drive to clone, it will be clone as data disk. So, the cloned drive might be unable to boot on the original computer. 
  • @admin, I cloned it externally the other day and it booted.  I used partition assistant and the sector by sector setting.  I thought I was 100% successful but the problem I noticed is it matched the partition volume of the original bit locked partition and left me with all the extra space (1.5 TB) as unallocated space.  I have found I cannot resize the bitlocked volume without the bitlocker key. Any advice?
  • @Mjh2157, You might need to boot from the cloned drive, and disable Bitlocker. And then, you can use AOMEI Partition Assistant to resize partitions.
  • Hey there buddy!Man, that corporate stuff can be a real nuisance, huh? Sounds like they've got that Endpoint program locked down tight. But I like your thinking - you're not giving up easily!Your idea about using external enclosures and cloning from your personal PC is pretty clever. It might just work! Here's what I think:
    1. Yeah, definitely try the external enclosure route. It should bypass all that corporate security nonsense.
    2. Make sure your personal PC can read the work SSD. Sometimes corporate drives are encrypted and won't show up on other machines.
    3. If you can see both drives, AOMEI should be able to do its thing without the corporate software interfering.
    4. After cloning, before you swap the drives back, maybe try booting from the new SSD while it's still external. Just to make sure everything copied over okay.
    5. Be prepared for the possibility that the work laptop might freak out when it sees a new drive. Some companies have hardware checks in place.
    Just a heads up though - make sure you're not breaking any company policies here. Some places get real touchy about messing with their hardware.Good luck, man! Let us know how it goes. I'm rooting for you to outsmart that corporate

    Regards, Ferdinando :-)
  • I'm curious how the rest of the story goes. Did any of the solutions help?

    Regards, Ferdinando :-)
  • @admin

    Here is my story:
    So I did the sector to sector clone and it worked great insofar as the os functions and everything transferred perfectly.

    However, I went from a 256gb company ssd to a 990 pro 2TB.  After I was done high fiving myself after seeing everything boot up fine I looked at my c: drive and found I had about 1.6 TB of "unallocated partition."  I went to resize the partiton with Aomei and also within windows 11 pro and found that you can clone a bitlocker partition but you can't re-size a bitlocker partition without the key.  None of the my company's software like checkpoint, perimeter something or other and some other stuff picked it up as far as I could tell.  I clicked on them and they all said "in compliance."  I waited a couple of days and reached out to my IT department head and told him plainly what I did and he was interested in seeing if my new ssd was any faster.  I explained the need for the bitlocker key so I could expand the partition.  He text me the next day asking for an identifying key, which I sent him.  I followed up a few times over the last week and have not received a response.

    Even though I can boot from the cloned drive and use it, their software has me locked out of editing or disabling bitlocker or having access to the key.  I tried a few things:
    - registry edits
    - restarting in safe mode
    - disabling wifi and cellular 
    - disabling the software in checkpoint microsoft services/disabling bitlocker in microsoft services.  Most of these I was locked out from hitting the Stop button or disabling.  If I wasn't they came right back on.
    - tried editing startup in msconfig to disable them
    - tried some commands in powershell to disable bitlocker
    - searched for a .bek file in my c: drive to decrypt, anything bitlocker or .bek is hidden.
    - used an app that crashes the computer so it provides a report that you can then try to decrypt the code from.  That file is inaccessible to me lol.

    I totally understand this whole thing is ridiculous and not worth my time, but I think I was more interested in seeing if I could defeat it than actually getting that 1.6tb allocated.

    Alas, I sit here in defeat...
Sign In or Register to comment.