Home Storage General Discussion

How Create ISO or IMG File of Bootable OS ?

Is there a reliable and easy way to create an ISO or IMG file of an active OS on a SSD with AOMEI Backerupper Pro ? I want to create a bootable ISO file of  Windows 11 that is on my C: drive so I can use it on Ventoy so I can can boot it up on a Ventoy USB drive so I can use AOMEI Backupper Pro to clone the ISO image back onto the computer's SSD if it ever become corrupted or infected with malware.  I tried it with AOMEI's Create Bootable Media in the Tools menu to create an ISO file of my C: drive without any success. The ISO file created by AOMEI Backerupper's Create Bootable Media is less than 1GB when my C: drive is over 65GB.  The only successful way I tried was to use AOMEI Backupper to clone the C" partition onto another internal HDD/SSD which mean I would have to open up the PC and physically swap the HDD/SSD for it to work.


  • edited June 21
    Thank you EdT, I understand you want to create an image file of your Windows system disk, while you are inside of Windows.
    If your goal is to create a Windows system backup that could later be used to restore Windows to the same or different disk, you can go to BU > Backup > System > save image location, and then later copy or move the image.ADI file to your external disk.
    I understand you prefer Ventoy, that is a useful tool, and you could put multiple Aomei bootable ISO utilities into that. If you are using Windows 11, that means you have a GPT partition table type on your disk; that means you should be using Ventoy GPT partitition table type on your USB.
    If you make a simple Aomei USB utility using the standard BU > Tools > Create Bootable Media, it is usually MBR. But, if you make Aomei ISO utilities, and copy them to Ventoy for a GPT PC disk, then the Ventoy USB should be GPT.
    I have not heard of someone creating an ISO from a Windows system installation.
    " I tried it with AOMEI's Create Bootable Media in the Tools menu to create an ISO file of my C: drive without any success"
    The purpose of BU > Create Bootable Media is to create a small BU USB utility. Then later, you could use the BU USB utility to create an image.ADI file of your Windows system.
    There are several backup types, the easiest one to use in most cases is BU > Backup > System Backup. Disk backup can also work, but that is usually used for data disks that do not have Windows system. The Partition Backup is almost always used for data partitions that do not have Windows on them, because if you attempt to later restore the system partition with Windows on it, it may not boot correctly.
    Backupper WinPE USB:
    Add custom drivers, such as NVMe, if necessary. Does not work on some Monitors.
    Aomei (Win)PE Builder USB:
    Best for PCs before 2020, includes Backupper, Partition Assistant, Recuva, 7zip, OSF Mount, CPU-Z, Bootice, DiskMgmt.msc. Supports x64 portable apps. Does not support any additional drivers, such as some internal M.2 NVMe disks.
    Aomei Partition Assistant
    Uninstall free version to get 50% off Paid Version.

  • @EdT, Create Bootable Media will create a WinPE ISO/Media of AOMEI Backupper. It can't create windwos system ISO image file.
    Based on your needs, maybe you can try to use AOMEI Backupper to create a system backup for your system partitions. It will a .adi backup image file. When your system crash, you can try to boot the computer from Winpe media of AOMEI Backupper, then it will boot to the interface of AOMEI Backupper. Then, you can restore the system backup image file (.adi). So, it will restore the original system status that you create the backup.
  • EdTEdT
    edited June 22
    Thanks for the prompt reply gents.
    aiArtisan Will an image.ADI file work in Ventoy ?  It does not list an .adi file as one of those extension that will work and only an ISO and IMG files. 
    @admin  I am so confused about AOMEI's Create Bootable Media and what it does or does not do.  At this point the only thing I know AOMEI Backupper will work is when I clone a bootable C: drive to another internal HDD/SSD drive and then clone that drive back to my C: drive ever becomes corrupted. 
    If AOMEI Backupper can't clone my current C: drive and turn it into an a bootable ISO or IMG file then can it clone my C: drive onto an external USB drive(Bootable) ?  The reason is I don't want to open up my computer and start physically swapping NVMe and SSD drives to do the cloning or backup procedure.  If  my C; drive ever becomes corrupted or infected all I have to do is boot from my external USB drive and use AOMEI Backupper to clone it back onto my C: drive. Plus I can also backup my C: drive more frequently to an external USB drive.
    The only program I have used or know of that can clone my C: drive onto an external bootable USB drive is Hasleo WinToUSB and then run AOMEI Backupper to clone the external USB drive back onto my internal C: drive.
  • edited June 22
    BU > Tools > Media Creation > Create BU.ISO
    Ventoy app > Create Ventoy USB on empty USB stick
    Copy BU.ISO to Ventoy ExFAT partition
    Reboot > Temporary Boot Menu Fn Key > Boot Ventoy USB stick
    Ventoy select BU.ISO > Boot BU WinPE > BU System Backup
    Later you may repeat the process to restore your PCSystemBackup.ADI file.
    Ventoy is a 3rd party app not from Aomei. Ventoy is not required to create an Aomei USB utility.
    Alternatively, you may use BU > Tools > Create Media > USB.
  • @aiArtisan Finally figured out what the BU > Tool > Create Bootable Media is. The issue I have with it now is that it takes up the entire USB drive and I could not even move the backup folder with the .adi files into it. The only way I was able to get the System Backup folder onto the USB drive was to use BU Backup on the same drive. I cannot even resize the partition with Windows Disk Management. As for Ventoy I was successful in creating the ample.iso with BU Create Bootable Media to put into it and the System Backup folder with the System Backup file.
  • I couldn't get the ample.iso to boot in Ventoy. I tried it with the both "WinPE creating environment from internet" checked and unchecked in BU>Tools>Create Bootable Media and still no cigar. My USB drive is formatted to exFat and secure boot is disabled. Anymore ideas to try ?
  • edited June 23
    "Anymore ideas to try ? "
    The partition table type of the Ventoy USB stick must match the partition table type of the target PC disk. There are 2 types, MBR for old disks, and GPT for new disks. Please use free tool Aomei Partition Assistant to tell you whether you are using MBR or GPT type.

  • So the USB drive where Ventoy was installed on was MBR and the NVMe drive on the computer is GPT. So I Diskpart the USB drive where Ventoy was on and created a new partition in GPT with Windows Disk Management and reinstalled Ventoy. Checked it again and the USB drive with Ventoy is back again at MBR. It looks like installing Ventoy changes it back to MBR. How do you make the USB drive with Ventoy stick to GPT ?
  • edited June 23
    Ventoy Settings > Set to GPT > Install
  • Okay did all that, even changed to a different USB stick, same symptom. I get an error message like "Invalid EFI ...."just as I boot into the USB drive from the manual boot menu. The screen flashes fast as it goes into the Ventoy menu where I can see the ampe.iso file in the list and then when I select it and enter it gives an option to Boot to Normal Mode, Boot to Wimboot Mode ...etc. In Normal Mode it goes into a blank screen and hangs. Can it be something with the ampe.iso file that AOMEI created ? I will try it with a Windows ISO file see what it does.
  • edited June 23
    1) Please take a screenshot of your UEFI Temporary Boot Menu and post it here.
    2) Please take a screenshot of the error and post it here.
    3) Please install Aomei Partition Assistant, take a screenshot of your disks and post it here.
    Thank you.
    If you are having trouble with Ventoy, you could alternatively use BU > Tools > Create Media > USB.

    Partition Assistant free
    Ventoy is a 3rd party tool not from Aomei. Please confirm you are using the newest Ventoy version 1.0.99.

  • EdTEdT
    edited June 23
    Okay I got somewhere with a Windows 11 ISO file. It booted in the Ventoy USB drive which leads me to believe it has something to do with the BU Create Bootable Media process. I have no issues with the BU > Tools > Create Media > USB process as it boots into BU with no issues, just that it's kind of tricky to copy the system backup files onto the same USB drive. I don't know how I can do a PrtSrc in UEFI Temporary Boot Menu as the computer will reboot and loose whatever it captured in PrtSrc.
  • You have attached your photo as a File. Please attach the photo, with the Attach Image button instead.
    Please take a screenshot of your UEFI Temporary Boot Menu and post it here, using your camera.
    Please take a screenshot of the error and post it here, using your camera.
    "it's kind of tricky to copy the system backup files onto the same USB drive"
    FAT32 partition cannot have files larger than 4GB. BU > System Backup > Predetermined FAT32 4GB Splitting Setting. It will create 1 backup split into several small 4GB files into a folder for you. Then copy the folder of small files to your FAT32 partition if you wish.

  • I had it both as an image and file before, somehow the image was deleted. The images below basically shows the progression. I even tried to use the bootable  BU>Create Bootable Media>USB Drive That I created previously to create an .iso file with ImgBurn and it still does not boot in Ventoy.  There is something definitely wrong with AOMEI BU Create Bootable Media tool in converting it to a bootable ISO file.
  • @EdT, Maybe you can first create WinPE bootable USB via AOMEI Backupper, and then, please try to create backup to the USB. Because the WinPE USB will use FAT32 format, so the backup image file will be split automatically.
  • I was able to create BU>Create Bootable Media>USB and it worked with no problem. The problem is the ampe.iso created by "Create Bootable Media" will not work in Ventoy. I even tried to use the bootable USB with BU on it and convert it back to an .iso file with ImgBurn and that did not work. So it has something to do with the way BU Create Bootable Media creates the .iso file.
  • EdTEdT
    edited June 24
    Okay here is a follow up. I was able to get both the ampe_7.3.4.Pro.iso I downloaded from a link from someone over at Ventoy's forum and the ampe.iso file I created using BU Create Bootable Media tool to work. The issue was I had to wait over a minute for the ampe.iso file to boot up in Ventoy once I see the black screen. I would have never thought it would take this long to boot up in a USB 3.2 Gen 2 1000GB/s USB drive. There was also another annoying issue with booting up these .iso files in Ventoy in that there is a desktop error message and the left side menu only is partially visible while the left side menu is fully visible in the bootable USB version something I guess for the folks over at AOMEI to figure out.
  • "link from someone"
    Please only use official links for Aomei software. Unofficial links and programs may contain a virus or ransomware.
    "menu only is partially visible"
    Thank you for reporting this error, please reply with a screenshot of this error from your camera.

Sign In or Register to comment.