Home AOMEI Products Support

AOMEI Backupper - System Restore - Inaccessible Boot Device

Hi hope all are well!

I cloned an internal SATA GPT HDD to a GPT SATA SSD in an external enclosure. It booted fine while plugged in as USB, I also confirmed the new SSD was showing as C: , so I know it booted
After removing the HDD and installing the SSD as an internal, it wouldn't boot and kept giving me the blue screen with Inaccessible Boot Device. I then tried all the bootrec commands, and the bcdboot pointing to C:\windows and the ESP. It would say boot files successfully created but it would not work.
At first it would say 0 identified windows installations, but somehow towards the end, I got it to say 1, but it still wouldn't work.

Should I delete all contents on the ESP and then run bootrec? I'm out of ideas. Every time I've run into this before I've ran the bcdboot command and it's worked fine after.
I've seen this issue with the full drive clone, I thought the "System Restore" / OS migration would solve this.

Done so much googling and tried most, none of them worked. Any ideas?
Thanks in advance!!


  • edited December 2022
    Is this a traditional 2.5" SATA SSD, or an M.2 SATA SSD?
    During System Restore, did you check Align to SSD box? I don't know if that prevents errors, but in the future, it is worth a try.
    I understand you have tried Bootrec and BCDBoot, could you please list all of the other things you have tried?
    While the System Clone method usually works, in the future, please use the disk clone method, it is more complete, and has less risk of boot errors.
    You said you had your SSD connected by USB, and then later, this error happened. Did you wait until the PC was fully shut off before unplugging your USB-connected SSD? Here is an article about why that is important:

    Great free tools from Aomei:

    Aomei WinPE Builder 2.0 USB, includes: Partition Assistant, Backupper, Recuva, OSF Mount, CPU-Z, BootIce. Does not work with internal NVMe drives, even if you add the driver manually.


    How to create your own personal Windows To Go, with
    Partition Assistant:


    Other great tools not from Aomei:

    Hirens Boot PE - live USB tool suite
    to add custom drivers such as NVMe, simply put them into the “CustomDrivers” folder

    LazeSoft - live USB boot repair

    EasyBCD - application

    If these tools don't repair your issue, reclone the disk using the full disk clone method. Please reply back, letting everyone know how you solved this issue, thank you Swordsx48.

  • Hey Moose! Merry Christmas and thanks for responding!

    -2.5" SATA SSD, as mentioned in the first line  :D
    -yes I did use the align for SSD box
    • bootrec.exe /fixmbr
    • bootrec.exe /fixboot
    • bootrec.exe /scanos
    • bootrec.exe /rebuildbcd
    though some of them gave "access is denied" which makes sense because it's GPT / UEFI.
    and I also did bcdboot. I think the next thing would be to delete the EFI and then use bcdboot to recreate the EFI files, if it would create all of them

    -If all else fails, namely, deleting and recreating the files using a Windows 11 Installation media (the OS is WIndows 10 but, the other USB I had was MBR and the Windows 11 one is GPT], then I will do a full disk clone. Oddly I recall the disk clone giving me this issue as well in the past. Also this is going from a 2tb HDD to a 1tb SSD so hoping it can downsize it properly. Though there's only about 150gb used on the 2tb HDD anyway.

    -yes absolutely it was shutdown

    -if I use aomei's PE or Hiren's boot PE, which I have both, which tool from there could help? I've used bootice, made custom BCDs, none of it worked.

    I'll try deleting what's on the esp and then recreating. It did finally detect the windows installation so maybe something there? if not ill go for the full disk clone but in the past ive had the full disk clone work fine for a while, but later on it gave me the inaccessible boot device.

    Thanks for the help!

  • edited December 2022
    This link will help you learn the difference between a 2.5" and an m.2

Sign In or Register to comment.