Home AOMEI Products Support

AOMEI Cloud?

I purchased AOMEI Backupper Professional 7.0.0 yesterday (2022-11-06), after reading the information here:


One of the listed features that contributed to me deciding to purchase was the listing of a new Cloud Backup feature, as on that page:

I could not find any further information on that feature at the time, but found after purchase that only a free trial of AOMEI Cloud was included with an expiry date of  2022-11-24.

I made a test backup of a folder to the AOMEI Cloud and then restored one of the sub-folders to a new one, which worked fine and I see confirmation of capacity used here:

Also The backup is listed under Backup Management, with the backup confirmed when I look at Properties:

I will not do any serious backups to the AOMEI Cloud until I have an idea of how expensive it is to keep active!  I am a retired pensioner, so would not consider subscribing to another cloud service unless it is very inexpensive, or allowed a certain data storage amount for free (I don't generally need 1 TB).

Having said that, there appears to be a bug, in that neither my cloud backup or restore are listed under Tools -> View Logs, which just lists other backups run yesterday and this morning:

I look forward to feedback on these points.


  • Well I have not received any feedback on the logging issue yet, but on running the program this morning, I saw that there is a new update to Version 7.1.0, so I updated to that version.

    I then (manually) ran the same backup and restore again with the new version.  Again, the backup and restore worked fine, but nothing was logged for either activity.

    I think that I should point out another issue that I encountered when running the first backup and again today when re-running it.  After the backup is started, I received a Windows Security Alert telling me that "Windows Defender Firewall has blocked some features in this app" so I had to manually click the "Allow access" button for the backup to continue. 


    I have not tried to run a scheduled backup, but presumably that would "hang" or fail due to this issue, so presumably I would need to add some Firewall settings for AOMEI Backupper Professional to operate normally, but I have not seen anything regarding that in any information from you that I have seen.  Am I missing something?

  • .. I can't cancel duplicate post?
Sign In or Register to comment.