Home AOMEI Products Support

Can't get WinPE to recognize Realtek NIC

Hi all,

I am using AOMEI PE Builder to make an ISO. I am adding every INF file I can find that pertains to Realtek NICs but nothing I do is working. When booting into WinPE and going to PENetwork, I just get "No network cards detected!" error. 

The actual chip is a Realtek 8125BG.

I've tried the "WinPE" folder from a Realtek package, and also the Win10 x64 driver. I also used DISM++ to extract the driver a running system is using but that didn't work either.

As far as using the PE Builder, is there a way to bulk add a folder of drivers instead of adding driver INFs one at a time?

Comments

  • Also, I tried the Bootable Media Builder built into Backupper (Technician License), and I added the INFs during this process as well. 

    Going this route, when I boot, it boots into Backupper directly. When I go to backup, I can enter a UNC path such as \\MYNAS\Backups\, and I am presented with a dialog to enter username/password, but it doesn't seem to work. 
  • Maybe the NAS name isn't recognized - try using a numeric ip address.

    PE Builder is good, but as far as I know, you have to add drivers one at a time. I make a minimal ISO with PE Builder, then inject drivers with a powershell script.  And, I've seen network drivers that I can't successfully add in PE Builder, but I can inject later.
  • @Wssddc,  Could you access and add your NAS path under the WinPE created by AOMEI PE Builder?
    "inject drivers with a powershell script."---How did you do it? Could you take screenshots so that we check it further?
  • OK, so here's what I was able to figure out....

    Using the built-in Bootable Media Builder, downloading WinPE files, and adding the driver files, I made an ISO and booted PXE just fine.

    The problem was when I went to pick a location for the backup, I'd type in "\\MYNAS\Backups" and hit enter. One of two things would happen. I'd get a "The file name is not valid." message, or I'd get a prompt for username and password. Entering the correct username and password would just bring it up again as if the credentials were incorrect. It didn't matter if I used "MYNAS\Username" or just "Username". 

    I went to a Command window, and could ping "MYNAS" so this wasn't a DNS issue, and ipconfig showed proper network configuration.

    I then manually mapped a network drive with:
    `net use R: "\\MYNAS\Backups" Password /user:Username`

    This mapped a drive successfully and I was able to continue with the backup.

    Just for kicks, after I did this, I was able to type "\\MYNAS\Backups" just fine in the location selection dialog. 

    I then tried things again with the PE Builder, and with this tool, it seems the driver isn't being loaded at all. However, I can Run "devmgmt.msc" and manually add the driver from a USB stick, and then I get an IP address right away. After I did this, I had to do the exact same drive mapping steps above to connect to the NAS. I don't get why I can't just log into the NAS from the file selection window, or why logging in from that window doesn't work. 
Sign In or Register to comment.