Home AOMEI Products Support

trouble creating working WinPE

Apologies if this has been discussed elsewhere - I tried searching for "WinPE", "bootable", etc. but found nothing particularly relevant.

I'm trying to create bootable WinPE images from Backupper STD 6.9.2.   I have several different machines, so please bear with me to see the whole extent of the issue.  All the machines are Win10 Home (up to date), but some are UEFI:GPT and others are BIOS:MBR.

1. on UEFI:GPT creating a WinPE image fails at 10%.  I have two of these machines - a desktop and a laptop, which have different drives and NICs.  WinPE create fails identically on both - no real error message or code, just [paraphrasing] "create failed - see the faq".  It does not matter whether the target is an ISO file or USB drive directly.

2. on BIOS:MBR creating a WinPE image works fine both to ISO or USB direct, but the result cannot be booted on a UEFI:GPT machine. 

I tried using RUFUS to write the BIOS:MBR ISO to a GPT partitioned USB.  Formatted with NTFS it starts to boot on UEFI but then fails saying it cannot load the NTFS driver.  Formatted with FAT32 the UEFI machines cannot even see the USB drive.  The result is the same regardless of SecureBoot settings.

I also tried creating a WinPE images using PEBuilder2 (downloaded today 2022-05-22).  That worked both on UEFI:GPT and BIOS:MBR machines, but the image it creates does NOT include Backupper (just PartitionAssist).  It also seems the UEFI:GPT and BIOS:MBR images work only on corresponding hardware [this I actually understand though I wish I could make a single image that worked everywhere].  However, from the PEBuilder2 page I was under the impression that Backupper would be included, and I cannot figure out how to add it.

So I can back up my UEFI:GPT machines, but I can't restore them (unless they remain bootable). 

Has anybody know how to build a WinPE image on a UEFI:GPT machine?   Alternatively, does anyone know how to include Backupper into a PEBuilder image?



  • @Gneuner2, Generally, AOMEI PE Builder will integrate AOMEI Backupper and AOMEI Partition Assistant automatically. Please reinstall AOMEI Backupper on your computer, and then recreate WinPE via AOMEI PE Builder. If there still is not AOMEI Backupper when you boot into the winpe, could you take a screenshot to us?

    In addition, please also try to create WinPE again via AOMEI Backupper. When you create the WinPE, please check if it checks "Download WinPE creating environment...". If yes, please try to download and install Windows ADK and Windows PE Addon. After that, please try to create WinPE with uncheck the option.
    As for downloading and installing Windows ADK and Windows PE Addon, please refer to here:
  • @admin -  Apologies for the delay in responding - somehow I didn't receive an email notice when you posted.

    I completely uninstalled both Backupper 6.9.2 and PEBuilder 2.0 and rebooted before reinstalling them.  I had tried reinstalling OVER them previously, but this time I removed them first.

    Backupper 6.9.2 still fails to create a WinPE image.  It gets to ~36% "Preparing to create WinPE image." and then fails.

    Manually installing the PE environment does not help ... I checked the contents of AOMEIPEENV.ZIP against the pe_env directory that Backupper downloaded itself and the contents are identical.  I substituted the zip contents anyway, but it did not help.

    I have not yet tried installing the Windows ADK ... it seems to be fairly large (and I already have 2 copies of the PE environment: one in Backupper and one in PE Builder).

    On the plus side, PE Builder 2.0 seems to work correctly after reinstall - the ISO it created contained both PartitionAssist and Backupper and they both at least appear to run.  I did not try to do anything with them because right now I have the problem of no network access from the bootable disk - I have to locate drivers for my "Killer E2600" network card so I can access the backups on my NAS.

  • @Gneuner2, you can delete the PE environment of Backupper. And then, please try to download and install Windows ADK..., then recreate the WinPE via AOMEI Backuper.
    If it still can't recognize your network, please try to manually add network drivers via "Add Drivers" when you recreate the WinPE.
  • @Admin - still not getting email when you post even though email notices ARE selected in my profile.  ???

    I deleted the pe_env directory under Backupper and installed the ADK with default settings. I ran Backupper and tried to make a WinPE using ADK only (without downloading the PE environment).  After a considerable time, it failed at ~10%.

    Realizing that the default ADK installation does NOT update the Windows search path, I manually added a path to the bin/i386 directory that contains the ADK executables.  No difference - creating a WinPE failed as above.

    Then I tried telling Backupper to download the PE environment.  It failed to download and bombed out at ~6%.

    So then I manually installed pe_env (from AOMEIPEENV.ZIP) into the Backupper directory and tried again without downloading PE.  Failed same as with ADK only (1st image) at ~10%.

    So I tried again, this time selecting to download the PE environment even though it already existed.  Again it failed at ~10% as with the ADK only (1st image).  

    So I have no idea how to get Backupper to make a WinPE bootable on my UEFI:GPT machine.   I can make one with PEBuilder2, but I have yet to figure out how to get my network card to function ... simply adding the NIC driver during setup doesn't seem to work - the resulting WinPE can't see the NIC.

  • I've been playing with PEBuilder trying to get the NIC working in the bootable image with no luck.  I have the drivers, but just adding them to the image seems not to be sufficient ... the WinPE can't see the network card and there doesn't seem to be any  additional configuration (beyond adding the drivers) possible through PEBuilder.
    I haven't tried making a disc directly via the ADK - the documentation for it is a bit overwhelming.
  • I appear to have the same problem creating an Aomei Boot Disc.  The particular machine I'm having trouble with is a Dell D620 laptop running Windows 10 Home version 21H2.  This is a 32-bit machine.  I had no problem creating such a disk on my 64-bit desktop but get the same error Gneuner2 gets on the 32-big laptop.  Of course, the 64-bit boot disk fails to boot on the 32-bit laptop.  Could this be related to the recent upgrade to 6.9.2?
  • @Supertech - I'm trying to make 64-bit bootables for a UEFI:GPT machine, but I'm relieved to learn that I'm not totally alone in my troubles.

  • @Supertech, Could you try to use an old version to create WinPE on the 32-bit machine and check if you will get the same error?
  • @admin
    I tried making a boot disk with Backupper 6.8.0 - it fails just like with 6.9.2.

    I tried dism64++ as suggested in the article you referenced: I exported all the network drivers from my machine, and imported all of them into the PEBuilder2 image. Does not work ... network is not started.  Running wpeinit manually after the WinPE desktop appears does nothing.

    I don't understand either problem.  It seems Backupper can make a WinPE boot disk on a BIOS:MBR machine, but NOT on a UEFI:GPT machine.  And it seems that PEBuilder2 can build a working WinPE disk on either type of machine, but can't add (or can't start) additional network drivers.
  • @Gneuner2, are you using a wifi network?
    Could you create a WinPE ISO of AOMEI Backupper on the UEFI:GPT machine, and then share it to us via cloud? We will test and check it further.
  • OK, I've had some success that may help you resolve this problem for some others.  First, I removed the latest version of Aomei from my 32-bit Dell D620 laptop and installed 6.8.0.  Then I created a boot disk using the Tools\Create Bootable Media option, selected Windows PE and then the Download WinPE creating environment from the internet.  Booting from this resulted in the Windows Boot Manager error (below) complaining about a 64-bit app on a 32-bit machine that I experienced earlier.  To me, this indicates you may have the wrong (64-bit) version up on your server where the Tool goes to download a 32-bit version.  
        Secondly, I went through the same process, EXCEPT, I DIDN'T select the Download WinPE creating environment from the internet.  I presume this utilizes code local in my 32-bit Windows installation.  This boot disk worked perfectly.  I hope this helps.  I may upgrade to the latest 6.9.2 and see if not downloading the WinPE from internet works there too.
  • I have succeeded creating 32-bit Bootable Media in v6.9.2.  What works is NOT selecting Download WinPE creating environment from the internet.  If that's selected you end up with a disk that is for 64-bit machines not 32-bit.  This still points to the possibility that Aomei has the wrong code in a folder on a server that they need to look into.
       My apologies for crashing into Gneuner2's thread.  My initial search for boot disk issues lead me here and while it seems we both were having boot disk problems they were caused by different underlying causes.
  • @Supertechm, sorry for the inconvenience. The Download WinPE creating environment is 64bit. We will optimize the problem after.
  • @admin

    The UEFI:GPT machine is hardwired, but WiFi also is available.  I have (via DISM++ as directed) imported ALL the network drivers from this machine into the PEBuilder ISO.  The resulting ISO boots, the AOMEI programs run locally, but it claims no network devices can be found.

    The ISO is at  https://i.getspace.us/cloud/s/YgxSq82wYnZo3KD
    All the network drivers that it should contain are in a ZIP at  https://i.getspace.us/cloud/s/EQz7x6ToaXCL5ZB

  • @Gneuner2, Please run AOMEI Backupper under WinPE, then click "Storage Management" under Tools, then click "Set IP" to check if there is an internet.
  • @admin - there is no "Tools/Storage Management" category.

    Sorry for lousy pictures ... had to take with cell phone. 

    Running PENetwork gives this error.

  • edited June 2022

    Your links are no longer working.

    If you did not download the pe env, then either winre.wim from the recovery folder, or winpe.wim from downloaded adk would be used.

    What is the motherboard and nic ?
Sign In or Register to comment.