Home AOMEI Products Support

Unable to get Surface Laptop 3 to boot from usb

I'm unable to boot a Surface Laptop 3 using a usb thumb drive created using the 'Create Bootable Media' tool in the Backupper Technician application.  I have other PC's that are able to boot from the same drive with no problem, so it doesn't seem to be an issue with the usb drive.   I have also verified that the Surface laptop can boot from other usb drives by booting and restoring the Windows OS (using the Windows Surface iso).

After reading through the other discussions, I tried to create a usb drive using the Windows PE Builder, but it always fails to download the PE environment.  The error given is -  "Failed to download WinPE creating environment. Please make sure your internet connection is active, or manually download WinPE creating environment and unzip the file to the installation directory and retry".  I tried downloading the PE environment and unzipping it to the specified location in the DownloadPath.ini file.  When running the PE builder again, I un-check the download PE environment box, but it won't let me click on the Next button.

Am I doing something wrong?  It seems others have gotten this to work, but after a whole day of trying different solutions, I haven't made any progress.

Any help would be greatly appreciated.


  • @G_t, is your computer using UEFI mode? or Legacy mode? What system is it running?
    For AOMEI PE Builder, generally, when you have downloaded the environment manually, it will still need to check " the download PE environment box", then it will call the downloaded environment when you create WinPE.

  • g_tg_t
    edited July 2021
    @admin,  The laptop is using UEFI mode and is running Windows 10.  

    For the PE Builder, I unzipped the downloaded environment in the path specified in the DownloadPath.ini file, but I still get the Failed to download error when creating the usb drive.

    I tried setting up the usb drive from an iso that SIW2 uploaded in a different thread  - https://www.aomeitech.com/forum/discussion/comment/17123#Comment_17123.  The laptop is able to boot from the usb drive created from that iso file, but it doesn't have mouse or keyboard functionality.

  • @G_t, " I still get the Failed to download error when creating the usb drive."---The directory might be wrong, so it can't detect the downloaded environment. Then, it will try to download automatically again.
    Could you take screenshots of DownloadPath.ini and unzip directory so that we check?

  • @admin Sorry for the delayed reply.  Here are the screenshots
  • @G_t, Could you try to reinstall AOMEI PE Builder? Generally, the path DownloadPath.ini are:

    Only G: is Variable. When you download the WinPE creating environment, you need to unzip it to X:\PB Download\x64.

Sign In or Register to comment.