Home AOMEI Products Support

AOMEI Partition Manager Pro unable to convert usb drive to GPT

I recently purchased AOMEI partition Manager Pro because I want to be able to convert drives from MBR to GPT, but I notice that when I tried to do this to an usb drive, the option is greyed out.

I tried to look up the reason from the forum. I can see that in Jan 2020, there was a post from someone with a similar issue, but was told that this will be fixed in a future version. It's now June 2021. Is this not fix then? I am having second thoughts on purchasing the product.


  • OK,
    I experimented some more and notice that the menu does work. Apparently, the disk I select that did not work turned out to be the USB boot created by Acronis backupper, so the generated usb keys are always MBR and cannot be converted to GPT? I notice the one generated by the WinPE builder is in MBR format but can be boot from UEFI boot. How does that work?

  • @Paulsiu, Our program will create UEFI boot file on the MBR disk. Sorry that we can't tell you the detail information.
Sign In or Register to comment.