Home AOMEI Products Support

OneKey - creating boot failed

I tried to update my OneKey system backup in windows 10 and it kept failing with an error about marking system partition.

Might have been controlled folder access protection so after rebooting and trying again it seemed to fail during the pre os pe boot part (cant recall what error, might have been the creating boot failed one), after booting up into windows and checking with partition assistant (that i also purchased) it appeared to have deleted the Aomei boot parition (800MB) and the Aomei recovery partition. I tried again and kept getting the same message:

<div>Adjusting partition layout to save backup image...<br></div><div>Creating boot...<br></div><div>Created boot failed.<br></div>

Any idea how to fix this? At the moment I am just using Backupper (which i also purchased) to do my backups, but as I only just bought all three like two weeks ago or so I feel the OneKey should be working.


  • @Mrfearless, Could you send us the log folder under the installation directory of AOMEI OneKey Recovery so that we check?
  • I found an C:\oklog folder as well that appears to have some OneKey log info, not sure if thats helpful.
  • @Mrfearless, Could you take  a screenshot of Windows Disk Management so that we check the layout of your disks? You can press Win+R, then run "diskmgmt.msc" to open your windows disk management.
  • Here is the screenshot of my disks:
  • @Mrfearless, We suggest that you can shink the C: drive to get an unallocated space about 60gb via window disk management or AOMEI Partition Assistant. After that, please run AOMEI OneKey Recovery to create backup again, and please select the unallocated space to create AOMEI recovery partition.
  • I shrank the c drive with Partition Assistant and that left me with an unallocated partition size of approx 162GB. After booting back up into windows I ran OneKey and it seemed to work and created the recovery partition and the AOMEI boot partition. It also left about 59GB of unallocated space. I presume that space will be claimed with any future updates? Either way it appears to have worked. Thanks for the help.
  • @Mrfearless, you can try to merge the unallocated space to C: drive.  
    And, if you set the boot menu, please also try to boot your computer, then press boot menu to see if you can boot onto the recovery environment.
  • I tried to update OneKey system backup today. Got an error message about needing to restart. So restarted and went into AOMEI recovery option from boot and it came up with a black and white text windows error screen about using installation disks to repair error. Exited out of UEFI mode and went into BIOS and forced to boot to windows boot manager and got back into windows. Ran Part Assist and seen that the Aomei recovery boot and Aomei recovery partition were gone. Tried to run the OneKey again, got same error about having to restart - Have 160GB unallocated space now for use with OneKey but its not working.
  • @Mrfearless, Could you try to run AOMEI OnekKey Recovery from Windows, and then create the backup again?
    Please select the unallocated space to create AOMEI Recovery Partition.
  • I ran it again from windows and the same error message came up. Also it doesnt allow me to choose the unallocated space, it simply shows me where it is going to place the recovery partitions when i click advanced.
    3.png 166.3K
    4.png 161.3K
    2.png 187.5K
    1.png 188K
  • @Mrfearless, Sorry for the inconvenience.
    Could you send us the log folder under the installation directory of AOMEI Onekey Recovery so that we check it again?
  • I resized the c: drive to fill up and use the unallocated space with Part Assist. After rebooting into windows I tried OneKey again, but it failed with a different message. I also tried saving the system image to a different location and got the same message about failing to reboot.
  • @Mrfearless, Could you allow us to offer remote assistance? If yes, please let us know what time zone or city you locate in and when you were free to apply this operation. 
  • edited July 2021
    I gave up on using this product. I uninstalled it. Quite annoying as I paid for it and expected it to work. I resorted to using the AOMEI Backupper which I also bought. But it turns out that this cannot create system recovery either. So I settled for just normal backups, but it turns out the scheduler doesnt run and setting it to use the task scheduler instead still doesnt execute backup tasks. Terrible products. I have had to resort to using the free Macrium Reflect as a way of backing up my partitions as even if I manually run the backupper program can I really be confident it will actually work if I ever needed to restore? The answer is NO. Would not recommend these products to anyone. Dont waste your money on them, go to any other product or tool out there.

  • @Mrfearless, " it turns out the scheduler doesn't run and setting it to use the task scheduler instead still doesnt execute backup tasks"----Could you try again? We will try to help you solve the problem. Is it ok?
Sign In or Register to comment.