Beware - AOMEI erased my source disk

I am not a happy customer.  AOMEI BackUpper just trashed my source disk. 

The sequence of events was I chose clone disk and then chose the source and destination disk.  The system was running off of the destination disk so I got a message from AOMEI saying it needed to restart the computer to do the backup.  After doing some file operations it tried to reboot my computer and I all I got was a cryptic error message. 

I rebooted the computer again and saw that AOMEI had wiped out the allocation tables on my source disk.  It now shows 1 terabyte of free disk.  It is frustrating because I suspect the data is still there but I cannot get to it anymore.

I wonder if there is any way to recover the data?   Apparently AOMEI BackUpper cannot keep track of which disk is source and which disk is destination after a reboot.

I miss the days of write rings on mag tapes or sliding tabs on floppies that can prevent stuff like this.

Comments

  • I am trying a recovery program named EASEUS.  It looks like the TRIM option is disabled so my data might be recoverable.  All I really need is my e-mail for the past four months>

    I think my issue was that I forced the computer to boot on the disk that was to be the destination disk to see how slow it was by disconnecting the SSD (which was to be my source disk).  I then powered everything off and reconnected the SSD disk and did a reboot.  I noticed that it still booted off of the HDD (destination disk)  and not the SSD but I did not think anything about it.   It made sense when it said it needed to reboot.

    I did look at the disk with a hex editor, HxD, and there is definitely still data on it. I am hoping the TRIM was disabled on that drive so it is not rearranging data on the "empty" drive.

    I am thinking the software should keep track of the disk serial numbers so it can be sure which is the source and which is the destination regardless of which disk is used as the C drive after a reboot. 

    Anyway fingers crossed - be careful if it says it needs to reboot.  Next time  I do a backup I will make sure it boots on the disk to be copied (the source disk).
  • @ERC, Could you boot from the target disk? So, the clone is completed? 
    Did you boot from the target disk and then check the source disk is free?
  • I am embarrassed.  I was running a much older version (like 3.2)  so this probably is not a problem anymore. 

    I did manage to recover pretty much all of my new files from the "empty" source disk using R-Studio.  The most important was my e-mail and bookmarks which I successfully recovered.  Under disk manager the source disk was totally free space (no partitions) after AOMEI rebooted my machine.  I could not boot from my source disk at all.

    I tried the free version of EASEUS at first but it took 2 hours and 30 minutes to scan the disk and then said my email storage files were 0 bytes.  I then tried the free version of R-Studio - it took like 2 minutes to build the file tree.  I went to the Mozilla Thunderbird folder for my inbox and clicked on the file.  R-Studio said the chances of recovery of the file were good so I plunked down $57.  I was extremely pleased how I could just go in and get the files I needed from the "empty" source disk.  I did not try a full recovery of the disk as it would have needed a more expensive version and I would be afraid of depending on a disk that was totally recovered.

    I did note that TRIM was enabled on the source disk but I suspect AOMEI Backupper went in and changed some bits to mark the disk as empty rather than actually deleting any files so TRIM did not get triggered.  Remember this problem happened when I was booted onto the destination disk when I launched the clone operation.  I am thinking it would be nice to build a WINPE CD (WINAIK?) so I can run Backupper without running into file in use problems.  I think others have done this so I am going to investigate.

    In any case I am happy camper again...
  • I see there is an option under tools to create a CD and it works.  Great product.
Sign In or Register to comment.