WIN10 PE bootable disk won't see main computer HD

I have a new Dell Inspiron 3881 running WIN Home which has a single 1TB HD. This is working well. I've made an AOMEI disk image of this HD on a USB drive and also created a WIN10 PE Bootable Disk on a DVD using the AOMEI PE Builder. To test this out (before I get any failure) I've booted from this DVD and this gets me to the AOMEI recovery environment just fine. However, when in this environment, the system will not "see" my main computer HD. So when I test out setting up a Restore  operation by plugging in my USB drive with the image on it, the main computer HD is not available as the target drive. In fact the only disk visible is the USB drive with the image.
I've used AOMEI disc images successfully in the past for recovery of other computers - what's gone wrong this time?
«1

Comments

  • Replying to my own post.......I've had a reply from AOMEI Support advising that I should add specific Hard Disk drivers to the PE Builder. They pointed me towards software called DISM++ to find and download suitable drivers. I have a Dell Inspiron 3881 desktop so did this and picked Dell drivers and added these to the bootable DVD made by AOMEI PE Builder.
    However, when booted from this DVD my Dell 3881 still won't recognise my HD.
    I guess I may have picked the wrong drivers for the Western Digital hard drive in the 3881. Does anyone know what the correct drivers are? They'll be on my HD under C:\windows\system32\DriverStore\FileRepository so if can just identify the right ones I can get them onto the PE boot disk
  • edited February 17
    In the left pane of dism++ click DRIVERS. Then tick Storage controllers and tick IDE Atapi Controllers. 
    Click Export to export the drivers from your running system into a folder.

    DELL3881-DISM++.jpg


    Otherwise, you could download from dell. They come as an exe file so first you need to extract it with 7-zip .

    https://www.dell.com/support/home/en-uk/drivers/driversdetails?driverid=ktg51&oscode=wt64a&productcode=inspiron-3881-desktop



  • Thanks for this reply.
    I successfully exported the IDE Atapi controllers files using DISM++ to a folder and then selected these 4 .inf files under the Add Drivers dialogue when setting up AOMEI PE Builder. I burned a new DVD from this - but when booted from this, it still wouldn't see the Dell's HD, either in Partn Assistant or in the Restore part of Backupper. I've also tried the Dell link and downloaded:  Intel-Rapid-Storage-Technology-Driver_KTG51_WIN64_17.9.1.1009_A03.exe.
    I unzipped this with 7-zip and got a number of files, including SetupRST.exe.  The only  .inf files are in a sub folder F6 and sub-sub folders  f6flpy-x64, HsaComponent and HsaExtension (one .inf file in each sub-sub folder)
    Which of these should I add to the WINPE builder disk?
  • edited February 19
    Which of these should I add to the WINPE builder disk?
    All of them.

    The official dell media for your machine has a lot of drivers included in the bootable wim files.

    Storage controllers

    Ide-atapi controllers

    I suggested exporting both the the storage controllers and the ide atapi drivers from your running system using dism++


  • Thanks for this reply.
    I successfully exported the IDE Atapi controllers files using DISM++ to a folder and then selected these 4 .inf files under the Add Drivers dialogue when setting up AOMEI PE Builder. I burned a new DVD from this - but when booted from this, it still wouldn't see the Dell's HD, either in Partn Assistant or in the Restore part of Backupper. I've tried the Dell link and downloaded:  Intel-Rapid-Storage-Technology-Driver_KTG51_WIN64_17.9.1.1009_A03.exe.
    I unzipped this with 7-zip and got a number of files, none of which are .inf files but include SetupRST.exe. Which of these, if any should I add to the WINPE builder disk?
  • Thank you for your reply. Do I need to use dism++ to export these drivers or can I just use the "add file" or "add driver" dialogues in the WINPE boot disk builder to copy these files from the HD?
    I ask because when accessing these driver files using dism++ I only get the option when clicking "Export" to save the files in another folder. I then add these files u
  • Try exporting the storage controllers and ide-atapi with dism++.

    Then add them with the aomei pebuider.
  • Thanks again. Sorry to ask what may be a stupid question, but AOMEI WINPE builder has 2 options: "Add Files" and "Add Drivers". "Add Drivers only selects the .inf files, whereas "Add Folders" allows all (eg .sys) files associated with an .inf file to be added.  Which is best to use, or doesn't it matter?
  • edited February 14
    inf files contain the info about the registry entries that need to be created and which other files need to be included, so they are copied to the correct places. Not unusual for a pebuilder only to ask for the inf location.

    Yes, it does matter.

    Use the Add Drivers  function.



  • Thank you once again and I've now made a new WINPE boot disk using AOMEI PE Builder, and added to it (using "Add Driver" and selecting them one by one) all the .inf files that I exported to a folder using DISM++ under IDE ATA_ATAPI controllers and Storage Controllers.
    I had high hopes of this but once I'd booted to this disk I found that I STILL couldn't see my Dell's main HD.
    Can anyone advise me what's going wrong - or what I'm doing wrong?
    At the moment the image of the HD that I made with AOMEI Backupper is useless because I can't access the HD to restore it. I've restored without trouble several HDs on previous computers from AOMEI images so I don't understand what is different about this new Dell 3881.
    BTW after one general reply from AOMEI Support saying "use dism++", I have no further input from them to my request for support.
    Maybe I'd be better with other imaging software suites. Does anyone have experience of successfully making a WINPE boot disk for a Dell 3881with other imaging softwares?
  • edited February 14
    You can borrow mine. I will upload it and link it when done.

    I am not sure why you are having that issue. Did you let the pebuilder use winre - or did you download the winpe ?

    The winre.wim file you already have as part of your dell windows installation should contain any necessary divers.
  • edited February 17
    You can give this a try. It is named 190A.iso
    edit fixed: 1904FIXED.iso

    https://1drv.ms/u/s!AkcyDjKJJ6KwiF7AGroOWqot4Jtf?e=glAhyl




  • Thank you for these iso files. I've now burned each of them to DVDs using WinISO but, unfortunately, when I try to boot from them in my DVD drive I get the "no bootable media found" message.
    I can boot OK from the DVD made with AOMEI WinPE Builder but of course it doesn't see my HD!
    I've also my Windows folder for winre.wim but it was not found.
    I think winpe was downloaded when I  downloaded and installed AOMEI WinPE Builder.
    I do appreciate your help in trying to sort out this issue.
  • edited February 14
    It is better to create bootable usb stick for 190A.iso. Because some of the programs are not in the wim and should run off a usb stick.

    You can use usb7ice to create bootable usb from iso file . The default seetings are fine. Just point it at the iso and select your usb stick in the dropdown.


    Usb7ice.zip


    usb7ice.jpg


  • Thanks once again.
    A problem with using a bootable USB stick (as I first tried to do when I got the Dell 3881) is that, despite seeking help from Dell support, I can find no way to add booting from USB to its boot menu! In the BIOS/UEFI setup, there is a file to select to add booting from DVD, but no file for booting from USB. 
  • If the pebuilder says your current system supports creating the bootable media  - do not tick the box to download.
    Just click Next. Then you shouldn't need to add drivers.

    PEBUILDER.jpg
  • Unfortunately the AOMEI PE Builder requires me to tick the box "Download WinPE creating environment...." Otherwise the Next button becomes inactive.
    So I guess my system does not have any built-in support for creating bootable media.
    I'm going to have another go at adding drivers and making a new boot disk
  • You might be able to fix it. From an administrator comand prompt, type:

    reagentc /disable

    then press enter

    reagentc /enable

    than press enter
  • A further comment about booting from USB......I've now made a Dell recovery bootable USB stick using the Dell OS Recovery application.
    With that USB stick plugged in I could at last select booting from USB in the boot menu and the system booted OK into the Dell recovery environment. However, this only returns the computer to its initial factory state, unlike restoring from an AOMEI image.
    I could not previously find a USB boot option when I had an AOMEI PEBuilder bootable USB stick plugged in. Whether that will now change when an AOMEI boot USB stick is plugged in I don't know. I will test this as soon as I've procured a new USB stick (I used the only one I had spare to make the Dell Recovery USB).
    I'm not a novice with computers and have been messing with them since the early 1990s, and have recovered a quite few using AOMEI images. But I've never had a system as un-intuitive as this Dell one!
  • edited February 15
    Did you mange to fix the bcd recovery sequence using reagentc commands ?

    If you can get aomei to use the winre.wim, it should work fine. But the recovery sequence needs to be set up properly, which reagentc is supposed to do..
  • I've tried the reagentc commands from the Admin command prompt. Each command was successful but unfortunately it made no difference to AOMEI WinPE Builder which still required me to tick the "Download WinPE creating environment..." box before i could move forward. 
  • Or do I need to reboot after completing the reagentc commands?  I'll try that next (probably tomorrow)

  • Rebooting after the reagentc commands didn't help.
    However, I've now made USB boot drives using RUFUS and SIW2's 190.iso and 190A.iso files. These were indeed bootable and at last the Dell 3881's BIOS setup gave me the option of selecting USB booting to add to the boot menu.
    (As an aside, it is now clear to me that the Dell ONLY allows selection of USB booting when a bootable USB is actually plugged in during the initial startup sequence when you select the BIOS setup using F2. This seems counter-intuitive to me, since the BIOS does allow setting up a DVD drive for booting without a bootable DVD being present in the drive).
    So with the Dell booted from USB's made from 190.iso or 190A.iso and the computer showing me a recovery environment, I thought I was home and dry. However, although everything else worked in this booted environment, and I could "see" my main Dell HD in Partition Asst, AOMEI Backupper did not work! It just gave various error messages (from "unknown error" when you started it, to "can't find the image drive" when it did occasionally start without the initial error message.
    So I then thought I'd try making a bootable USB using AOMEI WINPE Builder (I'd tried this before but thought I'd give it another go). This appeared to go ahead and complete successfully but, when I tried to boot from it, it was unbootable and, of course, would not even give me the option to select USB booting in the BIOS setup.
    The next thing I'm going to try is to get AOMEI WINPE Builder to make and export an iso file and then use RUFUS to mount that on a USB drive.
    Meanwhile, I do have the Dell bootable USB made with their OS Recovery application, but this only allows me to recover to factory state and of course relies on the recovery partitions on the hard drive still being usable.
    This has been the most frustrating process I've ever had with any computer I've owned trying to set up a proper recovery strategy.
    If anyone can suggest other actions I can take, I'll truly appreciate it.
  • My mistake. I have fixed it now. Will upload new iso.
  • Thank you - I've now mounted the fixed iso onto a USB drive and successfully booted from it.
    Backupper opens OK from this environment (although it looks a bit different from the normal Backupper environment). However, when I test click "restore" it claims that it can find no image to restore from, even though I have the USB drive with the image plugged in. 
    I've now tried a different backup application - Macrium Reflect. I've created a boot CD with this and, on loading this, the environment does allow me to "see" my HD. I've made an image of the HD with Macrium and the booted environment enables me to access this image for restore as well. 
    So, unless I do find a resolution,  I think I might ditch AOMEI, at least for my new Dell. A shame really because it still works well on my other computers - Thinkpad and HP laptops and an old Compaq desktop. I also bought a new licence for AOMEI on the Dell so that may end up being wasted.
    Anyway, many thanks for all your help.
  • Postscript - I've realised that the Macrium restore environment does not give access to a Partion Manager or to a Command Prompt. The 1904FIXED.iso made boot USB does give this access so I may still need to use it before a restore, to clean the HD with Dispart, and after the restore, to ajust drive letters (if necessary).
    So thanks once again
  • "when I test click "restore" it claims that it can find no image to restore from".

    You can browse to the image you want to restore. I always do this with any of these kind of programs.

    aomei-restore.jpg


    aomei-restore2.jpg


  • I also thought I could do that, but when booted to 1904FIXED.iso on a USB stick, I get the screen shown in 0940.jpg. Then when I click on Backupper I get 0941.jpg which is not the normal Backupper interface. Clicking on the menu on the RHS gets to 0942 and then clicking on Restore gets 0943, with no option to browse for the image drive.
  • edited February 18
    That is because you are on the Home screen.

    Click Restore in the Left pane as in this photo





    Now you are at the Restore screen, click "Select Image File"




    Then browse to the .ADI file


Sign In or Register to comment.