Using PXE boot for restores

Given our current covid lockdown status, it would be nice to be able to do restores remotely instead of going to PC with a USB key.  So I've been experimenting with PXE boot options.  I built a Virtual Box VM with no OS installed and set it to network boot.  Then I used the PXE option in Backupper 6.2.  That worked well - I was able to restore an image to the VM, and doing it this way, there's less worry about drivers on the target machine.

The problem is this: if machines are configured to always try PXE boot first when they are in their normal install location, then any PC in the subnet that happens to be rebooted while some other PC is being imaged will end up doing an unwanted PXE boot.  The usual suggestion is to put any machines in need of imaging in a special subnet, but that doesn't fit the image in place operation we're considering.  So it would be nice if there could be a way of controlling whether the PXE server would answer, perhaps based on hardware address.  (Yes, I know that won't work if we're crossing subnets.)

I thought the PXE server also was a DHCP server, but when I disconnected the network cable from the machine running the tests, the VM did not get an address by DHCP.  Maybe that's just a quirk of the Virtual Box networking, and maybe it doesn't matter in the real world.

Also, when I pulled the network cable, registered Technician Pro warned that it was an expired demo.  USB boot media doesn't seem to do this when it doesn't have network access, so not a big deal.

Comments

  • @Wssddc, PXE tool indeed use the DHCP server to assign the dynamic IP address for the client computer.
    "when I pulled the network cable, registered Technician Pro warned that it was an expired demo. "---Did you mean that you disconnect the network of the computer that you run PXE? or the client computer?
  • I pulled the cable on the physical computer.  Backupper and VirtualBox were running on the same machine for these tests.  (VirtualBox is irrelevant for the expired demo message.)
  • @Wssddc, Did you mean that AOMEI Backupper running on the physical computer warned that it was an expired demo? Could you reinstall and register AOMEI Backupper again?
  • I don't think I made it clear. When I reconnected the network and restarted Backupper, it said it was registered properly. I assume that means it's "phoning home" to verify the license. That doesn't really bother me, but I worry what would happen if the verification server was unreachable for any reason.
  • @Wssddc, This is strange. If you have registered AOMEI Backupper, it should keep register, even though disconnect the internet. Could you disconnect the internet to try again?
  • I just tried again. With network active, BU says I'm running Technician Plus as expected. Restarting BU with no network, it says Server Trial and expired.  USB boot keys do not seem to expire.
  • @Wssddc, Have you tried to reinstall and register AOMEI Backupper? Please first uninstall AOMEI Backupper manually via Control Panel, and then check and delete all registry items of AOMEI Backupper according to the following link (method 2). And then, please reboot the computer to install and register again.
    https://www.aomeitech.com/kb/backupper/failed-to-install.html
  • After registry cleanup and reinstall, I no longer see the trial expired error when starting Backupper with no network.  As part of the cleanup, I deleted an old 5.8 directory that had only a few files, maybe that contributed to the problem?  I got the notice that 6.3 was available while doing this test, so I did the upgrade.  6.3 also does not complain when the network is unavailable.  So this is resolved.  Thanks.  Now I have a bunch of 6.2 boot images to rebuild with 6.3...
Sign In or Register to comment.