Cannot safely remove my external drive

edited December 2020 in AOMEI Products Support
I am using  Aomei Backupper Standard version. Whenever I plug in my external drive, I cannot safely remove when I am done. 

Whenever I open the Backupper, even if I do not start any backup task and the Backupper is free, I cannot eject my external drive I assigned for backupping.  Tried to stop the service but it did not solve the problem. 

I am pretty sure this is because of Aomei Backupper and not from any other application.


Comments

  • Hello Ural,
    Sorry for the inconvenience. Our technician is analyzing the problem.
    Once there is any progress, we will tell you immediately.
  • Hi! I had the same "issue" until i realize that Windows 10 (last update) doesn't need user to eject external disks anymore... ;)
    If you're not tranfering any data, you just have to unplug your external drive.
  • Wait a minute....
    I would think this declaration would be contingent upon the disk device manager(disk device properties) specification.
    Depending on this setting, the ability/need to programmatically detach the device, or simply manually detach the device, has (almost)always been present. If you prefer to just "yank" out the USB device, you probably better have
    the "quick removal(default) assigned/defaulted".

    I also noticed this change when migrating to BK6.2. Although my USB devices are all "quick remove", a programmatic
    detach will now result in the failure message. It wasn't that way on BK6.1. But, it could be related to the interim OS
    changes instead, rather than BK6.1.

  • I have exactly the same problem as Ural. I don’t think it’s a good idea to unplug the external drive without safely ejecting it because the external drive seems to be running and feels hot to touch. I tried to eject/uninstall external drive using  Disk Management but was unsuccessful. I hope there’s a way to resolve this issue. Thanks. 
  • Hello,
    @Mae @Ural, We have fixed the problem. Please download and install the new version to check.
    AOMEI Backupper Standard:
    https://drive.google.com/file/d/1cfjOXTwMuwBVSOiqxv2_5baN0a5PxuHs/view?usp=drivesdk
    If you purchase a license code, you can use it to register on the standard edition.
  • So far with the link it seems that the problem has been fixed

  • I have this exact same problem but I'm using the Professional Edition version 6.3.0.

    Is there a fix for the Pro version?
  • @Rchang24, Please download the fixed version from the link. And then, please still use your license code to register.
    https://drive.google.com/file/d/1G15bdxG187CqhZRbNBgM1D1kcmzV6FlS/view?usp=drivesdk
  • That worked! Thanks.
  • edited January 12
    Have the same problem,   

    Professional Edition version 6.3.0. on Windows 20h2 image 19042.685. 

    Got the version from their link as mentioned above in the post. Remedy unfortunately none. 

  • @Longlife, Did you mean that you still have the same problem with the version from the link?
    https://drive.google.com/file/d/1G15bdxG187CqhZRbNBgM1D1kcmzV6FlS/view?usp=drivesdk
  • Vielen Dank für die Antwort Adminstrator. 

    Ja immer noch gleiches Anliegen mit der Version.
  • I have the same issue... Cannot safely remove my hard drive.

    I use a hot swap bay, and, hard drive.  When The backup is done, I use HotSwap! to saftley remove the drive.  I've been doing this for several years.

    After the Backupper 6.3 update, I receive...
    Problem uninstalling 'drive name' SATA Disk Device cannot be uninstalled right now because the device requested a system restart.

    The drive dissapears from FileExplored and 'Disk Management'.  But, I restart the system, then I can saftley remove.

    I tested with 3 different HD's, on 2 desktops each running Backupper 6.3.

    I can use use any other method & program to caopy/backup, and, saftley remove with no isses.

    I also tested by re-installing 6.1, but same issue.  So, there are probably reminents left causing this.
  • Additional information...

    This occurs ONLY when an external drive is mounted (Hot swap or USB), then Backupper is started.  Or, Backupper is started, an external drive is mounted, and Backupper rescans.

    If Backupper is started & exited, then an external drive is mounted.  It can be safely removed.
  • @Run2TheWell ;

    A support request with log as in the instructions is requested :

    There is a "log" folder, you can find it in the installation directory of the AOMEI Backupper(Such as C:\Program Files (x86)\AOMEI Backupper )
    Or you can also find the “log” folder by right-clicking on the shortcut icon of the AOMEI Backupper then click the “Open file Location” option then you can find it.
    Please compress the “log” folder to a ".zip" file and send it to us, thank you
    If you have any other questions or suggestions, please feel free to contact us back.
    Stay healthy and take care!

    Es gibt einen "Protokoll" -Ordner, den Sie im Installationsverzeichnis des AOMEI Backupper finden (z. B. C: \ Programme (x86) \ AOMEI Backupper).
  • @Longlife, What operation did you perform when you use the version we offered from the link? Backup? Or Clone?
    https://drive.google.com/file/d/1G15bdxG187CqhZRbNBgM1D1kcmzV6FlS/view?usp=drivesdk
    @Run2TheWell, Could you try the new version to check if the problem still exists? Please download the new version from the above link.
  • Administrator;  

    From the link download, running file, Aomei was Uninstalled Automatically -then Installed Devices Restart-Full Backup. 
  • @Longlife, Could you allow us to offer a remote check on your computer?
  • edited January 19
    Warum willst du das ?
    Wurden Sie vom AOMEI Support Team autorisiert? 
  • @Longlife, Could you allow us to offer a remote check on your computer? We will contact our technician to check and analyze the problem further in your environment. If you agree the remote, we will contact you via email further.
  • edited January 20
    @admin, Please suggest an appointment by mail.
Sign In or Register to comment.