Updating Backupper from 5.6 to 5.7 causes problem with Adobe Reader DC and AOMEI User Manual

I clean installed W10 earlier in the year and installed version 5.6 (then current version) of Backupper Professional. All was good.

When updating version 5.6 to 5.7 a curious issue arises. The installed PDF User Manual for Backupper is no longer reachable via the AOMEI interface. Having clicked  'User Manual' it is then apparent that this operation partly initiates Adobe Reader DC (it can be seen running in task manager) however Adobe will not from that point on open any PDF from any source. 

The only way back from this is either a reboot or to terminate Adobe in Task Manager. Having done this Adobe operates normally for all pdf's excluding the link from AOMEI interface.

The user manual pdf located in program files for AOMEI opens normally if accessed directly from program files so it is not itself corrupt.

As confirmation of this issue I restored back to a disk image where 5.6 was still installed. All worked OK once again. I tried updating this with a fresh copy of version 5.7  and again the same problem. The 'User Manual' link breaks Adobe Reader DC.

  

Comments

  • Using Backupper 5.7 Pro and cannot confirm this problem.
    I am able to open the Manual from within the GUI.
    Perhaps it is a quetions of Permissions.
    Do you have Full Control rights to the map of Backupper?
    This map is c:\Program Files (x86)\Aomei\AOMEI Backupper 5.7.0\
    In File Explorer right click on this map, then go to the Security tab and check out that you (as a user or as an administrator) have Full Control of this map.

    Also do you run Backupper as administrator?
  • Thanks. I seem to have full permissions enabled and yes, I run Backupper as Admin.

    I've updated AOMEI in the past on previous installs and never encountered this issue before. And that is the point the problem appears, before updating it is OK, after updating it is broken.

    Everything else within the program is fully functional.


  • Then I would suggest complete uninstall (keep license/registration key if you bought Pro version). Reboot and clean out the installation folder and the data folders of Backupper.
    Then reinstall, hope that helps....
    And of course you do this after you make a backup with Backupper :smiley:
  • Thanks, I'll have a think about that... not that I worry over what will happen, as I make daily backups.

    I think?? the latest W10 version is due to be released this week and so I might just clean install the lot when that happens.
  • Further update... just for info really.

    I tried uninstalling using the 'Uninstall' application within AOMEI's program files. That returns a not possible warning as it applies to Tech Plus version only. So I use the normal WIndows control panel method. That uninstalls OK but says that all elements of the application were not removed and to manually uninstall them. The AOMEI folder is gone so presumably it means registry entries and the like. I didn't pursue that but just installed a fresh copy of 5.7 again.

    No pdf manual as before.

    Next (and for no good reason apart from the fact I change a default to use AOMEI VSS and not Microsoft) I go to settings and select 'restore  defaults'.

    The pdf now opens correctly time after time. That's weird.

    I go back to a disk image just made and try the reset defaults thing. It doesn't work on the original image.

    So something buggy is going on. I start with 5.6 and update to 5.7 and it's broken. I uninstall 5.7 and reinstall while resetting the defaults and it works. Bizarre to say the least.

    Oh yes, I also got a warning when reinstalling over the top that the pdf manual was open in Adobe (and of course it wasn't, Adobe freezes and won't open anything once its locked up). So all a bit weird.   
  • @Mooly ; Actually, we don't change the 'User Manual link' in v5.7. This indeed is weird. 
    We have submitted the problem to our team to check further.
  • @admin Thank you, although I now have a further update on this.

    Microsoft released the latest W10 version in the last few days (called version 2004) and I upgraded using the Media Creation Tool and bootable flash drive.

    Having done this I now found the pdf opens correctly... which is very very strange but that is what has happened. So the W10 upgrade has changed something related to this.

    I suspect this will be something we just never find a logical reason for. 
  • ;Mooly Thanks for your feedback. We indeed detect there are some errors in some environments. We will optimize it asap.
  • edited June 19
    Just to add to this and following on from the above post.

    Backupper has just prompted me from the user interface screen that a new version is available (5.8) and which I have just updated to.

    The user manual is again non reachable and Adobe Reader DC 'broken' exactly as happened before with the earlier AOMEI update.

    Edit... A further issue seems to be apparent following this update. I'm noticing that the time taken for a 'restart' is consistently high (as if something is hanging) and is now consistently at 60 seconds from hitting 'Restart' until the PC actually restarts.

    I have restored back to a disk image made yesterday to undo all changes made by this update. All is now as it was before. The pdf manual opens correctly and restarts take an average of 10 seconds to commence.

  • @Mooly ;
    As for the restart time, our technician is checking and analyzing the problem. Once there is any progress, we will tell you immediately.
    As for Adobe Reader DC, sorry that v5.8 hasn't yet fixed the problem. We will submit the problem to our dev team again.
  • Thanks for looking into the issues. 
Sign In or Register to comment.