Weird occurrence

edited January 17 in AOMEI Products Support
Hello, I just had a weird thing happen. I have two external disks, 1 Seagate 2TB (Drive I), and one Goflex 3 TB. (Drive E). I had been having some problems recently with the Drive I disk when connected to the 3.0 usb. My computer would go to the Black screen with blinking cursor, after the BIOS splash screen. It took awhile to realize, if I waited long enough it would finally boot into windows 10. Since there was only a small amount of Data/files on this drive I thought I would just backup those files to the larger E drive. I used AOMEI Backerupper free version for this. I have used it for years now..no issues. I started the backup process. It was going pretty slow. Later I don't know how long, I came back to shut down the CPU for an errand I had to run. Honestly I forgot about the backup job I had started. I don't know if it finished. When I returned, I checked the drives in My PC and found the I drive was gone..not listed. I then checked the destination drive E to find a file with the name I had given my latest backup but it wouldn't open. When I clicked on it nothing happened.

So I decided to open the Backerupper program from the task tray. It hung up.. Got the loading screen..as I just did again. the interface was visible but it didn't open. I checked the task manager to see if it was non responding, and found the process had a very high usage red indicator, but still responding. Since I was stuck at this point I selected "end task" from task manager. I then retried to open the program, of which it did. It listed the back up, but when I tried to open or check it I was told it did not exists. I next used the utilities to check the image as nothing else would recognize it. After a lengthy search it went into a "reload Disk" function with a green bar going at pace from left to right. Afterwords nothing else was indicated to proceed, no results were shown. I re booted the CPU only to find the drive I was still missing from my list. I then shutdown the Computer and disconnected the I drive. After booting back into windows I checked the drive listings and low and behold both external drive were gone from the list!

I again shutdown. Checked the USB connections it was good..The remaining external Drive is connected USB 3.0 and has worked fine for years. Upon booting up this time the BIOS splash then black screen..no cursor this time and no OS. I shut down and retried same results. I did it a third time left the room for awhile and when I came back my desktop was showing I checked the drive and still no Drive E I had previously disconnected the drive I.

Any ideas on what is going on here? Have I just lost all my Backups?

Comments

Sign In or Register to comment.