Win7 bluescreen after cloning SATA SSD DATA drive (???)

This is unlikely to be a specific Aomei problem, but maybe someone knows what's going on.

So I have a laptop with a 512MB PCIe M2 SSD and a 1TB SATA 2.5" SSD. Initially installed it in such a way that I dualboot between Win7 Pro (system partition on the PCIe M.2 SSD), and Win 10 Pro (system partition on the SATA SSD).

These are all SAMSUNG SSDs. I then recently acquired a 2TB SAMSUNG SATA SSD to replace the 1TB SSD.

First approach I tried was using the Samsung data migration software from within the Win10 installation, to clone at least the Win10 partition. This reported that it wouldn't work. (failed right at the end)

Then used Aomei Partition Assistant free version to clone the 3 first partitions (ssd alignment and sector options checked), (2 small ones and the Win10 system partition)

However, when I then replace the 1 TB with the 2 TB SSD, not only does Win10 NOT boot (bluescreen with repair options), even the Win7 only STARTS booting, then fails with a bluescreen.

When I go back to the original situation, boot into Win7, remove all Win10 boot entries, remove all driveletters from partitions on the to-be-replaced 1TB SATA SSD that I approach from within Win7, I STILL get the bluescreen when I replace the 1TB SATA with the 2 TB SATA. EVEN when I remove all partitions from the 2 TB SATA.

When I remove the SATA SSD completely (just the M.2 PCIe SSD with the Win7 system partition and some data partitions in the system), I get diskcheck warnings but can boot into Win7 without issues.

So somehow somewhere it seems the original 1TB SATA SSD is still referenced, but then why do I manage to boot Win7 when NO SATA SSD is in the system????

I would like to avoid having to reinstall the OSes to be able to use this 2TB drive...  :(

Comments

  • Did you use the Disk Copy or Partition Copy?
  • Partition copy, mainly because there's a +300GB normal partition AND a 400+ encrypted partition on there as well, which I did not intend to migrate completely this way (would take too long over USB?).

    So it's worth trying an "overnight" Disk Copy instead? Does that copy the existing partitions, and then just leave the final 1 TB of the disk "empty"?
  • Partition Copy will not make a bootable clone, please use Disk Copy or Migrate OS to SSD.
  • OK, so I tried the Disk Clone option, "quick" with SSD optimisation and no changes to the existing partitions (just empty space at the end of the new 2TB disk)

    The operation was reported as successful, but the behaviour after switching the disks was exactly the same...  I think I'm out of luck, because yes I could still try the "migrate OS to SSD" , but the only one that is being MIGRATED is the Win10 Pro install, while the Win7 Pro system partition remains untouched on the M.2 SSD. But even THAT one crashes, so that's not going to help me...  :(

    A "sector-by-sector" Disk Clone is the other thing I could still try, but that's going to take an ETERNITY over USB, and I'm not sure it makes sense that it would make a difference?
  • This somehow must be caused by the somewhat complicated setup I have, I guess... Should have known that this would cause trouble down the line, lol...

    So basically what I have in my laptop is this:

    512 GB M.2 PCIe SSD - first regular partition is Win7Pro
    1 TB SATA SSD - first regular partition is Win10Pro

    The Win7Pro system partition is encrypted with TrueCrypt. When I boot the laptop and provide the password, I get into the ("Windows7-era") black text-only boot-selection screen where I can choose Win7 (default) or Win10.

    I still remember that it took a couple of attempts to get this to work correctly, with Win7 not being able to be installed/boot from PCIe SSD by default and such... Since this is almost two years ago, I don't remember all the details of what I had to go through, though.

    But the strangest thing AFAIC, is that I AM able to boot into Win7 when I COMPLETELY remove the SATA SSD from the system, yet it blue-screens as soon as I put the 2 TB SATA SSD into it, even when there are no partitions on it???? That makes no sense to me!! (obviously I'm just missing some intricate details of how the whole thing works...)
  • BIOS settings:
    - LEGACY "boot list" instead of UEFI
    - "M.2 PCIe SSD" listed before "Internal HDD" in boot sequence
    - "AHCI mode" SATA operation
  • When booting the Win7Pro while the 2 TB SATA is attached, I get a "UNMOUNTABLE_BOOT_VOLUME  blue screen after it starts booting Windows.

    When booting the Win10Pro, it's a "Recovery -  Your PC/Device needs to be repaired"  "required file missing or contains errors"

    File: \WINDOWS\system32\winload.exe
    Error code: 0xc000000e
  • Please try AOMEI Boot Repair to fix your system.
    https://drive.google.com/file/d/0Bx1HyPJEMTrNNzBkaFo2TDRCZ00
  • Well, I plan to reinstall the complete system when Windows7 goes out of support sometime next year. However, until then it remains the OS that I need to use. So my priority right now is actually JUST to be able to use the 2TB SATA SSD to extend my storage capacity while using Windows7. I can leave the Windows 10 aside for a while.

    From that point of view, "bootability" doesn't seem to be the problem:

    - with ONLY the M.2 SSD in the system, Windows7 boots AND functions correctly
    - with the M.2 SSD and my original 1TB SATA SSD in the system, everything functions correctly
    - with the M.2 SSD and the new 2TB SATA SSD (even without any partitions on it), I get the boot selection screen, I get Windows7 to start booting, but THEN I get the bluescreen with "UNMOUNTABLE_BOOT_VOLUME"

    This seems to indicate to me that the issue is not found anywhere in the boot sectors (?)

    Anyway, I also understand that this isn't an AOMEI issue, so I already appreciate your involvement!


  • BCD store needs fixing. That's rather common problem after cloning.
    Boot from windows installation media/command prompt and execute:
    bootrec /rebuildbcd.

    Regards,
    Adrian
Sign In or Register to comment.