Client won't connect Image Deploy Free

My unit just replaced a bunch of old laptops with thirty Dell Precision 3510.  Already have one configured the way we need it just need to clone that disk to the rest.   Already created the disk img with backupper but having difficulties getting the clients to connect via Image Deploy Free (IDF). I have 16 laptops connected via a switch, 1 server/15 clients.  The "NAS" with the disk img is just a shared folder on the server laptop.

Initially, I tried allowing IDF to create the WinPE automatically.  The clients all loaded w/ PXE, downloaded the WinPE iso but the clients didn't want to load the PE.  Instead I got a blue troubleshooting screen.  A bit of research said that the NIC driver was probable at fault.

Round2, found the .inf in my system files for my ethernet connection, created a WinPE manually through IDF and added the driver.  Progress, this time the clients loaded the PE.  Unfortunatly, the loop never completed. the server still showed them all as "The system is booting."  Couldn't push the image.  I did note that no scripts ran when the PE loaded but wasn't sure if they were supposed to or not.  Bit more digging and found that the server firewall might be blocking the clients telling them they're ready.  

Round3, Shut down firewall as well as antivirus on the server laptop.  Same results as before.  Everything seems to run fine.  But the server never updates with the clients being connected.

Round4 to I'd drop kick this laptop if it were mine!  Tried creating PE with every INF file remotly related to network anything.  Tons more combinations.  Even tried creating a PE with every INF file in the system folder.  All with the same results as above.  

Dell packages their drivers as an executable.  Tried finding a way to extract the INFs from that.. still same results.

I'm not sure if I'm using the incorrect INFs, if there some random setting that might be preventing the server from hearing the clients, or what.  If anyone could enlighten me on possiable solutions I'd greatly appreciate it.

Comments

  • Resolved - it was a driver error.  Finally found a driver that worked for the NIC
Sign In or Register to comment.