Restoring SysPrep Generalized Image w/ AOMEI Fails While Acronis Succeeds Fine

I'm an IT guy for a small business using Backupper 4.6.2 on their PCs.  They have some units they want to upgrade to Windows 10 x64 1809.  I have a clean EFI image I built in VirtualBox that I've sysPrep Generalized.  I backed up the image w/ AOMEI and had AOMEI successfully verify the image as well.  All restore efforts I mention below I booted AOMEI in EFI mode...never BIOS mode.  I restored the image to an EFI destination Desktop PC with AOMEI.   However, Windows 10 halts on "Windows Setup could not configure Windows to run on this computer's hardware."



The Windows setup error log has the following entries:

TOOL   BCD: Failed to get system partition. Status: c0000452
[0x0e00b3] TOOL   Sysprep_Specialize_Bcd: There was an error opening the system store. Status=[0xC0000452]
SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'Sysprep_Online_Specialize_Bcd' from C:\Windows\System32\spbcd.dll; dwRet = 0x3bc3
SYSPRP SysprepSession::ExecuteAction: Failed during sysprepModule operation; dwRet = 0x3bc3
SYSPRP SysprepSession::ExecuteInternal: Error in executing action for Microsoft-Windows-Sysprep-SpBcd; dwRet = 0x3bc3
SYSPRP SysprepSession::Execute: Error in executing actions from C:\Windows\System32\Sysprep\ActionFiles\Specialize.xml; dwRet = 0x3bc3
SYSPRP RunPlatformActions:Failed while executing Sysprep session actions; dwRet = 0x3bc3
[0x060435] IBS    Callback_Specialize: An error occurred while either deciding if we need to specialize or while specializing; dwRet = 0x3bc3

To rule out the Desktop PC in question I tested a restore to a laptop unit instead and observed the exact same problem.  Though AOMEI is acting as if it has the controller drivers during these restores, I also attempted the restores in RAID mode, AHCI and IDE mode.

I've never had to "universal restore" before as I prefer to use clean sysprep generalized system images.  Their version of AOMEI supports universal restore so I thought I might try that as a last resort to try and overcome this snaffu.  What's odd is when I boot into the AOMEI WinPE environment I see the dropdown for "system restore" or "universal restore."  However there aren't any backups pre-listed in the menu.  I browse to my backup and when I select my backup I'm launched into the next screens and none indicate universal restore is still selected.  Below are screenshots of what AOMEI indicates it's supposed to look like during the process yet in my case the "operation summary" menu only has "align partition to optimize for SSD."  In my case the "universal restore" designation that cannot be seen on that menu.





I have a colleague who has Acronis license for their IT WinPE boot disc so I called him over and backed up and restored the image without incident on the same PCs in question.  I didn't have to universal restore or make custom selections.  I'd like AOMEI to work instead of switching to Acronis.  I appreciate your guidance to sort this out.

Comments

  • Okay, well,

    I have two Windows 7's of 32 Bits and another of 64 Bits more sysprep in generalize mode.
    I created a "Disk Backup", because with System Backup" Aomie Backuuper at least with me is not recognized via sysprep.
    These two systems have Office and the daily programs that we all use.

    So much in VirtualBox and four real machines that I did restore them all worked. I just didn't do UEFI testing, because I don't even have machines with this technology!
    PS. I have AOMEI Backupper Technician Plus and in my layout it also worked with AOMEI Image Deploy. As I did in "Disk Backup" then it is restored as "Disk Backup" on an unallocated hard drive.


  • @vagn_32   Gotcha.  Yeah I'm convinced it can work with Windows 10 1809 if tweaked somehow.

    You noted you could never get AOMEI to do "system backup" on any of the sysprep images.  It would seem that remains unchanged since I also attempted that and it always returns Information Code:4098 and doesn't even progress to backing up data as far as I can tell.
Sign In or Register to comment.