How to Re-access a Denied Image Folder after Backup?

Recently, I have seen some AOMEI users encountered with the same problem---no accessing to some folders in the image after backup. They put their problems on our forum and get immediate help form others, especially from our moderators. Our friendly and knowledgeable moderators have given more than one solutions. Here, in order to give convenience to the future users who may have the same problem, referring to the previous posts, I made a summary of those solutions.

Solution1: It may be ACL (access control list) issues.  Windows uses ACLs as a more robust expansion of the older file system idea of file attributes (read only, system, archive, hidden) from the FAT days.  If browsing a mounted backup, the file system will be read only.  This will prevent users from making permanent changes, but if users are lucky, they could still take ownership even if the change isn't saved on the mounted image.  

1.  When browsing the non-accessible folder, right click on the documents folder, i.e. x:\users\michael\documents, and then choose properties.  

2.  Choose the Security tab.

3.  Click Advanced.

4.  On the new window that opens click Owner.

5.  Click the Edit button.

6.  If you see your user name in the list, select it then click Apply.

7.  If not click the other users or groups button.

8.  Add your user name to the list.

9.  If prompted to apply to the folder only or the folder and all subfolders and files, choose all subfolders and files.

10.  After this completes your user account should have ownership of the files.

11.  On the advanced window click the Permissions tab.

12.  Select your user account from the list then click the Change Permissions button.

13.  On the permissions page choose your account again then hit edit.

14.  Ensure full access is enabled to allow you to view, edit, and open any file in this folder.

15.  Copy the files you want to the new computer.

Solution2: It is possible that the current install of Windows has assigned a different user SSID (Service Set Identifier) to the installation to the one contained in the image. A clue to this will be that the folder reports itself as containing zero bytes. If this is the case, the folder can be accessed by changing the security descriptor of the folder. 

1. Right click on the folder that won't open and select properties.

2. Click on the Security tab and click on the Advanced button.

3. From the Permissions tab, highlight your user name in the list.

4. Ensure that there is a tick mark in the 'Include inheritable permissions' box.

5. Click on the Change Permissions button.

6. Make sure that your user name is still highlighted, there should be a tick in the box (at the bottom of the user list form) Include etc, also tick the 'Replace all child object permissions' and click on the OK button.

What should then happen is Windows should change the SSID of the folder, to users new SSID. Depending on how many files are in this folder it may take some time. When it has finished, users should then have access to the folder.

Solution3: If both of the solutions fail due to the read only nature of the file system on the mounted image, users may need to copy the folders from the original location to a writeable drive.

Solution4: Restore the whole image to a destination; the destination could be another place other than the original partition. Then, users can get access to the folder.

Solution5: The problem is due to Windows limitation. Users may use a file system driver which ignores windows permissions: http://www.hobeanu.com/accessgain/. The dev is not going to pay to have that signed, so it runs under 32 bit windows, and win7 32 pe and win7 64 bit pe.

For all the solutions, some have already been proved to work well by users while the others worth trying. Still, since users situations and computer configurations are unlike, the solutions which work to each user are different. Therefore, users should try them one by one till their problems solved.


Comments

  • Not allowed to change the permissions . Folders are mounted as read-only


  • I have used a number of other backup products, all of which handle this in a different (and better) way.  The issue seems to be that AOMEI Backupper mounts the volume as a read-only volume, which means that you CANNOT apply the permissions to the volume as you have detailed above - it is RO, not RW.  This is *NOT* a Windows limitation, but an AOMEI limitation due to mounting the volume RO.

    The best option to address this situation completely would be to allow the volume to be mounted RW instead of RO, and then on closing the volume offer to save changes or (default) to lose any changes to the volume.

Sign In or Register to comment.