Restoring a windows 10 image to a ssd drive didn’t work correctly

Hello to everybody,
this is my problem: I created a system image of windows 10 running on the internal hard disk of my laptop. 
Then I removed the dvd recorder drive and replaced with a ssd sata 3 hard drive through a specifc drive caddy. 
After that I did a “universal restore” of the previous image to this drive flagging the setting to optimize the restore for ssd. 
I did the restore 3 times and the problem were every time the same:
-sometime windows 10 didn’t run, remained stucked in the boot logo
- I wasn’t  able to restart it or shut it down, in the first case it got stuck in the restarting screen, in the second case the screen dimmed to balck but remained on
-I was’t able to install any software or driver

nothing of this problem occurred when I installed a fresh version of windows 10

what went wrong?
thank you for your help

Comments

  • edited September 2018
    You did not remove the original HDD? Try booting without the original HDD. 
    Otherwise you have two active boot drives at the same time. You can only have one. And  since the seconds is a copy of the first there can be a problem with letter assignment of partitions. Like C: could refer to both disks.

    But you can have 1 boot disk and 1 data disk. On that data disk you restore only the Windows partition of your backup and add that one to the boot menu (of the first disk). You can use free EasyBCD for that. This will give you a bootmenu in which you can choose the OS to start: The original on the HDD or the second on the DVD caddy SSD..
     
  • edited September 2018
    I did exactly as you wrote, now I am able to select which os to boot. The original os boots without problem but the restored one has the same problems as before, ( doesn't restart doesn’t switch off, doesn’t install anything) it does not even intall usb drives when I plug an external hard disk. I noticed that on this os the partition with the original windows 10 doesn’t apper in explorer. I can see it on disk management without volume letter to be assigned. I tried to assign a free letter again, both with disk managment interface and with diskpart  command but it doesn’t work ( whereas with diskpart it gets stuck in assignment process).
    after each firced restart the disk analyze tool runs before any os starts to boot 
    Are all this issues caused by a conflict letter or is there something else that needs to be changed?
    thank you again.  
  • edited September 2018
    A. But you were able to start the second OS? You said doesn't restart, so it does start?
    B. In both OS's you need to disable fast startup. See Control panel (control.exe) power options, power buttons.
    C. Did you restore only the Windows partition to the SSD as I suggested or did you restore the whole system?
    D. If you restore only the Windows partition again, Clean the SSD first with Diskpart thereby removing unwanted stuff.
    F. Then Add this partition to the boot menu..
    G. I understand correctly that the HDD contains the original OS and the SSD contains the restored copy of Windows. So two different drives? 
  • edited September 2018
    A. I confirm I’m not able to restart it or switching it off.  I only can switch it off  by pressing 5 second the power button

    B. I disabled, how you said, the fast start up option on both OS

    C.after reading your suggestion I restored again the system image. Aomei backupper asked me whether I wanted to carry out a system restore, I chose no and then I selected just the windows partition ( the bigger one). 

    D. I did not restore it again but I cleaned it with clean command in diskpart the first time. 

    F. as you said I added the partition with easybcd before answering you

    H. Yes you understood correctly, 2 different drives. 
    But I didn’t tell something that may be important:
    the iriginal OS has been as well restored from a universal backup made in Aomei in a virtual machine. 
    In the HDD works fine though...

    I: I was able eventually tu assign a letter to the original OS’s partition so now I see it on Explorer on the second OS ( the freaky one) but nothing changed afterwords

    I even tried to install the same version of windows upon it mantaining all programs and files but I wasn’t able to mount the iso image, an error message appered. 
     
  • Maybe you can replace the original hard drive with the ssd to see the result?
  • edited September 2018
    Done, same problem. 

    In turn I realized that the virtual machine system backup has never been restored anywhere before, this means that I got a little confused, The OS in the main hdd has been intalled from a installation DVD and the one restored in the ssd a windows 10 originally installed in virtual box only. They have very similar environment and led me into thinking they were the same. 

    Sorry for having given you incorrect information. 

    Now I installed again windows 10 in the ssd, now situated in the main hdd place, then installed some essential programs, made a system back up with aomei, restored it without system partition added a new line in bcdedit and it works perfectly. 

    The question  now is , can I still rely on the universal restore function that allows to migrate from virtual os to physical hard drive? This function was determining for me to buy amei backupper since I work a lot with virual machine. 

    My suspect is that the not working restored OS did’t have some crucial driver that would be automatically installed by a normal windows installation. This situation could have prevent the pc from installing anything later and caused the shut down and restart issues. 
    does it make sense?

Sign In or Register to comment.