AOMEI OneKey installer stops at the end of installation

We have a couple of Microsoft Surface Pro 3 with a fresh new Windows 10 - 64 bit installment on them, updated to latest version (1803). On some of these Surface tablets AOMEI stops right at the end, and Window puts up a warning box telling me that it "Could not start the programme correctly ( 0x0000142 ). Click OK to shut down the programme."
I guess that this is at the moment that the installer is about to end its installation of OneKey, it is in the final part of the installation process anyway.

The strange thing is that the installation is done on exactly the same image that is installed on the other Surface Pro 3 tablets, and on which AOMEI has managed to be installed and have successfully produced a recovery partition!

As I thought that it might be a hardware problem with the SSD I have run several disc diagnostic tools but they have found no problem with the SSD. The above problem has been present on four installments on four different Surface Pro 3 tablets, BUT running on exactly the same image that has been deployed on these machines. 

There is no third party virus or malware software installed that might interfere with the installation process, and, as said above, the AOMEI OneKey installer has been successful on the majority of our Surface tablets!

What to do about this?
Tagged:

Comments

  • Please open cmd and run the command below:
    for %1 in (%windir%system32*.dll) do regsvr32.exe /s %1
  • Thanks, admin!

    However, that did not work. 

    To sum up I have taken the following steps:

    1. In the final stage of the installation process of AOMEI OneKey Recovery programme (using the "OneKeyFree.exe" installer version 1.6.2.0), the programme halts and freezes after having created the desktop shortcut for OneKey Recovery 1.6.2 programme. The Cancel-button is greyed out/inactive, and I have to force-reboot Windows.

    2. Having restarted Windows, I try to start OneKey via the installed desktop shortcut "AOMEI OneKey Recovery 1.6.2", I am presented with the UAC dialogue, asking me if I will permit OneKey to make changes to my computer. (The software is located in the folder: C:\Program filer (x86)\AOMEI OneKey Recovery 1.6.2\OneKey.exe )

    3. Clicking "Yes" I am presented with an error window: (OneKey.exe - Program error - Could not start the programme correctly (0xC0000142). Click OK to shut down the programme") - So I click OK and the window goes away.

    4. I start Windows Command prompt  and type what you suggested:
    for %1 in (%windir%system32*.dll) do regsvr32.exe /s %1

    As a side note: Should not the proper command be:
    for %1 in (%windir%\system32\*.dll) do regsvr32.exe /s %1

    This runs through all dll:s and re-register them.

    Having finished this task, I try again, but can conclude that this did not change anything, and that the same error message popped up again stating that the programme could not start correctly and with the same error code (0xC0000142).

    What is the next step?

  • I have also tried to run the built-in "Compatibility Troubleshooter", and that makes the installer move passed the above point, BUT when it later restarts the computer and are booting into the BIOS phase (before loading Windows 10), it starts AOMEI OneKey, but suddenly ends and the computer reboots and continues to Windows 10 login without presenting the F11 key or the other choice to jump into the recovery partition. The strange thing is that this only happens on some of the laptops I have tried to install it on. So on 75% of the Surface tablets (same configuration), the installation was fine!
  • it starts AOMEI OneKey, but suddenly ends
    -You mean the PE starts, but suddenly ends?
  • No, the installer as described above.
  • So did it create the recovery partition successfully?
  • No. As I mentioned above, the installer starts, but just at the end, it stops. I think I have explained every step above. Thanks!
  • Maybe you could backup in PE directly? Try MakeDisc.exe in the installation directory.
  • I think we should focus on the fact that the installer does not work properly, and sometimes displays the message: "Could not start the programme correctly ( 0x0000142 )." at the end of the installation process of OneKey using the installer 1.6.2
  • I don't think this problem is caused by our program. As you said, the installer has been successful on the majority of your Surface tablets.
Sign In or Register to comment.