Folders on external hard drive have become corrupted after attempting to merge partitions.

My external hard drive (a 4 TB Seagate backup plus desktop drive) is split into two FAT32 partitions, each being about 2 TB. The other day I attempted to merge these partitions using AOMEI Partition Assistant. After some time, the merge failed so I cancelled the operation and unplugged my hard drive (and of course I also forgot to safely remove it). When I plugged the drive into my computer yesterday I noticed the issues.

The (F:) drive, (the partition I was merging the other partition into) was now showing up as having a capacity of only 185 GB with 184 GB used, which was significantly lower than the 2.18 TB I had the day before with about 1.9 TB being used. Certain data seems fine (including the entire other partition, (G:)) but there are quite a few folders containing large chunks of files I don't want to lose that, whenever I try to access, I get an error saying, "The file or directory is corrupted and unreadable."

I've tried to use the "chkdsk" command line in CMD but it fails because it says "The type of the file system is RAW". I've also tried using other free recovery software but it appears that the software are only finding data within that 185 GB capacity the drive claims to currently have, and nothing from the approximately 2 TB of storage that appears to have vanished.

I desperately want to be able to get the corrupted data back so any help/ advice would be greatly appreciated!


Comments

  • A Fat32 disk has a maximum capacity of 2TB. So merging two 2 TB to a 4TB disk could never be possible. Aomei should warn for that. Or am I missing something?

  • FAT32 is only limited to 2TB if the sector size is 512 bytes. If the sector size is 4096 bytes then the limit increases to 16TB. Source here https://en.wikipedia.org/wiki/File_Allocation_Table#FAT32. If in doubt use NTFS, not FAT32.

  • There was no warning, and one of my FAT32 partitions was over 2 TB anyways so I didn't think there would be an issue. My biggest concern at the moment is to try and get the missing data back.

  • Can you upload a screenshot of Disk Management?

Sign In or Register to comment.