Main Threads:Migrate HDD to SSD through ADI-Container
  • Hello,


    I recently tried to migrate my netbook HDD (~300 GB) with Windows 10 to a newer SSD (256 GB) using the free version of AOMEI Backupper.

    The HDD has 3 Partitions (System-reserved ~500 MB, BOOT ~297 GB, Recovery ~500 MB). The BOOT Partition, which contains the Windows System Folder etc., is only used with 95 GB. Therefore I hoped there would be no problem with migrating to a slightly smaller SSD.

    I tried this by removing the HDD from the netbook, docking it to my desktop-PC and using the 'Disk Backup' function to create a ADI-Container with my data. After that i attached the new SSD and used the restore function to write the image to it. I also checked the options 'fit all partitions to entire disk' and 'align partition to optimize for SSD'. So far it worked, I got 3 Partitions on my SSD (with slightly different sizes than before: System-reserved ~800MB).


    First thing I noticed was odd, is that the System-reserved Partition was automatically mounted by my Windows 10 machine with a drive letter and filesystem NTFS. 


    After removing it savely from my desktop-PC I reattached the SSD to my notebook and tried to boot. Unfortunately it will not boot. I get an error 0xc000000e. I tried to fix this by using 'bootrec' from a Win10-USB-Stick but after that i only got an error 0xc0000001. I do not really want to try to fix the drive after backup, I would rather prefer a solution working out of the box.


    Is there a solution to my problem? Did i do something wrong? I really appreciate your kind help, thanks in advance.


    Best regards


  • Has the new SSD the same partition style as the old HDD? GPT (for UEFI)  or MBR (for older BIOS systems) . That may be the reason it doesn't boot. 

  • Both use MBR (BIOS/UEFI boots in Legacy mode).

  • igordashaar,

    I don't think you did anything wrong. I recently performed the same operation and got the same results you did. I've run mulitiple restores to a spare SSD to test the restore function for SYSTEM and DISK restores. I only went as far as seeing if the restored drive would boot. I never examined the disk structure.

    A few weeks ago, I bought an upgraded and slightly larger (256 vs 250 GB) SSD to use as my OS drive. I could have used the clone function to move to the new disk but wanted to try a "real" DISK restore to see how it would work. After the restore, I found my 500mb recovery partition had been assigned a drive letter and was visible in File Manager. I contacted support and they said they knew about this "glitch" and had advised their engineers about it. They said I could remove the drive letter using Partition Asst. I did that but other things were screwed up so I decided to try again using a SYSTEM image. It worked fine but then I noticed the entire "recovery partition" was missing. After some digging through their HELP files, I found this is normal as AOMEI doesn't restore that partition to allow you to expand your OS if you want. It is not critical to keep the recovery partition as you can use a Windows recovery disk (if you created it) to get to the same functions. Or you can use the repair section of a Windows install ISO USB. I have the disk so I just left the drive the way it was and am now using the new drive without any further problems.

    With all that being said, after a year using AOMEI, I am losing faith in this product. I don't think it is as straight forward as it should be performing what should be "easy" functions. I would say this is a new product and they are still working out kinks, but being on V4 one would think basic functions would work as you think they should. 


  • Thanks! Good to know I am not the only one. After trying for multiple hours I decided to do a full system install without external backup software. Finished within 2 hours with complete software up and running. So far it was a nice experiment and i learned a bit about the "bootrec" command...

    The SYSTEM Backup only works from the current running system. Am I right?

  • A SYSTEM backup works for whatever you're using at the time of the backup. It will backup and restore all necessary partitions to make the drive bootable and usable to include the OS. If all your applications are on your C drive, they will still be there after a restore. If you have additional partitions on the drive, such as a separate one for data, it will NOT be copied. You need a DISK backup and restore for that. If you only have a C partition on your boot drive, you will get that back with a SYSTEM restore (minus the recovery partition as I found out).

    If you have a second HD (SSD) installed, say with partitions D: E: and F: and if you want to backup that drive, you would need to use a DISK backup for that. Since there would be no hidden partitions on that drive, it should backup and restore without any problems.

Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!