Home AOMEI Products Support

Exploring Image on NAS does not work

Dear Support-Team, dear all,

I just installed AOMEI Backupper Standard Edition 4.0.6 (German language) to test your product on a Win 7 PC. I would be happy to buy your tool, if I can get it to do what I need. I want to do my Backups to a NAS.

1) I was pleased with backing up the system and partitions to an ".afi" image on the NAS. (I still have to set up a test system to see if the recovery works properly with this configuration.) Only the File Backup ("Dateisicherung" in German) is quite slow as reported by some users - it takes a long time scanning "authority files", but I would still be happy to use your Backupper.

2) Unfortunately, I cannot explore the images. When choosing the option explore, by clicking on the drop-down menu attached to the image name in the home screen, Backupper is now successful in connecting to the NAS. (Somehow this did not work yesterday, but aborted with a timeout... just like the problem where the Backupper froze the first times when I tried to locate the directory for the backup on the NAS directly by browsing for a network drive instead of using the connect to NAS option...) Anyways, opening the image file from the NAS now seems to works. Also the image is mounted to a drive letter and the whole process is logged as being successful:

  "Ausführungszeit:    11.01.2018 22:35:14
  Name:    2018_01_10_Part_BKP_D
  Operation:    Image montieren                                                                    'mount image'
   Ausführungsergebnis:    Erfolgreich                                                           'successful'
   Fehlercode:    0                                                                                          'Error code: 0'
   Beschreibung:    Der Vorgang wurde erfolgreich abgeschlossen."

However, I cannot open the mounted drive in the Windows Explorer:


A screen-shot of the same message (from the web) in English:


(Sorry, for further testing I will install Backupper with English language configuration...)

3) Also when opening the "Tools->Explore Image" tool, I do not see the drive letter (when clicking on "back"), so I cannot unmount the image anymore and the drive letter stays visible in the Windows Explorer.

My hunch feeling is, that this is related to my previous problems. These were always centered around the fact that I have to log on to my NAS with a username and password. (The NAS username and password are also not identical to my Windows login and password.) Previously, this had caused Backupper to hang when using the "wrong" way to navigate to locations on the NAS in order to create an image...

Any suggestions are welcome!

With best regards and many thanks,



  • FYI:For another language you don't need to reinstall. Menu->Settings->Other->Language

  • Hi Robert, we believe it's a bug, please restore the backup image to access data.

  • Dear JohnnyboyGo, many thanks for the hint!

    Dear Admin,

    I setup a test sytsem with Win7 Enterprise + SP1 and AOMEI Backupper 30-day trial license on an old Laptop to look into the issue.

    Here, I did:

    - Backup the whole system to the NAS with AOMEI Backupper

    - Create a Recovery Disc with Backupper with the Win PE from that system

    - Wipe the whole disc (overwrite completely with zeros using the Ultimate  Boot CD)

    - Restart the Computer with the Rescue CD from Backupper

    - Restore the whole system from the NAS

    It all worked very well and went very quick - nice and smooth! :)

    Also, after the fresh install of Win 7 and Backupper on the test system I could connect to the NAS without any issues. Then also after starting up the Rescue Win PE system created with Backupper I could connect to the NAS without any issues and explore the image (mapping the immage to a drive letter and then using command shell to explore). However, after the system restore on the test system I had the same issues, where I could map the image to a drive letter, but could not explore the image!?! Then after restarting the test system several times sometimes I could connect to the NAS, sometimes not.

    Also, going back to my original Win 7 PC, where I currently use the free Backupper, I also created Rescue CDs:

    1) Using the Win PE from the original system, I could ping the NAS from the CMD, but could not connect to the NAS from Backupper.

    2) Downloading the Win PE system from your Website, I could connect to the NAS and map / explore the images. The only catch 22 was here, that the keyboard layout in your Win PE system is set to English, whereas I have a German keyboard. So initially I did not get my password right to connect to the NAS. Only after realizing the English keyboard layout, I got the Login to the NAS alright and then everything worked.

    Then trying to explore an image from my original system sometimes works (after restarting the system) and sometimes it does not... I have not found out yet, what the conditions are for success and failure...

    So in summary, there are the following lessons to be learned:

    - The problem with connecting to the NAS is a bit weird. I will have to keep looking into it! However, it is promising that it works sometimes.

    - It is highly advisable to test the rescue CD after having created one. If the Win PE from the original system does not work, one can try the Win PE that you supply on the internet. To see if the CD works one can try to explore the image or to do a backup to some USB drive (if you do not want to mess with your original system and do not have the time to setup a test system).

    - People using language settings other than English should be aware that depending on what Win PE system is used, keyboard layouts may have changed. So keep this in mind if you type passwords.

    - If connection to your NAS does not work, you could stil copy the image to an external USB drive and do the backup from there... (tools->import configuration... or browse directly to image on USB drive)

    I will now see, how this works on a Win 10 system. Also, I hope to find out, under which conditions the connection to the NAS works. :)

    Best regards,


  • edited January 2018

    Dear all,

    I got my Win 7 issues figured out!

    The problem with mapping the drive letter to an image on the NAS occurs, when one starts AOMEI Backupper from a non-admin account with 'Run as administrator' option. If I logon as Admin and start AOMEI Backupper within the admin account, all works fine!

    (That's why everything was working well, when I did real Admin work, like setting up the test machine. Whereas, when I only wanted to play around an check out some options of AOMEI Backupper, I logged on as a normal user and started Backupper with the 'Run as administrator' option and run into these issues.

    If you think about it, the problem makes sense. I mounted an image to a drive letter from within Backupper which was started using admin priviliges. Then I tried to access this drive as a user with non-admin privileges... Strange is only that the connected drives appeard in Windows Explorer, but did not show up in AOMEI Backupper. So to disconnect the drives I had to restart the computer...

    I also went back to the Rescue CD (Bootable Media) using the Win PE of my original system. It turned out that this one also had the English keyboard layout installed. So after taking that into accout when typing my password this CD worked fine as well!)

    So the lesson learned is, that full functionality of AOMEI Backupper can only be used, if it is used within an Admin account. The 'Run as administrator' option does not provide full functionallity and maybe should even be avoided. (Which - admittedly - I could have tought of!)

    And if you use the Rescue CD (Utlities->Create Bootable Media) and have a non English keyboard and you need to type a password, then first check which keyboard layout is loaded (just type some text with characters such as 'z' or language specific characters such as 'ö', 'ä', etc. to see if the layout fits your keyboard.)

    So there only remains the test with Win 10. All other issues are figured out now. :)



  • Dear all,

    also the tests on a Windows 10 System were successful. Creating a Backup, creating a rescue CD and Restoring all went fine. :) I was only surprised that the "Create UEFI bootable disc" option did not work, though this is a UEFI system. Instead the "Create legacy bootable disc" option worked fine... for whatever reason.

    Also connecting to the NAS was no problem (keeping in mind the keyboard layout).

    Thanks a lot for this great product and take care,


Sign In or Register to comment.