Main Threads:Need help reformating USB drive
  • I used AOMEI Partition Assistant to refromat a USB flash drive to NTFS from exFAT so I could back up some files and folders. After I reformated the flash drive and tried to use it I got a window that said the usb was corrupt. I'm hoping someone can help me reformat the flash drive. to NTFS.


    Not sure if this helps but here is what is showing on AOEMI Partition Assistant under Disk 3 removable

    G:  exFAT  125.00GB  640.00KB  125.00GB  Primary  None


  • Are you not able to just plug the hard drive into your windows, right click it, format, and format it that way?

  • I tried formating it that way first, I don't remember the exact error message but it was something like "windows wasn't able to format".

  • Can you see the stick in Diskpart?

    Open CMD.exe

    Diskpart

    list disk

    select disk #  (the USB stick

    Clean

    exit

    exit

    Then goto Disk management and initialize/format it.


  • I saw the USB stick in Diskpart>list disk but I didn't see how to clean it.

  • follow my commands shown above. If you saw it in list disk then:

    select disk #      (# is the USB stick)

    Clean               (this wipes the stick, making it as new)

    exit

    exit


  • It's listed as disk #2, (status) online, (Size) 125 GB, (Free) 0B. I enter Disk 2 after Diskpart>list and I see clean on the list but I don't see a way to select clean. Nothing happens when I click or move my mouse over it. 

  • You should type: "Select disk 2" press Enter and then type "Clean" press Enter. There is no selection. You probably saw a help screen because you only typed "disk 2"

  • That worked, says "succeeded in cleaning the disk". Now what?

  • After I cleaned the USB stick I tried to format it again and got the "windows wasn't able to format" error message again. Any suggestions?

  • Maybe it is broke/broken/kaputt. 

    Try formatting it in Diskpart. Google for instructions.

Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!