Home AOMEI Products Support

File/Folder syncronisation fails - Files in use

edited September 2016 in AOMEI Products Support


I'm trying to sync multiple folders from my computer with a externe USB device. Everything worked as it should during the first, second and third sync. Now I'm getting always a "Files in User" error while syncing. Even if i havn't start any programm and my system is completly fresh started.

System: Windows 10 x64 (anniversary update)

Program: Aomei Backupper v3.5

I'm not sure if it's maybe not working because the anniversary update or because i updated from v3.4 to v3.5. I recreated the sync task after the update (from aomei) and the first, second and third time every went well. Has someone any suggestions to fix this issue?

Greetings PPP


  • Please try to set another new syna task to see if you have the same problem, If yes, please tell us. And also we will test it.

  • Ok, i created a new task and deleted the old one. First sync and second sync went fine. We will see what will happend in a few days. This win10 update was to early for everyone...

  • Hello,

    after a few syncs the error is back again.

    Some more details:

        - It always occures while creating snapshots of the files

        - The files seems to be all located on the external USB device (which is the target)

        - Everytime different files are causing the error (pdfs, jpgs, docx, xls ...)

        - There are also files listed which have a "folder" icon or simple "file" icon but no name (more than 100)

        - Some of these folders have names i havn't used (chinese/japanese letters or letters which are normally not allowed for windows folders e.g ascii █ or utf ☐☐)

        - Some folder names / the folder structure is very "long" => these files seems to be listed more often in the files-in-use list; is there a limit of the length? (../../.../...)

        - I'm using german ÖÄÜ letters and blanks in may folder names

        - The first few syncs always went well

        - If I check the files with the program "Unlocker", it says that there are no active locks.

        - The USB device is using a exFat file system

    Greeting PPP

  • OK, we get it. Thanks for your feedback. We will test it and fix it in the next new version.

  • Problem still exists 5/12/2017

  • I also have this problem when backing up files (~60,000) from an internal drive to an (external) USB-drive. Similar setup as user PPP, but backup faills on every run with the error that a large number of files/folders (>1,000) with strange names I've never used.

    I've also tryed to create a new backup plan but the problem persists.

    As I'm not able to get sure that all is backed up properly, I don't trust the backup.

    Hope for your support,


  • August 12   /2017

    Hello Admin,

    i have the same problem with an exiernal USB drive . Can you fix it ?


  • @nullpointer @fouse Can you show me which files are occupied?

  • @admin:

    As I dont see how to export the list, I've made a screenshot: https://www.dropbox.com/s/vn4xjcifse4y90q/Capture.PNG?dl=0

    And the last log file:

    AOMEI Backupper 4.0.4 log is as follows:

    ====================== System Information ======================

    Module Path: C:\Program Files (x86)\AOMEI Backupper\ABCore.exe

    Product Name: Windows 10 Pro (6.2.9200.2)

    Service Package: 

    OS Version: 6.3

    Total Memory: 32696 MB

    Available Memory: 28336 MB

    System Root: C:\WINDOWS

    Processor Architecture: AMD64

    Processor Number: 16

    Current Time: 2017-8-12 16:39:53


    [0       ]vecParamLst.size()==2 return code: 0x00000000, helper.cpp(206).

    [0       ]BackupLogic.cpp(127): >>>>>>>>>>>>>>>>>>>>>> Start work thread >>>>>>>>>>>>>>>>>>>>>>>>>

    [2       ]::GetFileAttributesA(sCurPath) != INVALID_FILE_ATTRIBUTES return code: 0x00000000, NetworkMgr.cpp(254).

    [2250    ]dwErrCode==NO_ERROR return code: 0x00000000, helper.cpp(352).

    [2250    ]dwErrCode==NO_ERROR return code: 0x00000000, helper.cpp(352).

    [2250    ]dwErrCode==NO_ERROR return code: 0x00000000, helper.cpp(352).

    [2250    ]brwcs2wcs(pTmp, pPath, BufLength)>0 return code: 0x00000000, helper.cpp(346).

    [2       ]::GetFileAttributesA(sCurPath) != INVALID_FILE_ATTRIBUTES return code: 0x00000000, NetworkMgr.cpp(254).

    Backup Parameters:

    MediaType             = 0

    BackupType            = 0

    NetWriteSpeed         = 0

    EncryptLevel          = 1

    SplitFileSize         = 0

    NetWriteSpeed         = 0

    DependencyVer         = -1

    PasswordProtect       = 0

    IsCheckImgAfter       = 0

    IsNotBackupSub        = 0

    IsNotBackupHideFile   = 0

    IsNotbackupSystem     = 0

    TempFolder        = C:\Users\rbros\AppData\Local\Temp\

    ImgFilePath       = B:\BackUp\Files\My File Backup(1)\

    [ACLCheckBackupFolderHelper, Thread] 0

    [ACLCheckBackupFolderHelper, Thread] 0

    Create VSS successful!

    [BackupFolderCountHelper, Thread] 0



  • @nullpointer Please try to backup in Backupper WinPE to see if the error persists.

  • Same problem.  A small number of files in the "File Sync" folder on the USB show as in use.  They were created by Backupper and nothing else is accessing the USB until I attempted the next Sync.

  • Please use the latest version.

  • @PeterJ

    The latest version corrects the scrambled (chinese?) filesames, but the files are still marked as "in use". 

    I double ckecked those files, but they are not used by another program or system. I even tried to move thos files to another drive - which worked - but afterwards other files are marked as "in use".

  • @PeterJ

    I was able to track down the error to files/folders which are EFS encrypted. After decryption the backup of the same files worked as expected.

Sign In or Register to comment.