Home AOMEI Products Support

backup -> restore of simple win7 SSD fails

edited November 2015 in AOMEI Products Support

I have a seemingly trivial task: make a disk backup of a system drive (an SSD) and restore it to another one.

source disk: http://screencast.com/t/YaD8cdGBG

after restore: http://screencast.com/t/lXfU7oyWbE25

also, the disk isn't booting in an identical or even the same PC (0xc000000e error on startup).

the same with acronis is no problem at all. what I am doing wrong here?


  • Ok, this doesn't induce confidence into the program. a simple task I cannot reliable execute and no reaction from support.. :(

  • We feel very sorry for so late to reply you due to the weekend.

    And we have checked the sceenshot and found the reasons caused this issue.

    1.You system partition was encypted.

    2.The disk3 was a GPT disk,if you want to boot normally you need to set to boot by UEFI in BIOS or you can convert the GPT disk to MBR before you restore it.

    Hope these will help you,we apologize again for so late to reply.

  • And we also checked the Email adress and found that our mailbox did not received any mail from you,sorry for that problem.

  • thanks for coming back. I think we misunderstood. the whole process of backing up/restoring the disk (not the system!) happens on a PC which has indeed an encrypted system partition.

    but we want only to be able to backup the disk no 3 in it's entirety and restore it later for use in another PC (not the one wit the encrypted system disk).

    I just see, that the first screenshot is the wrong one. here again:

    source disk: http://screencast.com/t/ZLEeSnUt2

    after restore: http://screencast.com/t/lXfU7oyWbE25

  • We feel very sorry for that problem.

    Our Tech Team are trying their best to analyze the reasons and find out a way to fix it.

    At present you can use system CD or WIN PE tools to repair your system.

  • no, unfortuately, the system cannot be restored with system repair, we tried. 

    the problem is more of a realibilty nature. we wonder if this is a problem of the backup or the restore process. if it is the first, then we would be screwed if we would have depended on the backup. we would have potentially a lot of useless backups. (we are evaluating AOEMI backupper as alternative to acronis true image right now)

  • Maybe you can try to use PE Builder to create a bootable disk to boot your pc,then you can get into the Win PE environment.Under the PE environment you can use AOMEI Backupper to check if the backup image is integrated.If it is,you can restore it again under the Win PE environment.

  • ok, I will this give a try, but the PCs we prepare from the backups are off site and we need to wait until we get one back here.

    As an emergancy measurement this is ok, but our process is normally to prepare the disks before we get the PCs here. Then we just insert the new disk and send them back. I f we had to do the restore process with Win PE this would hinder the process considerably, so we really would like to see a solution here.

  • edited December 2015

    Disk 3 on screen shot 1 is MBR. Disk 3 on screen shot 2 is GPT. MBR-disks do not boot as GPT, the system-reserved partitions have different functionality. (That is, OS installs on MBR differently than OS installs on GPT, regarding system-reserved or system partitions.)

    Disk 3 on screen shot 2 is obviously a different disk, than Disk 3 on screen shot 1. By hazard Disk3 from screen shot2 happens to be GPT. And unfortunately you have to convert it to MBR yourself, this is not done by Backupper. It seems and as far as I tried. Use diskpart from the Windows shell command to convert to MBR. It seems.

    Additionaly, on GPT-disks; Windows is three partitions: WinRE, system, C:, and SHOULD contain WinRE, system, MSR, C:\   (MSR is unused and nothing bad happens when it is missing). On MBR-disks however, Windows is 1 or 2 partitions, just C:\, or boot partition and C:\. Your case is 2 partitions.

  • not sure what happened, but my comment from a week or so ago seems to have gone. it was along the lines, that you are right in your diagnosis, but the problem is, that what you see is the before and after cloning. so it is right that an MBR disk doesn't boot as a GPT disk, the question is, why a restore did result in a GPT disk instead of an MBR disk.

    but we tested a bit further: now we tried to restore another win7 PC but into a vmware guest according to this document.  http://www.backup-utility.com/universal-restore/migrate-os-to-virtual-machine-1234.html - this is basically the same procedure as admin suggested.

    but, again, the machne doesn't boot, this time it isn't even recognized as a bootable disk, the VM tries to boot from PXE (as a last resort when it doesn't find a bootable disk).


  • Why a restore did result in a GPT disk instead of an MBR disk.?

    because AOMEI backupper does not convert the disk style (altough it should, of course).

    And regarding vmware: The Virtual firmware has to be set to BIOS or EFI.

    And regarding vmware: the EFI virtual firmware has to know about the boot loader on the disk.  See here, altough it is for Fedora, and long.


    if  virtual firmware is BIOS, then the disc has to have an Active partition, it is the one that will be booted.

    And see here for using BCDBoot (a lot of useless advice, but also useful advice):  http://superuser.com/questions/460762/how-can-i-repair-the-windows-8-efi-bootloader

Sign In or Register to comment.