OneKey Windows 10 "Failed to initialize the Program" error

edited November 2015 in AOMEI Products Support

Great product that I have used on several of my 8.x computers.  Upgraded one from Win 7 -> Win 10 (6.2.9200.2).  Deleted existing recovery partition, installed ADK ( both 8.x and 10.x versions), and ran OneKey.  It completes the first phase and initiates a restart, briefly flashes the OneKey Loader, then gives the message:


    "Failed to initialize the program due to unknown reasons" ...


Looking at the disk partitions afterwards I see no recovery partition created.


The computer is 

    Lenovo IdeaCentre K330A, 

    AMD x64, 

    8GB ram, 

    DPKT15a 2/25/11 Bios


The full contents of all the logfiles can be seen at https://www.dropbox.com/s/3jlbbe06sjgoal7/OneKey151118.txt?dl=0


The log1.txt file contains the following errors


    diskinfo.h(451): Failed to init GPT style table.

    [2       ]dyndisk.cpp(213): Failed to RegQueryValueEx on GetSysDgGuid.

    [0       ]ldmio.cpp(89): No dynamic disks are found.


    BootQuickCfg.h(24): =========================CBootQuickCfg======================

    [0       ]BootQuickCfg.cpp(361): /////////////////////////////RemoveBootOption//////////////////////////////

    [0       ]BootQuickCfg.cpp(371): SystemVersion = 6

    [6       ]bootset.cpp(1249): Failed to get our option.

    [6       ]bootset.cpp(1250): C:\Program Files (x86)\AOMEI OneKey Recovery 1.2>C:\WINDOWS\system32\bcdedit.exe /enum /v



Any help/suggestions appreciated.





Comments

  • We feel very sorry for that problem.

    We are trying our best to work on this issue and we will fix it next version.

    Sorry for the current inconvenience.

    You can try to install Partition Assistant and run Onekey again to see if it works.

  • Thanks - I will wait for an update.

  • Just so you know you are not alone in this, I get the exact same issue with Windows 10.

  • I also have this exact same problem !

  • Failed on three PCs so far.  Two are AMD based & have had identical failures, as above. 


    The third PC, an Intel based machine, failed for an entirely different reason.


    So, I think that AMD based computers have this particular problem discussed in this thread.

  • I have the exact same problem with AOMEI OneKey Recovery 1.5 on Windows 10 Pro.

    Clean Install Windows 7 Ultimate upgraded to Windows 10 Pro. Legacy mode boot SSD. Is it still not resolved? It's kind of makingi this software useless, cause soon everyone are having Windows 10. Really like the program idea thou and would like to get it working.

  • Hyperion , thanks for your support.we will fix it ASAP.

    But, please chekc that whether is creates the recovery partition? 

    If it is yes, we have the solutions.

  • I'm having this problem as well. My laptop has Windows 10 installed on an SSD. My secondary HD is empty. I tried to install OneKey on my HD first as it was the recommended option. It created the AOMEI Recovery Partition. When it failed to initialize I tried it a second time and got the same result. I tried it a third time by manually selecting my SSD and it did not create the partition.

  • I'm having the same issue.  There was a recovery partition made and it has the "OneKey_PE.iso file in the partition but I still get the same error message.  Is there a fix for this yet?

  • @ImageTech Did you get the error after reboot your computer?

  • I am receiving the same error.  Did a fresh install of Windows 10 then installed AOMEI One Key Recovery 1.6, after installation I try and launch AOMEI One Key Recoery 1.6 and receie the same error.


    I get the error after reboot and no recovery partition has been created.  I have a 64 bit AMD processor.


    Any ETA on a fix for this yet, or any suggestions on possible workarounds/soutions?

  • @grits Please contact [email protected] for a temporary solution.

Sign In or Register to comment.