New version of Backupper refuses to install

I had a previous version of Backupper on my Windows 7 machine. I uninstalled it before trying to install the new version. As part of the uninstallation I restarted the computer as instructed. Next I tried to install the new version, but after the first screen or two of the setup it displays a message saying "Setup has detected a restart required to perform the uninstall. Please restart and try again." I restarted again...and again....and again. Every time I try to install the new version it gives me that same message and won't let me continue the installation. I have also tried re-installing the old (2012) version to see if that would work, but it gives me the same message.

What can I do?

Thanks in advance for any suggestion.

Comments

  • I’m sorry to hear that this problem happened in your computer. 

    It may occur that our uninstall procedure cannot start normally in your computer circumstance. 

    To solve this problem, you can directly delete the installation directory of AOMEI xxx and then delete its registry. 

    PA

    Steps: 1. Find and delete the installation directory of AOMEI xxx. 

    2.Go to Start, enter and run regedit. (Note: you should run it as Administrator) 

    3. Locate the following path: “HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Aomei Partition Assistant_is1”  “ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Aomei Partition Assistant_is1”

    and then delete this folder. 

    4. Finally, you can install the latest version. 

     

    AB:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\AOMEI Backupper

    Or

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\AOMEI Backupper

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ammntdrv

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\amwrtdrv

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ambakdrv

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f}

    delete these and the installation directory.

  • Thanks for the help. It finally allowed me to install it. After following your instructions it still said it "detected a restart required to perform the uninstall" at first. But then I searched for "AOMEI" and "Backupper" in regedit and deleted every folder or key that had one of those words. I kept searching until it found no more, and then the setup allowed me to install the new version.


    In case anyone else has the same problem and reads this in the future, if regedit says you can't delete one of those registry folders that were mentioned, you might have to manually edit the registry permissions to allow you to delete them. That's what I had to do, and I used the instructions at https://www.raymond.cc/blog/full-control-permission-to-delete-or-edit-restricted-windows-registry/2/

  • Thanks for the support you provided.

  • edited December 2017

    Hello,


    I have exactly the same problem: uninstalled Aomei Backupper free version 3.6 (I think), and when trying to install new free version 4.0.6 the installer refuses saying I should reboot, but after rebooting the installer always says the same.


    I've deleted the keys of AB in the registry (not only the specified above by admin message, but ALL, as user OneWhoBacksUp had told) but the problem persists.


    I've also deleted AomeiBR directory in c:\ProgramData\.


    Currently I have neither Aomei directories nor Aomei registry keys (hadn't installed other Aomei products) in my Windows 7 but the installer still refuses to install the last Backupper.


    Any ideas please? Thanks in advance.


  • @mrband ; Please use a registry clearer to clean the registry information and then install Backupper again to see if it works.

  • I have the same problem, none of the suggestions helped. Wasted a ton of time on this. And no, don't bother to help me. You are delusional if you think I will continue to use your program after this debacle. We're talking about BACKUP, people. Yeah... no, thanks.

  • edited July 27
    I have the same problem; OS is Windows 7 Professional.
    I tried to upgrade from the earlier release and ran the installer for V. 4.1.0
    The installer detected the earlier release. I expected it would prompt me to update, but it offered to uninstall.
    At this point I quit and uninstalled the earlier version using Revo Uninstaller - just a habit.
    Apparently this was a mistake. I tried everything and followed the suggestions in this thread.
    After doing some cleanup I see no folders or registry entries related to Aomei, but the new installer keeps saying "restart is required to perform uninstall"
    I definitely understand how Uneasy (see above) felt about this problem.  Any recommendations?
  • @Mike64 Can we arrange a screen share to better analyze the problem?
  • @Admin ; Sorry, it took me so long to come back.
    The problem went away. I did not do anything else since my last post on July 27, but last week I tried again and this time the installation went through very smoothly.  And I created my first backup.
    Thinking about it, what happened since I had this problem: 
    1) The PC was restarted couple times. This probably does not matter, because it was rebooted few times when I was getting message "restart is required to perform uninstall"
    2) I may have run Junk File Cleanup in Revo Uninstaller. It does not seem like a plausible explanation, unless there was some temp file left somewhere outside of  C:\Program Files (x86) and C:\ProgramData
     
    In any case, everything is fine now. Thank you for your help!
    Mike.
Sign In or Register to comment.